Проблемы
При попытке открыть страницу Настройки управления заказами на портале Business Portal в Microsoft Dynamics GP 10.0 или в Microsoft Dynamics GP 9.0 вы получаете следующее сообщение об ошибке:
Ошибка сервера в окне "/" Доступ приложения к пути
"c:\inetpub\wwwroot\bin\~privatefile.dbauthentication.config" отклонена. Сведения об исключении: ASP.NET не имеет права
на доступ к запрашиваемом ресурсу. Можно предоставить ресурсу права доступа к ASP.NET запроса. ASP.NET имеется базовое удостоверение процесса, которое используется, если приложение не выдвигает себя от себя. Если приложение выдает себя за <удостоверения imprersonate="true"/>, удостоверением будет анонимный пользователь или авторификация пользователя.
Причина
Эта проблема возникает, поскольку GPReg.dll отсутствует или не зарегистрирован.
Решение
Чтобы устранить эту неполадку, выполните следующие действия:
-
УбедитесьGPReg.dll что файл находится в папке корзины корневого каталога веб-сайта, который вы использовали для установки бизнес-портала.
Примечание. По умолчанию папка корзины находится в следующем расположении:C:\Inetpub\wwwroot\bin
-
Зарегистрируйте файл GPReg.dll вручную. Это можно сделать одним из описанных ниже способов.
-
Воспользуйтесь командной командой:
-
Выберите в меню Пуск пункт Выполнить, введите в поле Открыть команду cmd и нажмите кнопку ОК.
-
Измените каталог, содержащий файл GPReg.dll файла.
Примечание. Чтобы изменить расположение по умолчанию, введите CD inetpub\wwwroot\bin в командной подсказке и нажмите ввод. -
В командной области введите Regsvr32 GPReg.dll и нажмите ввод.
-
-
Используйте обозреватель microsoft Windows:
-
Щелкните правой кнопкой мыши кнопкуНачните и выберите Начните изучение.
-
Найдите и щелкните правой кнопкой мыши нужный GPReg.dll, выберите пункт Открыть с помощью, а затем щелкните Выбрать программу.
-
В диалоговом окне Открыть с нажмите кнопку Обзор.
-
В списке Папка выберите папку C:\Windows\System32, щелкните файлRegsvr32.exeи нажмите кнопку Открыть.
-
-
Дополнительная информация
Действия по воспроизведению проблемы
-
На бизнес-портале щелкните Сайт Параметры, выберите Параметрыприложения , а затем — Настройка управления заказами.
-
Если вам будет предложено ввести имя пользователя и пароль, введите имя пользователя и пароль.
-
Нажмите кнопку ОК.