Добавление соединительных линий между фигурами Visio

Применяется к
Visio, план 1 Visio профессиональный 2024 Visio стандартный 2024 Visio профессиональный 2021 Visio стандартный 2021 Visio профессиональный 2016 Visio стандартный 2016

В Visio есть очень удобные инструменты для соединения фигур в документе.

В приложении предусмотрена функция автосоединения, с помощью которой фигуры можно соединять прямо при добавлении, а также доступен инструмент "Соединительная линия" для соединения ранее добавленных фигур. Кроме того, вы можете изменять фигуры, которые отображаются на мини-панели инструментов, а также включать и отключать автосоединение.

Автоматическое соединение фигуры

Соединение фигур на странице

Соединение с фигурой на другой странице

Настройка внешнего вида соединительных линий с помощью тем

Использование других фигур соединительных линий

Изменение фигур на мини-панели инструментов "Автосоединение"

Включение и отключение автосоединения

Автоматическое соединение фигуры

Один из способов соединения фигур состоит в том, чтобы позволить Visio автоматически создавать соединители при добавлении фигур на страницу. Это особенно удобно при создании блок-схем.

  1. Включите функцию автосоединения. Для этого на вкладке Вид в группе Визуальные подсказки установите флажок Автосоединение.

  2. Перетащите фигуру из области Фигуры на страницу.

  3. Наведите указатель мыши на исходную фигуру и удерживайте его, пока вокруг фигуры не появятся стрелки автосоединения.

    Снимок экрана: активная функция автосоединения. Наведите указатель мыши на фигуру, чтобы отобразить стрелки.

  4. Наведите указатель мыши на стрелку, указывающую в том направлении, в котором требуется добавить фигуру.

    Снимок экрана: при наведении указателя мыши на стрелку автосоединения отображается панель с вариантами фигур для добавления.

    Появится мини-панель инструментов с первыми четырьмя экспресс-фигурами, доступными в наборе элементов Экспресс-фигуры. Если навести указатель мыши на фигуру на этой панели инструментов, будет показано предварительное расположение новой фигуры на странице.

  5. Выберите фигуру, которую вы хотите добавить.

  6. Если вы хотите продолжить добавление фигур, наведите указатель мыши на стрелку автосоединения рядом с новой фигурой и повторите действия.

    Снимок экрана: при наведении указателя мыши на вставленную фигуру отображаются стрелки автосоединения для добавления других объектов.

К началу страницы

Соединение фигур на странице

Совет.

Команды в группе Инструменты на вкладке Главная позволяют переводить Visio в различные состояния и режимы, что иногда вызывает сложности. Используйте клавиатуру для удобного переключения между инструментами "Указатель", " (нажмите CTRL+1) и "Изображение кнопки соединителя" (нажмите CTRL+3). Независимо от того, какой инструмент вы используете, например Блок текста или Точка соединения, несколько раз нажмите клавишу ESC, чтобы вернуться к инструменту Указатель.

  1. На вкладке "Главная" в группе "Инструменты" выберите изображение кнопкисоединителя или нажмите клавиши CTRL+3.
  2. Выделите фигуру и перетащите соединительную линию на другую фигуру.
  3. Когда все будет готово, выберите инструмент "Указатель", " на вкладке "Главная" в группе "Инструменты" или нажмите клавиши CTRL+1.

Отображение или скрытие анимации

Снимок экрана: соединительная линия соединяется с фигурами с помощью соединения точек на концах.

Кроме того, можно добавить на ленту команду Соединить фигуры, которая позволяет соединить несколько фигур в порядке их выбора.

Снимок экрана: видео соединения фигур

Совет

Чтобы добавить на ленту полезные команды, которых на ней нет, выберите"Параметры>файла>""Настройка ленты".

К началу страницы

Соединение с фигурой на другой странице

Вы можете использовать соединительные линии только между фигурами на одной странице. Чтобы добавить соединение с фигурой на другой странице, используйте фигуру Ссылка на другую страницу (для создания гиперссылки с одной страницы на другую) или добавьте гиперссылку и действие по двойному щелчку для любой фигуры (чтобы обеспечить переход на другую страницу того же документа).

Использование ссылки на другую страницу

  1. Откройте набор элементов "Фигуры простой блок-схемы " и перетащите фигуру "Ссылка на другую страницу " на текущую страницу.

    Снимок экрана: фигура

  2. В диалоговом окне "Ссылка на другую страницу " нажмите кнопку " ОК", чтобы добавить фигуру на текущую и на только что созданную страницу.

  3. На новой странице продолжайте создавать свою схему.

  4. Чтобы изменить внешний вид фигуры Ссылка на другую страницу, щелкните ее правой кнопкой мыши и выберите пункт Исходящая, Входящая, Круг или Стрелка.

Для перемещения между страницами дважды щелкните фигуру "Ссылка на другую страницу " на любой из страниц. Дополнительные сведения см. в статье Диалоговое окно "Ссылка на другую страницу".

  1. Щелкните фигуру правой кнопкой мыши и выберите "Гиперссылка" или выделите фигуру и нажмите клавиши CTRL+K*.

  2. Нажмите кнопку "Обзор" рядом с полем "Субадрес", а затем выберите в раскрывающемся списке рядом с пунктом "Страница" нужную страницу.

    Снимок экрана: диалоговое окно

    Примечание

    Для гиперссылки можно также задать имя фигуры на странице назначения. На вкладке "Разработчик" выберите "Имя фигуры" или используйте имя по умолчанию в поле "Имя" или измените его, а затем нажмите кнопку "ОК".

    Пользователям может потребоваться включить вкладку "Разработчик", прежде чем они будут следовать инструкциям по имени фигуры и ее поведению.

  3. Чтобы настроить для фигуры действие по двойному щелчку, на вкладке "Разработчик " нажмите кнопку "Поведение".

  4. Откройте вкладку "Двойной щелчок ", выберите параметр "Перейти к странице ", а затем выберите в раскрывающемся списке нужную страницу.

    Снимок экрана, показывающий действие Double-Click Visio

    Примечание

    Эту операцию следует выполнять только после изменения имен страниц, так как они не обновляются автоматически.

К началу страницы

Настройка внешнего вида соединительных линий с помощью тем

По умолчанию соединители выглядят как обычные линии, но с помощью тем к ним можно применить оформление, например наконечники стрелок. Встроенные темы можно найти в коллекции "Темы " на вкладке " Дизайн ". Сведения об изменении атрибутов соединительной линии, таких как стиль, цвет, толщина и т. д., см. в статье Изменение фигур соединительных линий.

Отображение или скрытие анимации

Снимок экрана: скрытые эффекты анимации

Примечание

Чтобы просмотреть другие варианты оформления, откройте вкладку " Конструктор ". В группе "Варианты " щелкните стрелку раскрывающегося списка и выберите "Соединители". Снимок экрана: скрытые эффекты анимации-1

Использование других фигур соединительных линий

Любые фигуры соединителей, например те, что доступны в наборе элементов " Дополнительные фигуры>Visio Extras>Connectors", можно использовать для соединения фигур вместо стандартной динамической соединительной линии . Их можно перетащить на страницу или выбрать в инструментах Соединитель и Соединить фигуры. Кроме того, ими можно заменить уже имеющиеся соединители.

  1. Откройте набор элементов с нужными фигурами.
  2. Выберите на странице соединительные линии, которые вы хотите заменить.
  3. На вкладке " Главная " в группе "Редактирование " нажмите кнопку "Изменить фигуру", а затем выберите нужную фигуру соединительной линии.

Отображение или скрытие анимации

Снимок экрана: скрытая анимация изменения фигуры

Примечание

Функция Изменить фигуру впервые появилась в Visio 2013, тогда как инструменты Соединительная линия и Соединить фигуры существовали еще до Visio 2007.

К началу страницы

Изменение фигур на мини-панели инструментов "Автосоединение"

Фигуры на мини-панели инструментов берутся из набора Экспресс-фигуры для схемы. На мини-панели инструментов отображается до четырех фигур. Вы можете настраивать фигуры, которые отображаются на мини-панели инструментов. В следующей процедуре в качестве примера используется Простая диаграмма.

  1. По умолчанию фигурами на мини-панели инструментов являются первые четыре фигуры из набора, который расположен сразу после набора Экспресс-фигуры. Например, ниже показаны первые 4 фигуры в наборе Простые фигуры.

    Снимок экрана: мини-панель инструментов с основными фигурами по умолчанию

  2. Чтобы отобразить другие фигуры на мини-панели инструментов для конкретного набора, вы можете перетащить их вверх списка набора. Например, вы можете перетащить фигуры Четырехконечная звезда, Пятиконечная звезда, Шестиконечная звезда и Семиконечная звезда вверх списка набора Простые фигуры.

    Снимок экрана: мини-панель инструментов с новыми основными фигурами

  3. Кроме того, вы можете изменить порядок наборов, перетаскивая их в верхнюю или нижнюю часть области "Фигуры". Подмножество этих фигур отображается в наборе "Экспресс-фигуры" в том же порядке, что они располагаются в области "Фигуры". Например, если перетащить набор Декоративные фигуры так, чтобы она располагался сразу после набора Экспресс-фигуры на панели Фигуры, порядок фигур в наборе Экспресс-фигуры изменится.

    Снимок экрана: мини-панель инструментов с новым набором вследствие изменения порядка

    Примечание

    Когда вы закрываете и повторно открываете схему, в области "Фигуры" автоматически восстанавливается порядок по умолчанию, что отражается на расположении фигур в наборе "Экспресс-фигуры".

  4. Чтобы использовать другой набор для мини-панели инструментов в качестве исходного, в наборе Экспресс-фигуры выберите фигуру из подмножества фигур необходимого набора. Например, выберите Диаграмма Венна в наборе График и математические фигуры.

    Снимок экрана: мини-панель инструментов с новым набором вследствие выбора

Совет

Чтобы вернуться к стандартной последовательности фигур в наборе, в области Фигуры щелкните имя набора правой кнопкой мыши и выберите пункт Восстановить набор элементов.

Примечание

Не во всех наборах есть фигуры, которые можно использовать на мини-панели инструментов. Например, фигуры в наборе Стрелки не отображаются на мини-панели инструментов.

К началу страницы

Включение и отключение автосоединения

Автосоединение — это параметр на уровне файла. Если вы включите этот параметр, он остается включенным для текущего файла, но если вы работаете с другим файлом, вам потребуется снова его включить. Для определенных шаблонов параметр включен по умолчанию. 

Включение и отключение автосоединения для активной схемы

  • На вкладке Вид в группе Визуальные подсказки установите или снимите флажок Автосоединение.

    Снимок экрана: установка или снятие флажка автосоединения на вкладке

Если параметр автосоединения затенен, вы можете исправить это, перейдя в параметры файла>Дополнительныепараметры> и выбрав Включить автосоединение:

Активация и деактивация автосоединения

  1. Откройте вкладку "Файл " и выберите "Параметры".

  2. В параметрах Visio выберите "Дополнительно".

  3. Чтобы включить автосоединение, в разделе Параметры правки установите флажок Разрешить автосоединение. Или снимите этот флажок, чтобы деактивировать автосоединение.

    Снимок экрана: установка или снятие флажка

  4. Нажмите кнопку ОК.

К началу страницы

См. также

Изменение соединительных линий, стрелок и точек

Добавление и изменение текста соединителя

Создание пользовательской соединительной линии

Включение и выключение приклеивания

Все, что нужно знать о соединителях в классической версии Visio

Обучение работе с Visio