Перейти к основному контенту
Поддержка
Войдите с помощью учетной записи Майкрософт
Войдите или создайте учетную запись.
Здравствуйте,
Выберите другую учетную запись.
У вас несколько учетных записей
Выберите учетную запись, с помощью которой нужно войти.

Важноперед запуском этого Исправления сохраните данные и закройте приложение. После запуска Исправления компьютер перезагрузится через 10 минут.

Проблема

На компьютере, который работает под управлением Windows XP, Windows Vista или Windows 7, некоторые значки в следующих местах случайным образом изменяются на другие значки:

  • Мой компьютер

  • Проводник

  • Рабочий стол

  • Панель быстрого запуска

Причина

Эта проблема возникает из-за неправильного обновления кэша значков.

Решение

Чтобы устранить проблему, первым шагом является вход в другую учетную запись пользователя с правами администратора. Для этого сделайте следующее.

  1. Выйдите из текущей учетной записи пользователя, которая сталкивается с изменениями значков.

  2. Войдите в систему в качестве пользователя с правами администратора.

Обратите внимание, чтофайл должен быть удален другим пользователем, поскольку в процессе записи регистра файл IconCache.db может быть перезаписан с поврежденными данными значка.

Внимание! В этом разделе, описании метода или задачи содержатся сведения об изменении реестра. Однако их неправильное изменение может привести к возникновению серьезных проблем, Поэтому следует точно выполнять следующие инструкции. В качестве дополнительной защитной меры перед изменением реестра необходимо создать его резервную копию. Это позволит восстановить реестр при возникновении проблем. Дополнительные сведения о создании резервной копии и восстановлении реестра см. в следующей статье базы знаний Майкрософт:

322756 Как создать резервную копию и восстановить реестр в Windows

Поэтому, для решения данной проблемы нужно выполнить следующие шаги.

  1. Если отображается диалоговое окно Закройте открытые программы взаимодействия, закройте все открытые окна.

  2. Создайте раздел реестра Максимальный кэш значков, а затем установите значение этого раздела на 2048. Для этого сделайте следующее.

    1. Нажмите кнопку Пуск, в поле Поиск введите regedit и выберите пункт regedit в списке программ.

    2. Найдите и выберите следующий раздел реестра:

      HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer

    3. В меню Правка выберите пунктСоздать, а затем — Строковый параметр.

    4. Введите MaxCachedIcons в качестве имени раздела реестра и нажмите клавишу ВВОД.

    5. Дважды щелкните раздел реестра Max Cached Icons, введите 2048 в поле Значение, а затем нажмите OK.

    6. Закройте редактор реестра.

  3. Удалите IconCache.db из следующего местоположения, в зависимости от операционной системы.

    Windows XP

    C:\Documents and Settings\<User Name>\Local Settings\Application Data

    Windows Vista или Windows 7

    C:\Пользователи\<Имя пользователя>\AppData\LocalПримечание <Имя пользователся> это поле для имени учетной записи пользователя, которая сталкивается с изменением значка.

Дополнительная информация

Устранение проблемы с помощью пакета MATS

  1. Пакет MATS сканирует ваш компьютер и затем определяет, какая ОС на нем используется: Windows XP, Windows Vista или Windows 7.

  2. Пакет MATS проверяет, имеется ли в соответствующих подразделах параметр реестра Max Cached Icons. Если параметра Max Cached Icons не существует, он создается и ему присваивается значение, равное 2048. Если ключ Max Cached Icons существует, ему присваивается значение, равное 2048.

    Примечание. При выполнении этой процедуры отображается диалоговое окно. Оно позволяет выбрать способ устранения проблемы: автоматически (рекомендуется) или вручную указать проблему, которую требуется исправить. При выборе проблем для устранения вручную в диалоговом окне можно указать один из двух вариантов: Настройка значков и папок или Другое или неизвестно.

  3. Пакет MATS проверяет, удачно ли удален файл IconCache.db.

Другие проблемы, устраняемые пакетом MATS

2394521Не удается очистить корзину в Windows XP или Windows Vista

949109 Ошибка "Файл или папка не существует" в Windows Vista

934160 "Разрешение сети или файла" или ошибка "Папки не существует"

2394740 Не удается выбрать несколько элементов после обновления с Windows XP до Windows Vista

813711 Теряются изменения размера, вида, значка или положения папки

Нужна дополнительная помощь?

Нужны дополнительные параметры?

Изучите преимущества подписки, просмотрите учебные курсы, узнайте, как защитить свое устройство и т. д.

В сообществах можно задавать вопросы и отвечать на них, отправлять отзывы и консультироваться с экспертами разных профилей.

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?
После нажатия кнопки "Отправить" ваш отзыв будет использован для улучшения продуктов и служб Майкрософт. Эти данные будут доступны для сбора ИТ-администратору. Заявление о конфиденциальности.

Спасибо за ваш отзыв!

×