Chyba runtime 3043: Chyba disku alebo siete

Príznaky

Chyba runtime 3043: Chyba disku alebo siete.

Táto chyba sa môže vyskytnúť pri spúšťaní aplikácie FRx Designer, vytváraní indexu alebo vytváraní zostavy.

Príčina

Túto chybu môže spôsobovať jedna alebo viacero z nasledujúcich príčin:

  • Neplatná cesta pracovnej jednotky, cesta importu/exportu alebo výstupná cesta.
  • Nedostatočné povolenia pre sieťový adresár alebo zdroj.
  • Sieťový zdroj, ktorý nie je k dispozícii.

Riešenie

Ak nie je možné otvoriť FRx Designer

  1. Kliknite na tlačidlo Štart a potom na položku Spustiť. Zadajte frx.ini a potom kliknite na tlačidlo OK.
  2. Vyhľadajte riadok LastCompany=. Ak tento riadok obsahuje hodnotu za znamienkom rovnosti, odstráňte text, ktorý nasleduje za znamienkom rovná sa iba v tomto riadku, a potom súbor uložte a zatvorte ho.
  3. Spustenie aplikácie FRx Designer – ak sa okno výberu spoločnosti zobrazí ešte pred prijatím chyby, prejdite v tomto článku na časť "Vyhľadanie potrebných ciest vo FRx". V opačnom prípade pokračujte krokom 4.
  4. Znova otvorte súbor frx.ini. Vyhľadajte riadok WorkDrive= a poznačte si cestu uvedenú za znamienkom rovná sa. Toto je pracovná cesta jednotky.
  5. Prejdite na časť "Kroky na riešenie" v tomto článku.

Vyhľadanie potrebných ciest v rámci FRx

  1. Ak sa zobrazí výzva na výber spoločnosti, kliknite na tlačidlo Zrušiť.
  2. V ponuke Spravovanie kliknite na položku Možnosti spracovania.
  3. Poznačte si cestu uvedenú v poli voliteľnej pracovnej jednotky – toto je pracovná cesta jednotky. Kliknutím na tlačidlo Zrušiť zatvorte okno Možnosti spracovania.
  4. V ponuke Spoločnosť kliknite na položku Informácie.
  5. Poznačte si cestu uvedenú v poli cesty importu alebo exportu – toto je cesta importu alebo exportu. Kliknutím na položku Zavrieť zatvorte okno s informáciami o spoločnosti.
  6. Ak sa chyba vyskytne pri generovaní zostavy, otvorte katalóg pre problematickú zostavu.
  7. Kliknite na kartu Výstup. Ak je v poli Názov súboru uvedená úplná cesta, poznačte si ju – toto je výstupná cesta. Ak je uvedený iba názov súboru, výstupná cesta a cesta importu/exportu sú rovnaké. Zavrite katalóg.

Kroky na riešenie problému

  1. Ak sa jedna alebo viaceré z vyššie uvedených ciest nachádzajú na sieťovom serveri, overte, či server funguje bez chýb.
  2. Ak sa jedna alebo viaceré z vyššie uvedených ciest nachádzajú na sieťovom serveri, overte, či je server dostupný z počítača, v ktorom sa zobrazuje chyba.
  3. Overte, či je pracovná cesta jednotky platná a správna. Ak nie je, cestu aktualizujte. Túto cestu možno aktualizovať v okne Možnosti spracovania alebo úpravou súboru frx.ini (umiestnenie týchto ciest nájdete v časti Vyhľadanie potrebných ciest vo FRx).
  4. Overte, či sú cesta importu/exportu a výstupná cesta platné a správne. Ak sú niektoré z týchto ciest neplatné alebo nesprávne, aktualizujte ich príslušným spôsobom (umiestnenie týchto ciest nájdete v časti Vyhľadanie potrebných ciest vo FRx vyššie).
  5. Zopakujte úlohu, ktorá spôsobila chybu predtým. Ak sa chyba už nevyskytuje, vynechajte všetky zostávajúce kroky. V opačnom prípade pokračujte krokom 6.
  6. Prihláste sa do problematického počítača pomocou konta, ktoré má v doméne oprávnenia správcu.
  7. Zopakujte úlohu, ktorá predtým spôsobila chybu. Ak sa chyba už nevyskytuje, pokračujte krokom 8. V opačnom prípade prejdite na krok 9.
  8. Odhláste sa zo zariadenia a potom sa znova prihláste ako používateľ. Ak sa chyba zobrazuje aj naďalej, používateľ nemá dostatočné povolenia pre jednu alebo viaceré z uvedených ciest. Skontrolujte povolenia pre každý adresár a v prípade potreby povolenia udeľte. Používatelia musia mať povolenia na čítanie, číta& nie, vykonávanie, zápis a úpravu pre každú z vyššie uvedených ciest. Po udelení potrebných povolení by sa chyba používateľovi už nemala zobrazovať.
  9. Ak chyba pretrváva, je pravdepodobne potrebné reštartovať server. Čo najskôr reštartujte server.

Odkazy