Príznaky
V programe Microsoft Outlook 2016 pre Mac alebo Office pre Mac 2011 sa pri pokuse o vyhľadanie e-mailovej správy alebo použitie filtra na priečinok zobrazí hlásenie Žiadne výsledky a položky úloh sa v priečinku Úlohy nezobrazia. Okrem toho, keď hľadáte položky pošty pomocou natívneho vyhľadávania Spotlight pre Mac OS, vyhľadávanie je neúspešné.
Príčina
Tento problém sa môže vyskytnúť pre niektorú z nasledujúcich príčin:
Microsoft Outlook 2016 pre Mac:
- Indexovanie vyhľadávania v Spotlighte je neúplné.
- Názov profilu obsahuje špeciálne znaky, ako napríklad lomku (/).
- Profil alebo niektorý z jeho nadradených priečinkov sa pridá na kartu Ochrana osobných údajov v Spotlighte.
- Priečinok Profily Outlooku 15 sa nenachádza v umiestnení ~/Library/Group Containers/UBF8T346G9. Office/Outlook.
- Index vyhľadávania v Spotlighte je poškodený.
Microsoft Outlook pre Mac 2011:
- Indexovanie vyhľadávania v Spotlighte je neúplné.
- Názov identity obsahuje špeciálne znaky, ako napríklad lomku (/).
- Identita alebo niektorý z jej nadradených priečinkov sa pridá na kartu Ochrana osobných údajov v Spotlighte.
- Priečinok Microsoft User Data sa nenachádza v priečinku ~/Dokumenty.
- Index vyhľadávania v Spotlighte je poškodený.
Riešenie
Pri riešení tohto problému postupujte nasledovne:
Spustite pomôcku OutlookSearchRepair .
Ak ste nedávno vytvorili nový outlookový profil v Outlooku 2016 pre Mac alebo novú identitu v Outlooku pre Mac 2011, pridali nové konto alebo ak ste nedávno importovali nové údaje zo zdroja, akým je napríklad súbor PST alebo OLM, indexovanie v Spotlighte nemusí byť dokončené. V takomto prípade Outlook pre Mac zobrazí hlásenie Žiadne výsledky. Ak chcete tento problém vyriešiť, počkajte na dokončenie indexovania a potom vyhľadávajte znova.
Skontrolujte, či názov profilu v Outlooku 2016 pre Mac alebo meno identity v Outlooku pre Mac 2011 neobsahuje špeciálne znaky, ako je napríklad lomka (/).
Ak chcete zobraziť svoj profil alebo meno identity:
Outlook 2016 pre Mac:- Kliknite na položku Spustiť, Aplikácie.
- Right-Click Microsoft Outlooku a vyberte položku Zobraziť obsah balíka.
- Rozbaľte obsah, zdieľanú podporu a otvorte Správcu profilov Outlooku.
PoznámkaPre správcu profilov Outlooku môžete vytvoriť alias a ak chcete, môžete ho presunúť na pracovnú plochu alebo na iné vhodné miesto.
Outlook pre Mac 2011:
Ak chcete zobraziť mená identít v pomôcke Microsoft Database Utility, podržte stlačený kláves Option a potom kliknite na ikonu Outlook pre Mac 2011.
Ak názov profilu alebo identity obsahuje špeciálny znak, zmeňte ho takto:
Otvorte priečinok Profil v Outlooku 2016 pre Mac alebo priečinok Identita v Outlooku pre Mac 2011.
V Outlooku 2016 pre Mac je umiestnenie:
/Users/<Username>/Library/Group Containers/UBF8T346G9. Profily Office/Outlook/Outlook 15/V Outlooku pre Mac 2011 je umiestnenie:
Používatelia/<Meno> používateľa/Dokumenty/Používateľské údaje Microsoft/Identity v Office 2011/Premenujte názov priečinka profilu v Outlooku 2016 pre Mac alebo názov priečinka identity v programe Outlook pre Mac 2011, ktorý obsahuje špeciálne znaky, odstránením špeciálnych znakov.
V závislosti od vašej verzie programu Outlook pre Mac potvrďte, že sa názov profilu alebo identity zmenil, a zobrazte ho nasledujúcim spôsobom:
V Outlooku 2016 pre Mac:
- Kliknite na položku Spustiť, Aplikácie.
- Right-Click Microsoft Outlooku a vyberte položku Zobraziť obsah balíka.
- Rozbaľte obsah, zdieľanú podporu a otvorte Správcu profilov Outlooku.
PoznámkaPre správcu profilov Outlooku môžete vytvoriť alias a ak chcete, môžete ho presunúť na pracovnú plochu alebo na iné vhodné miesto.
V Outlooku pre Mac 2011:
Stlačením a podržaním klávesu Option otvorte aplikáciu Microsoft Database Utility, potom kliknite na ikonu Outlook pre Mac 2011.
Ak je to potrebné, vyberte profil alebo identitu, ktorých meno sa zmenilo, kliknite na ikonu ozubeného kolieska a potom kliknite na položku Nastaviť ako predvolené.
V systéme Mac OS overte, či sa na kartu Ochrana osobných údajov v Spotlighte nepridal priečinok profilu alebo identity Outlooku alebo niektorý z jeho nadradených priečinkov. Ak sa na tejto karte zobrazuje priečinok Profily v Outlooku 2016 pre Mac, priečinok identity v programe Outlook pre Mac 2011, prípadne ktorýkoľvek z ich nadradených priečinkov, Spotlight neindexuje umiestnenie tohto priečinka. Odstráňte tieto umiestnenia z karty Ochrana osobných údajov v Spotlighte a počkajte na čas, kým sa dokončí indexovanie.
Skontrolujte, či sú údaje o identite v Outlooku 2016 pre Mac alebo Outlook pre Mac 2011 uložené v správnom predvolenom umiestnení.
Outlook 2016 pre Mac: Uistite sa, že priečinok Profily Outlooku 15 je uložený v umiestnení ~/Library/Group Containers/UBF8T346G9. Priečinok Office/Outlook.Outlook pre Mac 2011: Uistite sa, že priečinok Microsoft User Data je uložený v priečinku ~/Dokumenty.
Ak sa problém stále nevyrieši, index Spotlightu môže byť poškodený. Ak chcete opätovne indexovať index Spotlightu, postupujte takto:
Reštartujte Mac, aby sa reštartovali služby Spotlight.
Prejdite naterminálAplikácie>Vyhľadávača>>.
Zadajte reťazec mdimport -L.
Dôležité: Ak sa zobrazuje viac ako jedna inštancia reťazca "Microsoft Outlook Spotlight Importer.mdimporter", odstráňte aplikáciu Outlook, ktorú nepoužívate , vyprázdnite ju z Koša, reštartujte Mac a prejdite späť na krok 1.
V termináli znova indexujte databázu Outlooku pomocou nasledujúceho príkazu a nahraďte zástupný symbol user_name> vlastným menom < používateľa:
mdimport -g "/Applications/Microsoft Outlook.app/Contents/Library/Spotlight/Microsoft Outlook Spotlight Importer.mdimporter" -d1 "/Users/<user_name>/Library/Group Containers/UBF8T346G9. Office/Outlook/Outlook 15 Profiles/<my_profile_name>"
Poznámka V tomto príkaze je cesta za znakom "-g" predvolenou cestou inštalácie programu Outlook. Cesta za "-d1" je predvolená cesta vášho profilu, pričom <my_profile_name> je predvolene "Hlavný profil". Ak ste premenovali svoj profil alebo nainštalovali Outlook na iné miesto, budete musieť nahradiť skutočné cesty.
Dokončenie opätovného indexovania bude chvíľu trvať. Po dokončení procesu ukončite Outlook a potom ho znova spustite.
Ak ani po vykonaní týchto krokov nemôžete vyhľadávať v Spotlighte a dokončilo sa indexovanie Spotlightu dostatočne dlho, možno budete musieť Office pre Mac odinštalovať a nainštalovať znova. Ďalšie informácie o tomto postupe získate v článku databázy Microsoft Knowledge Base, ktorý sa zobrazí po kliknutí na nasledujúce číslo:
2398768 Ako úplne odstrániť Office pre Mac 2011
Ďalšie informácie
Pri vyhľadávaní v Outlooku 2016 pre Mac alebo v Outlooku pre Mac 2011 v systéme Mac OS X majte na pamäti tieto skutočnosti:
- Mac OS zahŕňa Vyhľadávanie v Spotlighte. Mac OS riadi indexovanie pevného disku pre vyhľadávanie v Spotlighte.
- Obe verzie Outlooku pre Mac poskytujú výsledky hľadania údajov Outlooku pomocou vyhľadávania v Spotlighte.
- Filtre v Outlooku pre Mac tiež využívajú vyhľadávanie v Spotlighte pri poskytovaní výsledkov hľadania.
- Úlohy v Outlooku pre Mac sa zobrazujú pomocou filtrov. Tieto filtre využívajú vyhľadávanie v Spotlighte.
- Keď sa objavia nové údaje, indexovanie Spotlightu môže trvať niekoľko minút. Môže sa to stať napríklad vtedy, keď dostanete nové e-mailové správy.
Spoločnosť Microsoft poskytuje kontaktné informácie tretích strán, ktoré vám pomôžu nájsť technickej podporu. Tieto kontaktné informácie môžu zmeniť bez predchádzajúceho upozornenia. Spoločnosť Microsoft nezaručuje presnosť kontaktných informácií tretej strany.
Produkty tretích strán uvedené v tomto článku vyrábajú spoločnosti, ktoré sú nezávislé od spoločnosti Microsoft. Spoločnosť Microsoft neposkytuje žiadnu záruku, či už vyjadrenú alebo predpokladanú, na výkonnosť alebo spoľahlivosť týchto produktov.