Pri kopírovaní hodnoty z excelového hárka do balíka Microsoft Dynamics NAV 5.0 Service Pack 1 sa na koniec hodnoty pridajú dva špeciálne znaky

Vzťahuje sa na
Microsoft Dynamics NAV 5.0

Tento článok sa vzťahuje na službu Microsoft Dynamics NAV pre všetky krajiny a miestne nastavenia pre všetky jazyky.

Príznaky

Pri kopírovaní hodnoty bunky z excelového hárka do balíka Microsoft Dynamics NAV 5.0 Service Pack 1 (SP1) sa na koniec hodnoty pridajú dva špeciálne znaky. Tieto špeciálne znaky sú znaky obdĺžnika ako znaky posunu riadka.

Poznámka: Ak používate Microsoft Dynamics NAV a Microsoft Excel v počítači s Windowsom 7, tieto dva znaky nie sú viditeľné. Ak máte Microsoft Dynamics NAV a Microsoft Excel spustené v počítači so systémom Windows Server 2003, znaky sú viditeľné.

Tieto znaky sa pridajú do polí v službe Microsoft Dynamics NAV. Preto je potrebné odstrániť špeciálne znaky manuálne.

Príčina

Tento problém sa vyskytuje, pretože znak konca riadka (CR) (ASCII 13) alebo znak posunu riadka (LF) (ASCII 10) sa pridá pri kopírovaní hodnoty bunky z excelového hárka do aplikácie. Klient RoleTailored (RTC) používa ovládací prvok textu založený na štandardnom textovom ovládacom prvku .NET. Ak má textový ovládací prvok .NET vlastnosť Viacriadkový nastavený na hodnotu Nie, pri prilepení textu ovládacieho prvku, ktorý obsahuje znak CR alebo LF, sa skopíruje len text pred znakmi. Ak má ovládací prvok textu nastavenú vlastnosť Viacčiarové riadky na hodnotu True, možno použiť znak Nový riadok. Ďalšie informácie získate na nasledujúcej webovej lokalite spoločnosti Microsoft:
Vlastnosť TextBoxBase.Multiline
V klasickom klientovi musí služba Microsoft Dynamics NAV implementovať špeciálne spracovanie metódy prilepenia ovládacích prvkov úpravy textu. Znaky nového riadka musia byť odstránené z konca riadka.

Riešenie

Informácie o rýchlych opravách

Od spoločnosti Microsoft je k dispozícii podporovaná rýchla oprava. V hornej časti tohto článku databázy Knowledge Base sa nachádza časť K dispozícii sú rýchle opravy. Ak sa vyskytne problém so sťahovaním, inštaláciou tejto rýchlej opravy alebo ak máte iné otázky týkajúce sa technickej podpory, obráťte sa na svojho partnera. Ak ste sa zaregistrovali do plánu podpory priamo v spoločnosti Microsoft, môžete kontaktovať technickú podporu pre Microsoft Dynamics a vytvoriť novú žiadosť o podporu. Na tento účel navštívte nasledujúcu webovú lokalitu spoločnosti Microsoft:

https://mbs.microsoft.com/support/newst art.aspx Technickú podporu systému Microsoft Dynamics môžete kontaktovať aj telefonicky pomocou týchto prepojení určených pre telefónne čísla pre konkrétne krajiny. Navštívte jednu z nasledujúcich webových lokalít spoločnosti Microsoft:

Partners (Partneri)

https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global +Podpora + kontakty Zákazníci

https://mbs.microsoft.com/customersource/support/information/SupportIn formácia/global_support_contacts_eng.htm V osobitných prípadoch môžu byť poplatky, ktoré sa zvyčajne účtujú za volania s oddelením technickej podpory, zrušené, ak pracovník technickej podpory pre systém Microsoft Dynamics a súvisiace produkty rozhodne, že konkrétna aktualizácia váš problém vyrieši. Zvyčajné náklady na podporu sa budú vzťahovať na všetky ďalšie otázky a problémy podpory, na ktoré sa nevzťahuje konkrétna príslušná aktualizácia.

            
          

Postup získania rýchlych opráv alebo súborov aktualizácie systému Microsoft Dynamics NAV

Po požiadaní o rýchlu opravu služby Microsoft Dynamics NAV sa vám v e-maile odošle hypertextové prepojenie.

E-mail bude obsahovať hypertextové prepojenie a heslo. Hypertextové prepojenie môžete použiť na stiahnutie rýchlej opravy Microsoft Dynamics NAV alebo súborov aktualizácie. Po kliknutí na hypertextové prepojenie sa otvorí dialógové okno Sťahovanie súborov – upozornenie zabezpečenia . Potom sa zobrazí výzva na spustenie, uloženie alebo zrušenie sťahovania.

Ak kliknete na položku Spustiť, súbory spustia sťahovanie a proces extrakcie. Je nutné zadať priečinok pre nové súbory a potom zadať heslo.

Ak kliknete na tlačidlo Uložiť, musíte zadať cestu na uloženie komprimovaného súboru. Keď otvoríte súbor, ktorý ste uložili, zobrazí sa výzva na zadanie cesty k súborom. Potom musíte zadať heslo uvedené v e-maile.

Ak kliknete na tlačidlo Zrušiť, proces sťahovania sa zastaví.

Inštalácia rýchlej opravy Microsoft Dynamics NAV alebo súboru aktualizácie

Rýchle opravy a aktualizácie platformy Microsoft Dynamics NAV sú k dispozícii ako samostatné súbory. Ak chcete nainštalovať rýchlu opravu alebo aktualizáciu systému Microsoft Dynamics NAV, musíte nahradiť existujúce inštalačné súbory systému Microsoft Dynamics rýchlou opravou alebo súbormi aktualizácie. Postupujte podľa nasledujúcich krokov.

Krok 1: Nahradenie inštalačného súboru aplikácie Microsoft Dynamics NAV Client

V inštalácii klienta Microsoft Dynamics NAV Client nahraďte nasledujúce súbory rýchlou opravou alebo súborom aktualizácie.

Názov súboru Verzia súboru Veľkosť súboru Dátum Čas Platforma
Dbm.dll 5.0.32009.0 434,176 09-Dec-2010 19:53 x86
Fin.exe 5.0.32009.0 10,747,904 09-Dec-2010 19:31 x86
Finhlink.exe 5.0.32009.0 339,968 09-Dec-2010 19:44 x86
Finsql.exe 5.0.32009.0 10,809,344 09-Dec-2010 20:17 x86
Nc_netb.dll 5.0.32009.0 102 400 09-Dec-2010 19:54 x86
Nc_tcp.dll 5.0.32009.0 102 400 09-Dec-2010 19:54 x86
Nc_tcps.dll 5.0.32009.0 147,456 09-Dec-2010 19:55 x86
Ndbcs.dll 5.0.32009.0 1,286,144 09-Dec-2010 20:20 x86
Slave.exe 5.0.32009.0 151,552 09-Dec-2010 19:44 x86

Ak chcete nahradiť existujúce súbory služby Microsoft Dynamics NAV, postupujte podľa nasledujúcich krokov:

  1. Zavrite službu Microsoft Dynamics NAV.
  2. Vyhľadajte inštalačný adresár klienta Microsoft Dynamics NAV. Klient Microsoft Dynamics NAV Client je zvyčajne nainštalovaný v nasledujúcom adresári:
    C:\Program Files\Microsoft Dynamics NAV\CSIDE Client\
  3. Skopírujte stiahnuté súbory.
  4. Prilepte stiahnuté súbory do inštalačného adresára klienta Microsoft Dynamics NAV.
  5. Po zobrazení výzvy kliknutím na tlačidlo Áno prepíšte súbory v inštalačnom adresári.

Krok 2: Nahradenie inštalačného súboru aplikačného servera Microsoft Dynamics NAV

Ak máte nainštalovaný aplikačný server systému Microsoft Dynamics NAV, v inštalácii aplikačného servera Microsoft Dynamics NAV nahraďte nasledujúce súbory rýchlou opravou alebo súborom aktualizácie.

Názov súboru Verzia súboru Veľkosť súboru Dátum Čas Platforma
Dbm.dll 5.0.32009.0 434,176 09-Dec-2010 19:53 x86
Nas.exe 5.0.32009.0 1,859,584 09-Dec-2010 19:41 x86
Nassql.exe 5.0.32009.0 1,916,928 09-Dec-2010 20:19 x86
Ndbcs.dll 5.0.32009.0 1,286,144 09-Dec-2010 20:20 x86
Slave.exe 5.0.32009.0 151,552 09-Dec-2010 19:44 x86

Ak chcete nahradiť súbory, postupujte podľa týchto krokov.

  1. Zastavte aplikačný server Microsoft Dynamics NAV.
  2. Vyhľadajte inštalačný adresár aplikačného servera Microsoft Dynamics NAV. Server Microsoft Dynamics NAV Application Server je zvyčajne nainštalovaný v nasledujúcom adresári:
    C:\Program Files\Microsoft Dynamics NAV\Application Server\
  3. Skopírujte stiahnuté súbory.
  4. Prilepte stiahnuté súbory do inštalačného adresára aplikačného servera Microsoft Dynamics NAV.
  5. Po zobrazení výzvy kliknutím na tlačidlo Áno prepíšte súbory v inštalačnom adresári.
  6. Spustite aplikačný server Microsoft Dynamics NAV.

Krok 3: Nahradenie inštalačného súboru ovládača Microsoft Dynamics NAV ODBC

Ak máte nainštalovaný ovládač Microsoft Dynamics NAV ODBC, v inštalácii ovládača Microsoft Dynamics NAV ODBC nahraďte tieto súbory.

Názov súboru Verzia súboru Veľkosť súboru Dátum Čas Platforma
Cfront.dll 5.0.32009.0 1,294,336 09-Dec-2010 19:55 x86
Dbm.dll 5.0.32009.0 434,176 09-Dec-2010 19:53 x86
Nc_netb.dll 5.0.32009.0 102 400 09-Dec-2010 19:54 x86
Nc_tcp.dll 5.0.32009.0 102 400 09-Dec-2010 19:54 x86
Nc_tcps.dll 5.0.32009.0 147,456 09-Dec-2010 19:55 x86
Nodbc.dll 5.0.32009.0 2,650,112 09-Dec-2010 19:35 x86
Nodbc.xml Nevzťahuje sa 1,209 07-IV-2008 01:09 Nevzťahuje sa
Nodbccfg.cfg 5.0.32009.0 614,400 09-Dec-2010 19:36 Nevzťahuje sa
Nodbccfg.xml Nevzťahuje sa 2,472 07-IV-2008 01:09 Nevzťahuje sa
Slave.exe 5.0.32009.0 151,552 09-Dec-2010 19:44 x86

Ak chcete nahradiť súbory, postupujte podľa týchto krokov.

  1. Vyhľadajte inštalačný adresár ovládača Microsoft Dynamics NAV ODBC. Ovládač Microsoft Dynamics NAV ODBC je zvyčajne nainštalovaný v nasledujúcom adresári:
    C:\Program Files\Common Files\Dynamics NAV\NODBC\
  2. Skopírujte stiahnuté súbory.
  3. Prilepte stiahnuté súbory do inštalačného adresára ovládača Microsoft Dynamics NAV ODBC.
  4. Po zobrazení výzvy kliknutím na tlačidlo Áno prepíšte súbory v inštalačnom adresári.

Predpoklady

Ak chcete použiť túto rýchlu opravu, musíte mať nainštalovaný balík Microsoft Dynamics NAV 5.0 Service Pack 1.

Alternatívne riešenie

Ak to chcete obísť, upravte bunku a označte ju ako "Iba text".

Stav

Spoločnosť Microsoft potvrdila, že ide o chybu v produktoch spoločnosti Microsoft, ktoré sú uvedené v časti Vzťahuje sa na.

Ďalšie informácie

Ďalšie informácie nájdete v článku databázy Microsoft Knowledge Base, ktorý sa zobrazí po kliknutí na príslušné číslo článku:

824684 Popis štandardnej terminológie, ktorá sa používa na popis aktualizácií softvéru spoločnosti Microsoft

Poznámka: Toto je článok typu FAST PUBLISH, ktorý bol vytvorený priamo v rámci organizácie podpory spoločnosti Microsoft. Informácie obsiahnuté v tomto dokumente sa poskytujú tak, ako sú, ako odpoveď na vzniknuté problémy. V dôsledku rýchlosti ich sprístupnenia môžu materiály obsahovať typografické chyby a môžu byť kedykoľvek revidované bez predchádzajúceho upozornenia. Ďalšie dôležité informácie nájdete v Podmienkach používania .