Tento článok sa vzťahuje na službu Microsoft Dynamics NAV pre všetky krajiny a miestne nastavenia pre všetky jazyky.
Príznaky
Po spustení zostavy Zastarané pohľadávky (120) alebo zostavy Zastarané záväzky (322) v klientovi RoleTailored (RTC) v systéme Microsoft Dynamics NAV 2009 sa vyskytne nízky výkon. Okrem toho v niektorých prípadoch klient zlyhá a zobrazí sa nasledujúce chybové hlásenie:
Poznámka
Výnimka OutOfMemory.
Tento problém sa vyskytuje v nasledujúcich produktoch:
- Microsoft Dynamics NAV 2009 R2
- Microsoft Dynamics NAV 2009 Service Pack 1 (SP1)
Príčina
Tento problém sa vyskytuje, pretože do RTC sa odosiela veľké množstvo údajov. Množstvo údajov je oveľa viac než to, čo sa v skutočnosti vytlačí.
Riešenie
Informácie o rýchlych opravách
Spoločnosť Microsoft teraz poskytuje podporovanú rýchlu opravu. Jeho účelom je však len vyriešiť problém, ktorý je popísaný v tomto článku. Použite ju len v systémoch, v ktorých sa vyskytol tento konkrétny problém. Táto rýchla oprava môže byť ešte otestovaná. Ak teda nie ste týmto problémom vážne zasiahnutí, odporúčame počkať na ďalší balík Service Pack pre systém Microsoft Dynamics alebo ďalšiu verziu systému Microsoft Dynamics NAV, ktorá obsahuje túto opravu.
Poznámka: V osobitných prípadoch môžu byť poplatky, ktoré sú zvyčajne účtované za hovory s oddelením technickej podpory, zrušené, ak pracovník technickej podpory pre systém Microsoft Dynamics a súvisiace produkty rozhodne, že konkrétna aktualizácia vyrieši váš problém. Zvyčajné náklady na podporu sa budú vzťahovať na ďalšie otázky a problémy podpory, na ktoré sa nevzťahuje konkrétna príslušná aktualizácia.
Informácie o inštalácii
Spoločnosť Microsoft poskytuje príklady programovania len pre ilustráciu bez výslovnej alebo implicitnej záruky. To sa týka (okrem iného) aj implicitných záruk obchodovateľnosti alebo vhodnosti na konkrétny účel. Článok predpokladá, že poznáte predvádzaný programovací jazyk a nástroje, ktoré sa používajú na vytváranie a ladenie procedúr. Pracovníci technickej podpory spoločnosti Microsoft vám môžu pomôcť vysvetliť funkčnosť konkrétneho postupu, tieto príklady však nebudú upravovať, aby poskytovali ďalšie funkcie alebo zostavili procedúry podľa vašich špecifických požiadaviek.
Poznámka Pred inštaláciou tejto rýchlej opravy overte, či sú všetci používatelia klienta Microsoft Navision odhlásení zo systému. Týka sa to používateľov klientských služieb Microsoft Navision Application Services (NAS). V čase implementácie tejto rýchlej opravy by ste mali byť jediným klientskym používateľom, ktorý je prihlásený.
Ak chcete implementovať túto rýchlu opravu, musíte mať vývojársku licenciu.
Odporúčame priradiť používateľskému kontu v okne Prihlásenie do Windowsu alebo v okne Prihlásenia do databázy ID roly SUPER. Ak používateľskému kontu nie je možné priradiť ID roly SUPER, musíte overiť, či má používateľské konto nasledujúce povolenia:
- Povolenie Upraviť pre objekt, ktorý budete meniť.
- Povolenie na spustenie pre objekt systémového objektu ID 5210 a pre objekt systémového objektu ID 9015.
Poznámka: Ak nepotrebujete vykonať opravu údajov, nemusíte mať práva na ukladacie priestory údajov.
Zmeny kódu
Poznámka: Opravy kódu pred použitím opráv v produkčných počítačoch vždy testujte v kontrolovanom prostredí.
Pri odstraňovaní tohto problému postupujte nasledovne:
Zmeňte kód v spúšťači OpenCustLedgEntry - OnAfterGetRecord v zostave starých pohľadávok (120) takto:
Existujúci kód... IF AgingBy = AgingBy::"Posting Date" THEN BEGIN CALCFIELDS("Remaining Amt. (LCY)"); IF "Remaining Amt. (LCY)" = 0 THEN CurrReport.SKIP; END; InsertTemp(OpenCustLedgEntry); ...Náhradný kód
... IF AgingBy = AgingBy::"Posting Date" THEN BEGIN CALCFIELDS("Remaining Amt. (LCY)"); IF "Remaining Amt. (LCY)" = 0 THEN CurrReport.SKIP; END; InsertTemp(OpenCustLedgEntry); // Add the following line. currReport.SKIP; ...Zmeňte kód v zákazníkovi Položka účtovnej knihy – OnAfterGetRecordtrigger v zostave starých pohľadávok (120) takto:
Existujúci kód... IF CustLedgEntry.FINDSET(FALSE,FALSE) THEN REPEAT InsertTemp(CustLedgEntry); UNTIL CustLedgEntry.NEXT = 0; ...Náhradný kód
... IF CustLedgEntry.FINDSET(FALSE,FALSE) THEN REPEAT InsertTemp(CustLedgEntry); UNTIL CustLedgEntry.NEXT = 0; // Add the following line. CurrReport.SKIP; ...Zmeňte kód v spúšťači TempCustLedgEntryLoop - OnAfterGetRecord v zostave Aged Accounts Receivable (120) takto:
Existujúci kód... IF PrintToExcel THEN MakeExcelDataBody; ...Náhradný kód
... IF PrintToExcel THEN MakeExcelDataBody; // Add the following line. If NOT PrintDetails then CurrReport.SKIP ...Zmeňte kód v spúšťači Položka účtovnej knihy dodávateľa – OnAfterGetRecord v zostave starých záväzkov (322) takto:
Existujúci kód... IF VendorLedgEntry.FINDSET(FALSE,FALSE) THEN REPEAT InsertTemp(VendorLedgEntry); UNTIL VendorLedgEntry.NEXT = 0; ...Náhradný kód
... IF VendorLedgEntry.FINDSET(FALSE,FALSE) THEN REPEAT InsertTemp(VendorLedgEntry); UNTIL VendorLedgEntry.NEXT = 0; // Add the following line. CurrReport.SKIP; ...Zmeňte kód v spúšťači OpenVendorLedgEntry - OnAfterGetRecord v zostave Aged Accounts Payable (322) takto:
Existujúci kód... InsertTemp(OpenVendorLedgEntry); ...Náhradný kód
... InsertTemp(OpenVendorLedgEntry); // Add the folloiwng line. CurrReport.SKIP; ...Zmeňte kód v spúšťači TempVendortLedgEntryLoop - OnAfterGetRecord v zostave Aged Accounts Payable (322) takto:
Existujúci kód... TotalVendorLedgEntry[1]."Amount (LCY)" += VendorLedgEntryEndingDate."Remaining Amt. (LCY)"; GrandTotalVendorLedgEntry[1]."Amount (LCY)" += VendorLedgEntryEndingDate."Remaining Amt. (LCY)"; ...Náhradný kód
... TotalVendorLedgEntry[1]."Amount (LCY)" += VendorLedgEntryEndingDate."Remaining Amt. (LCY)"; GrandTotalVendorLedgEntry[1]."Amount (LCY)" += VendorLedgEntryEndingDate."Remaining Amt. (LCY)"; // Add the following line. If NOT PrintDetails then currreport.SKIP; ...
Predpoklady
Ak chcete použiť túto rýchlu opravu, musíte mať nainštalovaný niektorý z nasledujúcich produktov:
- Microsoft Dynamics NAV 2009 R2
- Microsoft Dynamics NAV 2009 Service Pack 1 (SP1)
Informácie o odstránení
Túto rýchlu opravu nemožno odstrániť.
Stav
Spoločnosť Microsoft potvrdila, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v časti Vzťahuje sa na.
Poznámka: Toto je článok typu FAST PUBLISH, ktorý bol vytvorený priamo v rámci organizácie podpory spoločnosti Microsoft. Informácie obsiahnuté v tomto dokumente sa poskytujú tak, ako sú, ako odpoveď na vzniknuté problémy. V dôsledku rýchlosti ich sprístupnenia môžu materiály obsahovať typografické chyby a môžu byť kedykoľvek revidované bez predchádzajúceho upozornenia. Ďalšie dôležité informácie nájdete v Podmienkach používania .