Stav špeditéra sa neaktualizuje na Zatvorené a obrazovka Zobrazovač denníkov aktualizácií špeditéra (40.460.00) neobsahuje položku pre identifikáciu špeditéra v správe objednávok v systéme Microsoft Dynamics SL

Vzťahuje sa na
Dynamics SL 2011 Dynamics SL 2015

Príznaky

Keď dokončíte alebo zrušíte dodávku, hodnota v poli Stav sa neaktualizuje na Zatvorené v správe objednávok v systéme Microsoft Dynamics SL.

PoznámkaPole Stav sa zobrazí na karte Ďalšie informácie na obrazovke Špeditéri (40.110.00).  Okrem toho obrazovka Zobrazovač denníkov aktualizácií odosielateľa (40.460.00) neobsahuje položku pre identifikáciu odosielateľa. 

Príčina

Príčina 1
      

Nastavenie oneskorenia aktualizácie odosielateľa je nesprávne. Pozrite si rozlíšenie č. 1.

      

Príčina 2

Nastavenie času spánku pre správcu procesov je príliš malé. Pozrite si rozlíšenie č. 2

      

Príčina 3

Krok Aktualizácia odosielateľa na karte Kroky na obrazovke Typy objednávok (40.200.00) je nastavený nesprávne. Pozrite si rozlíšenie č. 3.

      

Príčina 4

Typ objednávky sa zmenil na karte Kroky na obrazovke Typy objednávok (40.200.00) pred zatvorením existujúcich špeditérov. Pozrite si rozlíšenie 4.

      

Príčina 5

Prispôsobenia boli pridané na obrazovku Špeditéri (40.110.00), ktorá prerušila spracovanie záznamov špeditéra. Pozrite si rozlíšenie č. 5.

      

Príčina 6

Akákoľvek iná príčina než príčina 1 až príčina 5.  V tomto prípade sa tento problém vyskytuje bez ohľadu na typ objednávky. Pozrite si rozlíšenie 6 alebo uznesenie 7.

      

Riešenie

Riešenie 1
      

Overte, či nastavenie na oneskorenie aktualizácie špeditéra nie je príliš veľké. Postupujte takto:

  1. V ponuke Modul kliknite na položku Správa objednávok.

  2. Na table Správa objednávok kliknite v časti Nastaveniena položku Nastavenie správy objednávok.

  3. Na karte Iné skontrolujte, či hodnota v poli Oneskorenie aktualizácie odosielateľa (v minútach) nie je príliš veľká.

    Poznámka Ak je hodnota Oneskorená aktualizácia odosielateľa (v minútach) nastavená na 30, odosielateľ sa zatvorí až 30 minút po dokončení záznamu o špeditérovi.

         Riešenie č. 2

Predĺžiť čas spánku procesu Správca procesov. Postupujte takto:

  1. V ponuke Modul kliknite na položku Správa objednávok.

  2. Na table Správa objednávok kliknite v časti Nastaveniena položku Nastavenie správy objednávok.  

  3. Ak je hodnota v poli menšia ako 15, na karte Iné zadajte do poľa Doba spánku správcu procesuhodnotu 15.

      

Riešenie 3
      

Opravte stav kroku v type objednávky. Postupujte takto:

  1. V zozname Moduly kliknite na položku Správa objednávok.

  2. Na table Správa objednávok kliknite na položku Typy objednávok v časti Údržba.

  3. Do poľa Typ objednávky zadajte ID typu objednávky, ktoré chcete zmeniť.

  4. On the Steps tab, click Required in the Status for the Update Shipper.

  5. Kliknite na tlačidlo Uložiť. Potom zavrite obrazovku Typy objednávok (40.200.00).

      

Riešenie 4
      

Zrušenie špeditérov a súvisiacich predajných objednávok. Postupujte takto:

  1. V zozname Moduly kliknite na položku Správa objednávok.

  2. Na table Správa objednávok kliknite na položku Potvrdenie dodávky v časti Vstup.

  3. Do poľa Identifikácia špeditéra zadajte identifikáciu špeditéra, ktorého chcete zrušiť.

  4. Kliknutím začiarknite nasledujúce políčka:

    • Zrušiť špeditéra
    • Zrušiť objednávku
  5. Kliknite na položku Dokončiť. Potom zavrite obrazovku Potvrdenie odoslania (40.117.00).

         Riešenie 5

Odstráňte prispôsobenia pre obrazovku Špeditéri(40.110.00). Postupujte takto:

  1. Zatvorte všetky obrazovky okrem obrazovky Špeditéri(40.110.00).

  2. V ponuke Prispôsobiť kliknite na položku Prispôsobiť režim.

  3. V ponuke Prispôsobiť kliknite na položku Odstrániť zmeny pre obrazovku.

  4. Kliknite na tlačidlo Áno a potom na tlačidlo OK.

  5. Zatvorte obrazovku Špeditéri (40.110.00). Potom otvorte obrazovku.

         Riešenie 6
      

Zmeňte poradie špeditérov na poradie, ktoré rozpozná správca procesov. Postupujte podľa nasledujúcich krokov. 

Poznámka Pred postupovaním podľa pokynov v tomto postupe sa uistite, že máte úplnú záložnú kópiu databázy, ktorú môžete v prípade výskytu problému obnoviť.

  1. Na obrazovke Správca procesov (40.400.00) kliknite na položku Zastaviť.

  2. Pomocou nástroja Microsoft SQL Query Analyzer alebo Microsoft SQL Server Management Studio spustite príslušný príkaz v databáze aplikácie.

    • Microsoft SQL Server 7.0

      Poznámka

      SELECT "execADG_Release_For_Update '" + rtrim(CpnyID) + "', '', '" +rtrim(ShipperID) + "'" z SOSHIPHEADER kde NextFunctionID ="4043000" a NextFunctionClass = "0200"

    • Microsoft SQL Server 2000 alebo Microsoft SQL Server 2005 alebo Microsoft SQL Server 2008

      Poznámka

      SET QUOTED_IDENTIFIEROFF SELECT "exec ADG_Release_For_Update '" + rtrim(CpnyID) + "','', '" + rtrim(ShipperID) + "'" z SOSHIPHEADER whereNextFunctionID = "4043000" a NextFunctionClass = "0200"

                      

  3. Skopírujte výsledky príkazu do nového okna. Vylúčte záhlavia stĺpcov ani riadky. Potom spustite príkaz new a znova zaraďte do frontu špeditérov, ktorí sú uvedení.

    Poznámka Nasledujúci príkaz je príkladom výsledkov, ktoré môžete skopírovať.

    Poznámka

    Exec ADG_Release_For_Update '0060', '', 'S0009868'

  4. Na obrazovke Správca procesov (40.400.00) kliknite na tlačidlo Štart.

         Riešenie 7
      

Zrušte odosielateľa. Postupujte takto:

  1. V zozname Moduly kliknite na položku Správa objednávok.

  2. Na table Správa objednávok kliknite v časti Vstup na položku Špeditéri.

  3. Na karte Ďalšie informácie začiarknite políčko Zrušené kliknutím a potom kliknite na tlačidlo Dokončiť.