Pri tlači klasických zostáv z klienta RoleTailored v systéme Microsoft Dynamics NAV 2009 Service Pack 1 sa zobrazí chybové hlásenie "Súbor zup nemožno použiť, pretože sa už používa"

Vzťahuje sa na
Dynamics NAV 2009

ČLÁNKY RÝCHLEHO PUBLIKOVANIA POSKYTUJÚ INFORMÁCIE PRIAMO Z ORGANIZÁCIE TECHNICKEJ PODPORY SPOLOČNOSTI MICROSOFT. INFORMÁCIE OBSIAHNUTÉ V TOMTO DOKUMENTE SÚ VYTVORENÉ AKO ODPOVEĎ NA VZNIKAJÚCE ALEBO JEDINEČNÉ TÉMY ALEBO SÚ URČENÉ NA DOPLNENIE INÝCH INFORMÁCIÍ VEDOMOSTNEJ DATABÁZY.

Tento článok sa vzťahuje na službu Microsoft Dynamics NAV pre všetky krajiny a miestne nastavenia pre všetky jazyky.

Príznaky

Pri rýchlej tlači klasických zostáv z klienta RoleTailored (RTC) v balíku Microsoft Dynamics NAV 2009 Service Pack 1 sa zobrazí nasledujúce chybové hlásenie:

Poznámka

Súbor zup nemôžete použiť, pretože sa už používa.

Poznámka: Zostavy sa budú tlačiť aj naďalej.

Príčina

Tento problém sa vyskytuje, pretože klasické zostavy nemajú rozloženie vo Visual Studiu. Microsoft Dynamics NAV používa na tlač týchto zostáv nástroj zostáv z klasického klienta. Tento problém sa vyskytuje, keď služba Microsoft Dynamics NAV rýchlo otvorí a potom zavrie klasický nástroj zostáv. Keď Microsoft Dynamics NAV zavrie klasického klienta, súbor .zup sa aktualizuje. Preto ak sa jeden z klasických nástrojov zostáv pokúsi zavrieť pred dokončením predchádzajúceho nástroja zostáv, tento problém sa vyskytne.

Riešenie

Informácie o rýchlych opravách

Od spoločnosti Microsoft je k dispozícii podporovaná rýchla oprava. V hornej časti tohto článku databázy Knowledge Base sa nachádza časť K dispozícii sú rýchle opravy. Ak sa vyskytne problém so sťahovaním, inštaláciou tejto rýchlej opravy alebo ak máte iné otázky týkajúce sa technickej podpory, obráťte sa na svojho partnera. Ak ste sa zaregistrovali do plánu podpory priamo v spoločnosti Microsoft, môžete kontaktovať technickú podporu pre Microsoft Dynamics a vytvoriť novú žiadosť o podporu. Na tento účel navštívte nasledujúcu webovú lokalitu spoločnosti Microsoft:

https://mbs.microsoft.com/support/newstart.aspx Technickú podporu systému Microsoft Dynamics môžete kontaktovať aj telefonicky pomocou týchto prepojení určených pre telefónne čísla pre konkrétne krajiny. Na tento účel navštívte jednu z nasledujúcich webových lokalít spoločnosti Microsoft:

Partners (Partneri)

https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global+Support+Contacts Zákazníci

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htm V osobitných prípadoch môžu byť poplatky, ktoré sa zvyčajne účtujú za volania s oddelením technickej podpory, zrušené, ak pracovník technickej podpory pre systém Microsoft Dynamics a súvisiace produkty rozhodne, že konkrétna aktualizácia váš problém vyrieši. Zvyčajné náklady na podporu sa budú vzťahovať na všetky ďalšie otázky a problémy podpory, na ktoré sa nevzťahuje konkrétna príslušná aktualizácia.

            
          

Postup získania rýchlych opráv alebo súborov aktualizácie systému Microsoft Dynamics NAV

Po požiadaní o rýchlu opravu služby Microsoft Dynamics NAV sa vám v e-maile odošle hypertextové prepojenie.

E-mail bude obsahovať hypertextové prepojenie a heslo. Hypertextové prepojenie môžete použiť na stiahnutie rýchlej opravy Microsoft Dynamics NAV alebo súborov aktualizácie. Po kliknutí na hypertextové prepojenie sa otvorí dialógové okno Sťahovanie súborov – upozornenie zabezpečenia . Potom sa zobrazí výzva na spustenie, uloženie alebo zrušenie sťahovania.

Ak kliknete na položku Spustiť, súbory spustia sťahovanie a proces extrakcie. Je nutné zadať priečinok pre nové súbory a potom zadať heslo.

Ak kliknete na tlačidlo Uložiť, musíte zadať cestu na uloženie komprimovaného súboru. Keď otvoríte súbor, ktorý ste uložili, zobrazí sa výzva na zadanie cesty k súborom. Potom musíte zadať heslo uvedené v e-maile.

Ak kliknete na tlačidlo Zrušiť, proces sťahovania sa zastaví.

Inštalácia rýchlej opravy Microsoft Dynamics NAV alebo súboru aktualizácie

Rýchle opravy a aktualizácie platformy Microsoft Dynamics NAV sú k dispozícii ako samostatné súbory. Ak chcete nainštalovať rýchlu opravu alebo aktualizáciu systému Microsoft Dynamics NAV, musíte nahradiť existujúce inštalačné súbory systému Microsoft Dynamics rýchlou opravou alebo súbormi aktualizácie. Postupujte podľa nasledujúcich krokov.

Krok 1: Nahradenie súborov v inštalácii klasického klienta služby Microsoft Dynamics NAV

V inštalácii klienta Microsoft Dynamics NAV Classic Client nahraďte nasledujúce súbory rýchlymi opravami alebo súborom aktualizácie.

Názov súboru Verzia súboru Veľkosť súboru Dátum Čas Platforma
Dbm.dll 6.0.30677.0 427,848 24-Feb-2010 15:16 x86
Fin.exe 6.0.30677.0 12,597,064 24-Feb-2010 15:17 x86
Finhlink.exe 6.0.30677.0 452,432 24-Feb-2010 15:17 x86
Finsql.exe 6.0.30677.0 12,718,928 24-Feb-2010 15:17 x86
Nc_netb.dll 6.0.30677.0 96,592 24-Feb-2010 15:16 x86
Nc_tcp.dll 6.0.30677.0 98,640 24-Feb-2010 15:16 x86
Nc_tcps.dll 6.0.30677.0 141,136 24-Feb-2010 15:16 x86
Ndbcs.dll 6.0.30677.0 1,348,944 24-Feb-2010 15:16 x86
Slave.exe 6.0.30677.0 152,400 24-Feb-2010 15:16 x86

Ak chcete nahradiť existujúce súbory služby Microsoft Dynamics NAV, postupujte podľa nasledujúcich krokov:

  1. Zavrite klienta Microsoft Dynamics NAV Classic.

  2. Vyhľadajte inštalačný adresár klienta Microsoft Dynamics NAV Classic. Microsoft Dynamics NAV Classic Client je zvyčajne nainštalovaný v nasledujúcom adresári:

    C:\Program Files\Microsoft Dynamics NAV\60\Classic

  3. Skopírujte stiahnuté súbory.

  4. Prilepte stiahnuté súbory do inštalačného adresára Microsoft Dynamics NAV Classic Client.

  5. Ak chcete prepísať súbory v adresári, kliknite na tlačidlo Áno .

Krok 2: Nahradenie súborov v inštalácii klienta Microsoft Dynamics NAV RoleTailored

V klientskej inštalácii služby Microsoft Dynamics NAV RoleTailored nahraďte nasledujúce súbory rýchlymi opravami alebo súborom aktualizácie.

Názov súboru Verzia súboru Veľkosť súboru Dátum Čas Platforma
Microsoft.dynamics.framework.patterns.dll 1.3.10803.137 71,656 24-Feb-2010 06:30 x86
Microsoft.dynamics.framework.ui.dll 1.3.10803.137 698,328 24-Feb-2010 06:30 x86
Microsoft.dynamics.framework.ui.mapping.dll 1.3.10803.137 104,424 24-Feb-2010 06:30 x86
Microsoft.dynamics.framework.ui.navigation.dll 1.3.10803.137 34,800 24-Feb-2010 06:30 x86
Microsoft.dynamics.framework.ui.ux2006.dll 1.3.10803.137 88,040 24-Feb-2010 06:30 x86
Microsoft.dynamics.framework.ui.ux2006.winforms.dll 1.3.10803.137 63,480 24-Feb-2010 06:30 x86
Microsoft.dynamics.framework.ui.windows.dll 1.3.10803.137 83,944 24-Feb-2010 06:30 x86
Microsoft.dynamics.framework.ui.winforms.controls.dll 1.3.10803.137 2,111,488 24-Feb-2010 06:30 x86
Microsoft.dynamics.framework.ui.winforms.dll 1.3.10803.137 690,152 24-Feb-2010 06:30 x86
Microsoft.dynamics.nav.client.builder.dll 6.0.30677.0 198,544 24-Feb-2010 15:05 x86
Microsoft.dynamics.nav.client.exe 6.0.30677.0 149,376 24-Feb-2010 15:05 x86
Microsoft.dynamics.nav.client.interop.communicator.dll 1.0.559.183 75,688 24-Feb-2010 15:05 x86
Microsoft.dynamics.nav.client.serviceconnection.dll 6.0.30677.0 104,352 24-Feb-2010 15:05 x86
Microsoft.dynamics.nav.client.ui.dll 6.0.30677.0 505,728 24-Feb-2010 15:05 x86
Microsoft.dynamics.nav.client.winforms.dll 6.0.30677.0 337,808 24-Feb-2010 15:05 x86
Microsoft.dynamics.nav.client.winforms.tlb Nevzťahuje sa 2,644 24-Feb-2010 12:05 Nevzťahuje sa
Microsoft.dynamics.nav.language.dll 6.0.30677.0 1,992,576 24-Feb-2010 15:05 x86
Microsoft.dynamics.nav.types.dll 6.0.30677.0 567,160 24-Feb-2010 15:06 x86
Microsoft.office.interop.outlook.dll 10.0.4504.0 395,136 24-Feb-2010 15:17 x86

Ak chcete nahradiť tieto súbory, postupujte podľa týchto krokov:

  1. Zatvorte klienta Microsoft Dynamics NAV RoleCustomed.

  2. Vyhľadajte inštalačný adresár klienta Microsoft Dynamics NAV RoleCustomized. Klient Microsoft Dynamics NAV RoleTailored je zvyčajne nainštalovaný v nasledujúcom adresári:

    C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored Client

  3. Skopírujte stiahnuté súbory.

  4. Prilepte stiahnuté súbory do inštalačného adresára klienta Microsoft Dynamics NAV RoleCustomed.

  5. Ak chcete prepísať súbory v adresári, kliknite na tlačidlo Áno .

Krok 3: Nahradenie súborov v inštalácii servera Microsoft Dynamics NAV Server

V inštalácii servera Microsoft Dynamics NAV Server nahraďte nasledujúce súbory rýchlou opravou alebo súborom aktualizácie.

Názov súboru Verzia súboru Veľkosť súboru Dátum Čas Platforma
Httpcfg.exe 5.2.3790.0 22,352 24-Feb-2010 15:17 x86
Microsoft.dynamics.nav.language.dll 6.0.30677.0 1,992,576 24-Feb-2010 15:06 x86
Microsoft.dynamics.nav.ncl.dll 6.0.30677.0 608,120 24-Feb-2010 15:06 x86
Microsoft.dynamics.nav.server.exe 6.0.30677.0 141,184 24-Feb-2010 15:05 x86
Microsoft.dynamics.nav.service.dll 6.0.30677.0 145,280 24-Feb-2010 15:05 x86
Microsoft.dynamics.nav.service.runtime.dll 6.0.30677.0 75,664 24-Feb-2010 15:05 x86
Microsoft.dynamics.nav.service.webservices.dll 6.0.30677.0 145,304 24-Feb-2010 15:05 x86
Microsoft.dynamics.nav.types.dll 6.0.30677.0 567,160 24-Feb-2010 15:06 x86
Microsoft.dynamics.nav.watson.dll 6.0.30677.0 42,880 24-Feb-2010 15:05 x86
nclcsrt.etx Nevzťahuje sa 89,525 24-Feb-2010 08:28 Nevzťahuje sa
nclcsrt.stx Nevzťahuje sa 91,724 24-Feb-2010 08:28 Nevzťahuje sa
Nclcsrts.dll 6.0.30677.0 1,473,872 24-Feb-2010 15:17 x86
Ndbcs.dll 6.0.30677.0 1,348,944 24-Feb-2010 15:17 x86

Ak chcete nahradiť tieto súbory, postupujte podľa týchto krokov:

  1. Zastavte navigačný server systému Microsoft Dynamics.

  2. Vyhľadajte inštalačný adresár Microsoft Dynamics NAV Server. Server Microsoft Dynamics NAV Server je zvyčajne nainštalovaný v nasledujúcom adresári:

    C:\Program Files\Microsoft Dynamics NAV\60\Service

  3. Skopírujte stiahnuté súbory.

  4. Prilepte stiahnuté súbory do inštalačného adresára Microsoft Dynamics NAV Server.

  5. Ak chcete prepísať súbory v adresári, kliknite na tlačidlo Áno .

  6. Spustite navigačný server systému Microsoft Dynamics.

Krok 4: Nahradenie súborov v inštalácii aplikačného servera Microsoft Dynamics NAV

Ak máte nainštalovaný aplikačný server Microsoft Dynamics NAV, nahraďte nasledujúce súbory v inštalácii aplikačného servera systému Microsoft Dynamics použitím rýchlej opravy alebo súborov aktualizácie.

Názov súboru Verzia súboru Veľkosť súboru Dátum Čas Platforma
Dbm.dll 6.0.30677.0 427,848 24-Feb-2010 15:16 x86
Nas.exe 6.0.30677.0 2,259,784 24-Feb-2010 15:17 x86
Nassql.exe 6.0.30677.0 2,358,096 24-Feb-2010 15:17 x86
Ndbcs.dll 6.0.30677.0 1,348,944 24-Feb-2010 15:16 x86
Slave.exe 6.0.30677.0 152,400 24-Feb-2010 15:16 x86

Ak chcete nahradiť súbory, postupujte podľa týchto krokov.

  1. Zastavte aplikačný server Microsoft Dynamics NAV.

  2. Vyhľadajte inštalačný adresár aplikačného servera Microsoft Dynamics NAV. Server Microsoft Dynamics NAV Application Server je zvyčajne nainštalovaný v nasledujúcom adresári:

    C:\Program Files\Microsoft Dynamics NAV\60\Application Server

  3. Skopírujte stiahnuté súbory.

  4. Prilepte stiahnuté súbory do inštalačného adresára aplikačného servera Microsoft Dynamics NAV.

  5. Ak chcete prepísať súbory v adresári, kliknite na tlačidlo Áno .

  6. Spustite aplikačný server Microsoft Dynamics NAV.

Po použití tejto rýchlej opravy sa RTC najskôr pokúsi zavrieť nástroj zostáv. Ak sa nedá zavrieť nástroj na tvorbu zostáv, RTC počká sekundu a potom to skúsi znova maximálne 30-krát.

Predpoklady

Ak chcete použiť túto rýchlu opravu, musíte mať nainštalovaný balík Microsoft Dynamics NAV 2009 Service Pack 1.

Stav

Spoločnosť Microsoft potvrdila, že ide o chybu v produktoch spoločnosti Microsoft, ktoré sú uvedené v časti Vzťahuje sa na.

Ďalšie informácie

Ďalšie informácie nájdete v článku databázy Microsoft Knowledge Base, ktorý sa zobrazí po kliknutí na príslušné číslo článku:

824684 Popis štandardnej terminológie, ktorá sa používa na popis aktualizácií softvéru spoločnosti Microsoft

SPOLOČNOSŤ MICROSOFT A/ALEBO JEJ DODÁVATELIA NEPOSKYTUJÚ ŽIADNE VYHLÁSENIA ANI ZÁRUKY TÝKAJÚCE SA VHODNOSTI, SPOĽAHLIVOSTI ALEBO PRESNOSTI INFORMÁCIÍ OBSIAHNUTÝCH V DOKUMENTOCH A SÚVISIACICH GRAFIKÁCH PUBLIKOVANÝCH NA TEJTO WEBOVEJ LOKALITE (ĎALEJ LEN "MATERIÁLY") NA AKÝKOĽVEK ÚČEL.

MATERIÁLY MÔŽU OBSAHOVAŤ TECHNICKÉ NEPRESNOSTI ALEBO TYPOGRAFICKÉ CHYBY A MÔŽU BYŤ KEDYKOĽVEK REVIDOVANÉ BEZ PREDCHÁDZAJÚCEHO UPOZORNENIA. V MAXIMÁLNOM ROZSAHU POVOLENOM PRÍSLUŠNÝMI ZÁKONMI SPOLOČNOSŤ MICROSOFT A/ALEBO JEJ DODÁVATELIA ODMIETAJÚ ZODPOVEDNOSŤ A VYLUČUJÚ VŠETKY VYHLÁSENIA, ZÁRUKY A PODMIENKY, ČI UŽ VÝSLOVNÉ, IMPLICITNÉ ALEBO ZÁKONNÉ, VRÁTANE, NIE VŠAK VÝHRADNE, VYHLÁSENÍ, GARANCIÍ ALEBO PODMIENOK VLASTNÍCTVA, NEPORUŠENIA CUDZÍCH PRÁV, USPOKOJIVÉHO STAVU ALEBO KVALITY, OBCHODOVATEĽNOSTI A VHODNOSTI NA KONKRÉTNY ÚČEL V SÚVISLOSTI S MATERIÁLMI.