Faxová služba zlyhá, keď faxový server prijme fax v počítači so systémom Windows Server 2008 alebo Windows Server 2008 R2

Príznaky

Predstavte si nasledujúcu situáciu:

  • V počítači so systémom Windows Server 2008 alebo Windows Server 2008 R2 nainštalujete rolu faxový Server.

  • Nakonfigurujete faxový Server role nasmerovať prichádzajúce faxy e-mailovú adresu.

V takomto prípade faxovú službu môže zlyhať pri doručení faxu. Okrem toho odosielateľa faxu prijme upozornenie, že úspešné odoslanie faxu. Však fax nie je smerované na zadanú e-mailovú adresu.

Aj tieto udalosti prihlásený v denníku aplikácie:

Identifikácia 32089
Identifikácia 32083
Poznámka: Tento problém nie je špecifický pre rolu faxový Server v počítači so systémom Windows Server 2008 alebo Windows Server 2008 R2. Tento problém sa môže vyskytnúť, keď všetky aplikácie alebo služby niektoré Data Objects súčasti CDO (Collaboration) volania Inetcomm.dll modul v počítači so systémom Windows Vista, Windows Server 2008, Windows 7 alebo Windows Server 2008 R2.

Príčina

Faxový Server role je niektoré hovory CDO modul Inetcomm.dll nasmerovať faxu, e-mailovú adresu. Vždy, keď je smerovaný faxy, Inetcomm.dll modul sa načíta a potom prázdne.

Dve triedy však nie sú neregistrované, keď tento modul sa nezruší. Ak modul sa obnoví na inú adresu, niektoré funkcie volania WndProc aj bod starú adresu. V takomto prípade výnimku sa vyskytuje, pretože staré adresy je neplatný. Výnimka nespôsobuje Faxová služba zlyhá.

Riešenie

Informácie o rýchlej oprave

Od spoločnosti Microsoft je k dispozícii podporovaná rýchla oprava. Táto rýchla oprava je však určená iba opravu problému, ktorý je popísaný v tomto článku. Rýchlu opravu použite len v systémoch, v ktorých sa vyskytuje problém popísaný v tomto článku. Táto rýchla oprava môže byť ďalej testovaná. Ak nie ste výrazne ovplyvnení týmto problémom, odporúčame vám počkať na ďalšiu aktualizáciu softvéru, ktorá bude obsahovať túto rýchlu opravu.

Ak je rýchla oprava k dispozícii na stiahnutie, na začiatku tohto článku databázy Knowledge Base sa nachádza časť „K díspozícii je rýchla oprava na stiahnutie“. Ak sa táto časť nezobrazuje, obráťte sa na oddelenie služieb zákazníkom a technickej podpory spoločnosti Microsoft a požiadajte o poskytnutie tejto rýchlej opravy.

Poznámka: Ak sa vyskytnú ďalšie problémy alebo ak je potrebné riešiť problémy, je možné, že budete musieť vytvoriť samostatnú servisnú požiadavku. Na ďalšie žiadosti o podporu a problémy, ktoré sa netýkajú tejto konkrétnej rýchlej opravy, sa vzťahujú zvyčajné poplatky za poskytnutie technickej podpory. Úplný zoznam telefónnych čísel služieb zákazníkom spoločnosti Microsoft a podpora alebo vytvoriť samostatnú servisnú požiadavku, nájdete na webovej lokalite spoločnosti Microsoft:

Poznámka: Formulár "Prevzatie dostupnej rýchlej opravy" sa zobrazuje pre jazyky, pre ktoré je rýchla oprava k dispozícii. Ak nemôžete nájsť požadovaný jazyk, znamená to, že rýchla oprava nie je pre tento jazyk k dispozícii.

Požiadavky

Použiť túto rýchlu opravu, musí byť počítač jeden z nasledujúcich operačných systémov:

  • Windows Vista Service Pack 1 (SP1)

  • Windows Vista Service Pack 2 (SP2)

  • Windows Server 2008

  • Windows Server 2008 Service Pack 2 (SP2)

  • Windows 7

  • Windows 7 Service Pack 1 (SP1)

  • Windows Server 2008 R2

  • Windows Server 2008 R2 Service Pack 1 (SP1)

Ďalšie informácie o možnostiach získania balíka Windows Vista service pack, po kliknutí na nasledovné číslo článku publikovaného v databáze Microsoft Knowledge Base:

ako získať najnovší balík service pack pre systém Windows Vista

Ďalšie informácie o možnostiach získania balíka Service Pack pre systém Windows Server 2008 získate kliknutím na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:

ako získať najnovší balík service pack pre systém Windows Server 2008

Požiadavka na reštartovanie

Po použití tejto rýchlej opravy nie je potrebné reštartovať počítač.

Informácie o nahradení rýchlej opravy

Táto rýchla oprava nenahrádza žiadnu inú rýchlu opravu.

Informácie o súboroch

Globálna verzia tejto rýchlej opravy má atribúty súborov (alebo novšie atribúty) uvedené v nasledujúcej tabuľke. Dátumy a čas jednotlivých súborov sú uvedené vo formáte koordinovaného svetového času (UTC). Pri zobrazení informácií o súbore sa dátumy a čas prevedú na miestny čas. Ak chcete vyhľadať rozdiely medzi časom UTC a miestnym časom, použite kartu Časové pásmo v položke Dátum a čas v ovládacom paneli.

Windows Vista a Windows Server 2008 súbor informácií poznámky

Dôležité upozornenie: Rýchle opravy systémov Windows Vista a Windows Server 2008 sa nachádzajú v rovnakých balíkoch. Avšak iba "Windows Vista" je uvedené na stránke žiadosti o rýchlu opravu. Ak chcete požiadať o opravu hotfix, ktorá je určená pre jeden alebo oba operačné systémy, vyberte rýchlu opravu, ktorá je uvedená v časti "Windows Vista" na stránke. Vždy si pozrite časti "Vzťahuje sa na" v článkoch, aby ste zistili skutočný operačný systém, pre ktorý je daná rýchla oprava určená.

  • Súbory vzťahujúce sa na konkrétny produkt, SR_Level (RTM, SPn) a služby pobočky (LDR, GDR) je identifikovať preskúmaním fileversion čísla, ako je uvedené v nasledujúcej tabuľke.

  • Service Pack 1 je integrovaná do Pôvodná verzia systému Windows Server 2008.

  • Súbory typu MANIFEST (.manifest) a súbory MUM (.mum) ktoré sa inštalujú pre jednotlivé prostredia, sú uvedené samostatne. Súbory MUM a súbory MANIFEST a priradené súbory katalógu zabezpečenia (.cat), sú dôležité na zachovanie štátu aktualizované súčasti. Súbory katalógov zabezpečenia (atribúty uvedené) sú podpísané digitálnym podpisom spoločnosti Microsoft.

Potrebujete ďalšiu pomoc?

Rozšírte svoje zručnosti
Preskúmať školenie
Buďte medzi prvými, ktorí získajú nové funkcie
Pripojiť k Microsoft insiderov chcú

Považujete poskytnuté informácie za užitočné?

Ďakujem za vaše pripomienky!

×