Príznaky
Pri pokuse o inštaláciu servera Microsoft Dynamics CRM 2011 na doménu sa zobrazí nasledujúce chybové hlásenie:
Vyskytla sa výnimka počas programu Microsoft. CRM. Tools. admin. OrganizationCreator: akcia Microsoft. CRM. Tools. admin. provisionBusinessAction zlyhala
Okrem toho sa v denníku inštalácie zaznamená toto chybové hlásenie:
Chyba | Inštalácia dokončená: OrganizationCreator – vyskytla sa
chyba | Vyskytla sa výnimka počas programu Microsoft. CRM. Tools. admin. OrganizationCreator: akcia Microsoft. CRM. Tools. admin. provisionBusinessAction zlyhala.
Vnútorná výnimka:
prihlásenie do domény pre tohto používateľa je neplatné: (dom. Ain \ <meno používateľa>).
Vyberte položku ďalšie prihlásenie do domény a skúste to znova.
Na lokalite Microsoft. CRM. Authentication. UserManagementFactory. ValidateActiveDirectoryUser...
Potom sa pokúšate nainštalovať server systému Microsoft Dynamics CRM 2011 aktualizáciou inštalačných súborov servera Microsoft Dynamics CRM 2011. Ak to chcete urobiť, použite jeden z nasledujúcich postupov:
-
Vyberte položku získať aktualizácie pre systém Microsoft Dynamics CRM (odporúča sa) počas inštalácie servera Microsoft dynamics CRM 2011.
-
Postupujte podľa pokynov v nasledujúcom článku databázy Microsoft Knowledge Base (KB):
2434455 Ako získať aktualizácie inštalácie pre systém Microsoft Dynamics CRM 2011
Po dokončení inštalácie servera Microsoft Dynamics CRM 2011 serverom aktualizáciou inštalačných súborov systému Microsoft Dynamics CRM 2011 nie je možné vykonať tieto úlohy:
-
Vytvorenie nových organizácií na serveri Microsoft Dynamics CRM 2011
-
Pridanie používateľov k serveru služby Microsoft Dynamics CRM 2011
Príčina
Pri pokuse o inštaláciu servera služby Microsoft Dynamics CRM 2011 v doméne sa zobrazí chybové hlásenie, pretože Inštalácia Microsoft Dynamics CRM 2011 servera blokuje inštaláciu, keď názov domény NetBIOS domény obsahuje bodku (.).
Okrem toho nie je možné vytvárať nové organizácie v systéme Microsoft Dynamics CRM 2011 Server alebo pridať používateľov k serveru Microsoft Dynamics CRM 2011 pri inštalácii systému Microsoft Dynamics CRM 2011 Server aktualizáciou inštalačných súborov.
Riešenie
Ak chcete nainštalovať server Microsoft Dynamics CRM 2011 na doménu, ktorej názov domény NetBIOS obsahuje bodku (.), postupujte podľa týchto krokov:
-
Ak chcete, aby sme vytvorili príslušný kľúč databázy Registry za vás, prejdite na časťOpravte to za mňa. Ak chcete radšej vytvoriť príslušný kľúč databázy Registry, prejdite na časťja to vyriešim.
Opravte to
, aby sa mi automaticky vytvoril príslušný kľúč databázy Registry, kliknite na tlačidlo opraviť alebo prepojenie. V dialógovom okne sťahovanie súboru kliknite na položku Spustiť a postupujte podľa krokov v sprievodcovi riešenie Fix it .
Poznámok-
Tento sprievodca môže byť dostupný iba v angličtine. Automatická oprava však funguje aj pre ostatné jazykové verzie systému Windows.
-
Ak nie ste v počítači, v ktorom sa vyskytol problém, môžete riešenie Fix it uložiť na USB kľúč alebo na CD disk a potom ho spustiť v počítači, v ktorom sa vyskytol problém.
Potom prejdite na časť vyriešil saproblém?Dovoľte mi spravit myselfCreate príslušný kľúč databázy Registry na serveri, v ktorom chcete nainštalovať server Microsoft Dynamics CRM 2011. Postupujte podľa nasledujúcich krokov:
-
Otvorte Editor databázy Registry.
-
Vyhľadajte toto umiestnenie: HKLM\Software\Microsoft
-
Ak ešte neexistuje, vytvorte kľúč databázy Registry MSCRM.
-
Vyhľadajte toto umiestnenie: HKLM\Software\Microsoft\MSCRM
-
Vytvorte novú hodnotu DWORD type databázy Registry a potom názov hodnoty databázy Registry VerifyDomainName.
-
Nastavenie datavalue hodnoty VerifyDomainName na hodnotu 1
-
-
Počas inštalácie servera Microsoft Dynamics CRM 2011 vykonajte jednu z nasledujúcich úloh:
-
Vyberte položku získať aktualizácie pre systém Microsoft Dynamics CRM (odporúča sa).
-
Ak server nemá internetové pripojenie, postupujte podľa pokynov v nasledujúcom článku vedomostnej databázy Knowledge Base, kde získate a nainštalujete aktualizácie:
2434455 2434455: ako získať aktualizácie inštalácie pre systém Microsoft Dynamics CRM 2011
-
Po dokončení inštalácie servera Microsoft Dynamics CRM 2011 sa nainštalujte súhrnná aktualizácia 4 pre systém Microsoft Dynamics CRM 2011 a potom reštartujte server.
Po reštartovaní servera budete môcť vytvárať nové organizácie v systéme Microsoft Dynamics CRM 2011 Server a pridať používateľov k serveru Microsoft Dynamics CRM 2011.
Ďalšie informácie o súhrnnej aktualizácii 4 pre systém Microsoft Dynamics CRM 2011 nájdete v článku databázy Microsoft Knowledge Base, ktorý sa zobrazí po kliknutí na nasledovné číslo článku:
2556167 K dispozícii je súhrnná aktualizácia 4 pre systém Microsoft Dynamics CRM 2011
Vyriešil sa problém?
-
Skontrolujte, či sa problém vyriešil. Ak sa problém vyriešil, dokončili ste sa v tejto časti. Ak sa problém nevyriešil, môžete sa obrátiť na oddelenie technickej podpory.
-
Ocenili by sme vaše pripomienky. Ak chcete poskytnúť pripomienky alebo nahlásiť akékoľvek problémy s týmto riešením, zanechajte komentár k bloguOpravte to za mňaalebo nám odošlite e-mailovú správu.
Stav
Spoločnosť Microsoft potvrdzuje, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v tomto článku v časti Informácie v tomto článku sa týkajú nasledujúcich produktov.
Ďalšie informácie
Ďalšie informácie o terminológii aktualizácie softvéru nájdete v článku databázy Microsoft Knowledge Base, ktorý sa zobrazí po kliknutí na nasledovné číslo článku:
824684 Popis štandardnej terminológie použitej na popis softvéru spoločnosti updatesFor ďalšie informácie o rýchlej oprave softvéru Microsoft Business Solutions CRM a balíku aktualizácií, po kliknutí na nasledovné číslo článku databázy Microsoft Knowledge Base:
887283 Rýchla oprava softvéru Microsoft Business Solutions CRM a aktualizácia názvov balíkov