Prihláste sa s kontom Microsoft
Prihláste sa alebo si vytvorte konto.
Dobrý deň,
Vyberte iné konto.
Máte viacero kont
Vyberte konto, s ktorým sa chcete prihlásiť.

Príznaky

Predstavte si nasledujúcu situáciu:

  • Máte tlačového servera so systémom Windows Server 2008.

  • Tento tlačový server má veľa klientov so systémom Windows Vista tlačiarne.

V takomto prípade pamäte zaraďovača tlače výrazne zvyšuje časom. Napríklad tento problém sa vyskytuje, keď niektoré tlačiarne tisíce klientov posielajú tlačové úlohy na tlačový server. Prípadne tlačový server, prestane reagovať a je potrebné reštartovať server obnoviť z tohto problému. V závislosti od tlače zaťaženie, tento problém môže nastať po systém bol spustený jeden deň alebo niekoľko týždňov.

Tiež, keď sa používateľ pokúsi tlačiť dokumenty z počítača so systémom Windows Vista, tlačovú náhodne zlyhá a používateľovi sa zobrazí nasledujúce chybové hlásenie:

Systém Windows sa nemôže pripojiť k tlačiarni. Nie je spustená zaraďovacia služba server. Reštartujte Zaraďovač tlače na serveri alebo reštartovať server stroj

Príčina

Tento problém sa vyskytuje z dôvodu pretekanie pamäte v službe zaraďovača tlače. Zaraďovacia služba spravuje nepovinný klienta oznámenie front. Okrem toho služba zaraďovača tlače cache tlačiarne DEVMODE štruktúra každého klienta rukoväť, ktorá sa otvorí. V kombinácii týchto dvoch funkcií spotrebúvajú veľa pamäte, keď veľa klientov tlačiarne tlačového servera.

Klientske počítače so systémom Windows Vista tlačiarne použiť tiež asynchrónne vzdialeného volania procedúr (vzdialené volania procedúr) získať zmena upozornenia tlačiarne. Preto veľa asynchrónnych volaní RPC naplánované pri veľa klientov tlačiarne tlačového servera. Po počet odoslané vzdialené volania procedúr dosiahne limit 6000, klienta používateľovi sa zobrazí chybové hlásenie, ktoré je spomenuté v časti "Príznaky".

Riešenie

Informácie o rýchlej oprave

Od spoločnosti Microsoft je k dispozícii podporovaná rýchla oprava. Táto rýchla oprava je však určená iba opravu problému, ktorý je popísaný v tomto článku. Rýchlu opravu použite len v počítačoch s týmto konkrétnym problémom. Táto rýchla oprava môže byť ďalej testovaná. Ak nie ste výrazne ovplyvnení týmto problémom, odporúčame vám počkať na ďalšiu aktualizáciu softvéru, ktorá bude obsahovať túto rýchlu opravu.

Ak je rýchla oprava k dispozícii na stiahnutie, na začiatku tohto článku databázy Knowledge Base sa nachádza časť „K díspozícii je rýchla oprava na stiahnutie“. Ak sa táto časť nezobrazuje, obráťte sa na oddelenie služieb zákazníkom a technickej podpory spoločnosti Microsoft a požiadajte o poskytnutie tejto rýchlej opravy.

Poznámka: Ak sa vyskytnú ďalšie problémy alebo ak je potrebné riešiť problémy, je možné, že budete musieť vytvoriť samostatnú servisnú požiadavku. Na ďalšie žiadosti o podporu a problémy, ktoré sa netýkajú tejto konkrétnej rýchlej opravy, sa vzťahujú zvyčajné poplatky za poskytnutie technickej podpory. Úplný zoznam telefónnych čísel služieb zákazníkom spoločnosti Microsoft a podpora alebo vytvoriť samostatnú servisnú požiadavku, nájdete na webovej lokalite spoločnosti Microsoft:

http://support.microsoft.com/contactus/?ws=supportPoznámka: Formulár "Prevzatie dostupnej rýchlej opravy" sa zobrazuje pre jazyky, pre ktoré je rýchla oprava k dispozícii. Ak nemôžete nájsť požadovaný jazyk, znamená to, že rýchla oprava nie je pre tento jazyk k dispozícii.

Dôležité rýchlych opráv systému Windows Vista a Windows Server 2008 sa nachádzajú v rovnakých balíkoch. Však iba jeden z týchto produktov môže uvedené na stránke "Rýchla oprava žiadosť". Ak chcete požiadať o opravu hotfix, ktorá je určená pre systém Windows Vista a Windows Server 2008, stačí vybrať produkt, ktorý je uvedený na stránke.

Požiadavky

Neexistujú žiadne požiadavky.

Požiadavka na reštartovanie

Po použití tejto rýchlej opravy je nutné reštartovať počítač.

Informácie o nahradení rýchlej opravy

Táto rýchla oprava nenahrádza žiadne iné rýchle opravy.

Informácie o súboroch

Anglická verzia tejto rýchlej opravy má atribúty súborov (alebo novšie atribúty) uvedené v nasledujúcej tabuľke. Dátumy a čas jednotlivých súborov sú uvedené vo formáte koordinovaného svetového času (UTC). Pri zobrazení informácií o súbore sa dátumy a čas prevedú na miestny čas. Ak chcete vyhľadať rozdiely medzi časom UTC a miestnym časom, použite kartu Časové pásmo v položke Dátum a čas v ovládacom paneli.

X86-bitové verzie systému Windows Server 2008

Názov súboru

Verzia súboru

Veľkosť súboru

Dátum

Čas

Platforma

Localspl.dll

6.0.6001.22200

634,368

11-Jun-2008

05:23

x86

Spoolss.dll

6.0.6001.22200

163,840

11-Jun-2008

05:23

x86

Spoolsv.exe

6.0.6001.22200

126,976

11-Jun-2008

03:41

x86

Windows Server 2008, verzie pre procesory Itanium

Názov súboru

Verzia súboru

Veľkosť súboru

Dátum

Čas

Platforma

Priečinok služby

Localspl.dll

6.0.6001.22200

1,617,920

11-Jun-2008

05:36

IA-64

Nie je k dispozícii

Spoolss.dll

6.0.6001.22200

446,464

11-Jun-2008

05:39

IA-64

Nie je k dispozícii

Spoolsv.exe

6.0.6001.22200

437,248

11-Jun-2008

04:19

IA-64

Nie je k dispozícii

Localspl.dll

6.0.6001.22200

634,368

11-Jun-2008

05:23

x86

SysWOW64

Spoolss.dll

6.0.6001.22200

163,840

11-Jun-2008

05:23

x86

SysWOW64

Windows Server 2008, verzie s procesorom x64

Názov súboru

Verzia súboru

Veľkosť súboru

Dátum

Čas

Platforma

Priečinok služby

Localspl.dll

6.0.6001.22200

788,480

11-Jun-2008

05:50

x64

Nie je k dispozícii

Spoolss.dll

6.0.6001.22200

241,664

11-Jun-2008

05:50

x64

Nie je k dispozícii

Spoolsv.exe

6.0.6001.22200

268,800

11-Jun-2008

04:26

x64

Nie je k dispozícii

Localspl.dll

6.0.6001.22200

634,368

11-Jun-2008

05:23

x86

SysWOW64

Spoolss.dll

6.0.6001.22200

163,840

11-Jun-2008

05:23

x86

SysWOW64

Stav

Spoločnosť Microsoft potvrdila, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v časti Vzťahuje sa na.

Ďalšie informácie

Ďalšie informácie o terminológii z oblasti aktualizácií softvéru získate po kliknutí na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:

824684 Popis štandardnej terminológie použitej na popis aktualizácií softvéru od spoločnosti Microsoft

Potrebujete ďalšiu pomoc?

Chcete ďalšie možnosti?

Môžete preskúmať výhody predplatného, prehľadávať školiace kurzy, naučiť sa zabezpečiť svoje zariadenie a ešte oveľa viac.

Komunity pomôžu s kladením otázok a odpovedaním na ne, s poskytovaním pripomienok a so získavaním informácií od odborníkov s bohatými znalosťami.

Boli tieto informácie užitočné?

Aká je podľa vás jazyková kvalita textu?
Čo sa vám páčilo, prípadne čo nie?
Stlačením tlačidla Odoslať sa vaše pripomienky použijú na zlepšenie produktov a služieb spoločnosti Microsoft. Váš správca IT bude môcť tieto údaje zhromažďovať. Vyhlásenie o ochrane osobných údajov.

Ďakujeme za vaše pripomienky!

×