Beräkna schema- och kostnadsprestandaindex i Microsoft Project

Sammanfattning

I Microsoft Project beräknas inte Schedule Performance Index (SPI) eller Cost Performance Index (CPI). Den här artikeln innehåller ett exempelmakro som beräknar SPI och KPI för varje uppgift i ett projekt.

NOTERA: SPI är förhållandet mellan utfört arbete och planerat arbete (BCWP/BCWS). KPI är förhållandet mellan budgeterade kostnader och faktiska kostnader (BCWP/ACWP).

Mer information

NOTERA: Microsoft tillhandahåller endast programmeringsexempel i visningssyfte, utan att någon form av garanti uttrycks eller är underförstådd. Detta omfattar men är inte begränsat till underförstådda garantier för säljbarhet eller lämplighet för ett visst ändamål. Den här artikeln förutsätter att du är bekant med programmeringsspråket som demonstreras och med de verktyg som används för att skapa och felsöka procedurer. Microsofts supporttekniker kan hjälpa till att förklara funktionaliteten i en viss procedur, men de kommer inte att ändra dessa exempel för att tillhandahålla ytterligare funktioner eller konstruera procedurer för att uppfylla dina specifika krav. 

Följande makro beräknar Schedule Performance Index (SPI) och Cost Performance Index (CPI) för varje aktivitet och placerar resultaten i numeriska fält. SPI för varje aktivitet är lika med BCWP/BCWS. CPI för varje aktivitet är lika med BCWP/ACWP.

Så här skapar du makrot:

  1. På menyn Verktyg pekar du på Makro och klickar på Makron. I Project 2010 går du till fliken Visa och klickar på knappen Makron .

  2. Skriv "CalcSPI_CPI" i fältet Makronamn och klicka sedan på Skapa för att öppna Visual Basic Editor.

  3. Skapa makrot genom att skriva följande subrutin.
    Sub CalcSPI_CPI()
    Dim t som uppgift
    För varje t I ActiveProject.Tasks
      Om inte t är ingenting så
        Om t.BCWS <> 0 Då
            t.Number10 = t.BCWP / t.BCWS 'detta beräknar SPI
        End If
        Om t.ACWP <> 0 Då
            t.Number11 = t.BCWP / t.ACWP 'detta beräknar KPI
        End If
      End If
    Nästa t
    End Sub

    NOTERA: I det här exemplet används fälten Tal10 och Tal11. Du kan använda något av de andra numeriska och alfanumeriska fälten som är tillgängliga. Du kan också formatera resultatet med funktionen Format.

  4. Klicka på Stäng och återgå till Microsoft Project på Arkiv-menyn i Visual Basic Editor.

  5. Peka på Makro på Verktyg-menyn i Microsoft Project och klicka sedan på Makron. I Project 2010 går du till fliken Visa och klickar på knappen Makron .

  6. Klicka på CalcSPI_CPI i listan med makron. Klicka på Kör.

Om du vill se resultatet av makrot infogar du fälten Tal10 och Tal11 i en aktivitetstabell. Gör följande:

  1. Klicka på Kolumn på Infoga-menyn.

    I Project 2010 går du till fliken Format och klickar på knappen Infoga kolumn .

  2. Klicka på Tal10 i listan Fältnamn.

  3. Klicka på OK.

  4. Upprepa steg 1–3 för fältet Tal11 .