Tabellerna AsyncOperationBase och WorkflowLogBase blir mycket stora och prestandaproblem uppstår när du använder många arbetsflöden i Microsoft Dynamics CRM 4.0

Gäller för
Dynamics CRM 4.0

Symptom

Du använder många arbetsflöden i Microsoft Dynamics CRM 4.0. Tabellerna AsyncOperationBase och WorkflowLogBase blir mycket stora och prestandaproblem uppstår.

Orsak

Det här problemet uppstår eftersom en arbetsflödesinstans och en arbetsflödespost skapas i tabellerna AsyncOperationBase och WorkflowLogBase i MSCRM-databasen när arbetsflödesreglerna startas. Men när arbetsflödesinstansen är klar finns arbetsflödesposten kvar i databasen. Därför fortsätter tabellerna AsyncOperationBase och WorkflowLogBase att växa. Till slut minskar prestandan.

Obs! Egenskapen AsyncOperationType för dessa poster är inställd på 10.

Lösning

Det här problemet är åtgärdat i den senaste samlade uppdateringen för Microsoft Dynamics CRM 4.0.
  Om du vill ha mer information klickar du på följande artikelnummer för att visa artikeln i Microsoft Knowledge Base:

949256 Microsoft Dynamics CRM 4.0-uppdateringar och snabbkorrigeringar

Viktigt Det här avsnittet, metoden eller uppgiften innehåller steg som beskriver hur du ändrar registret. Allvarliga problem kan dock uppstå om du ändrar registret på fel sätt. Se därför till att du följer de här stegen noggrant. För ytterligare skydd bör du säkerhetskopiera registret innan du ändrar det. Du kan då återställa registret om det uppstår problem. Om du vill ha mer information om hur du säkerhetskopierar och återställer registret klickar du på följande artikelnummer för att visa artikeln i Microsoft Knowledge Base:

322756 Så här säkerhetskopierar och återställer du registret i Windows

När du har installerat snabbkorrigeringen går du till avsnittet Åtgärda det åt mig om du vill att vi ska aktivera den här snabbkorrigeringen åt dig. Om du föredrar att aktivera snabbkorrigeringen själv går du till avsnittet "Låt mig åtgärda det själv".

Lös det åt mig

            
Om du vill aktivera snabbkorrigeringen automatiskt klickar du på knappen Eller länken Åtgärda det . Klicka sedan på Kör i dialogrutan Filhämtning och följ anvisningarna i guiden Åtgärda det.

            
            
Anteckningar

  • Den här guiden kan endast finnas på engelska. Den automatiska korrigeringen fungerar dock även för andra språkversioner av Windows.
  • Om du inte befinner dig på den dator som har problemet sparar du Fix it-lösningen på ett flashminne eller en CD-skiva och kör den sedan på den dator som har problemet.

Gå sedan till avsnittet "Löste det här problemet?".

Låt mig åtgärda det själv

Så här aktiverar du den här snabbkorrigeringen:

  1. Klicka på Start, klicka på Kör, skriv regedit och klicka sedan på
    OK.

  2. Leta reda på följande undernyckel i Registereditorn:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM

  3. Avgöra om det finns en DWORD-registerpost med namnet AsyncRemoveCompletedWorkflows. Värdedata för registerposten AsyncRemoveCompletedWorkflows måste vara 1.

  4. Om registerposten AsyncRemoveCompletedWorkflows inte finns lägger du till posten. Gör följande:

    1. Högerklicka på MSCRM, peka på
      Nytt, klicka på DWORD-värde och skriv sedan
       AsyncRemoveCompletedWorkflows i
      Namnruta .

    2. Dubbelklick
      AsyncRemoveCompletedWorkflows och skriv sedan
       1 i rutan Värdedata .

    3. Klicka på Start, klicka på
      Kör, skriv iisreset och klicka sedan på
      OK.

      Obs! Om värdet i rutan Värdedata för DWORD-värdet för AsyncRemoveCompletedWorkflows återgår till 0 fortsätter Microsoft Dynamics CRM att behålla arbetsflödesposterna i databasen även om uppgifterna är slutförda.

Obs! Den här snabbkorrigeringen är endast proaktiv. När snabbkorrigeringen installeras och aktiveras tas därför bara nya arbetsflödesposter bort automatiskt. Om tabellerna AsyncOperationBase och WorkflowLogBase redan är stora på grund av dessa arbetsflödesposter måste du rensa tabellerna med hjälp av Microsoft SQL Server rensningsskript som ingår i följande Microsoft Knowledge Base-artikel:

968520 Prestanda är långsam om AsyncOperationBase-tabellen blir för stor i Microsoft Dynamics CRM 4.0

Löste detta problemet?

  • Kontrollera om problemet är åtgärdat. Om problemet är åtgärdat är du klar med det här avsnittet. Om problemet inte är åtgärdat kan du kontakta supporten.
  • Vi skulle uppskatta din feedback. Lämna feedback eller rapportera eventuella problem med den här lösningen genom att lämna en kommentar på bloggen "Åtgärda det åt mig" eller skicka ett e-postmeddelande till oss.

Mer information

Om du vill ha mer information om terminologi för programuppdateringar klickar du på följande artikelnummer för att visa artikeln i Microsoft Knowledge Base:

824684 Beskrivning av standardterminologin som används för att beskriva Microsofts programuppdateringar Om du vill ha mer information om snabbkorrigeringar och uppdateringspaketterminologi för Microsoft Business Solutions CRM klickar du på följande artikelnummer för att visa artikeln i Microsoft Knowledge Base:

887283 namnstandarder för namn på paket i Microsoft Business Solutions CRM