Symptom
När du besöker någon av de projektrelaterade sidorna, till exempel tids post, utgifts registrering, Communicator-delen, projekt analytikern och projekt analysen i Business Portal, får du ett långt rött fel meddelande som liknar något av följande:
Fel meddelande 1:
Fel: bifogad fil: högsta tillåtna försök för anslutningen överskreds. HRESULT = 0x80004005: Ospecificerat fel-klient: ett oväntat fel uppstod under bearbetningen av denna begäran. HRESULT = 0x80004005: Ospecificerat fel-klient: det gick inte att skicka SOAP-meddelandet, eller så har inget identifierbart svar tagits emot HRESULT = 0x80004005: Ospecificerat fel-klient: Ospecificerat klient fel. HRESULT = 0x80004005: Ospecificerat fel faultcode = klient faultstring = bilaga: högsta tillåtna försök för anslutningen överskreds.
Se lösningarna 6, 7, 8 och 9
Fel meddelande 2:
Koppling: tids gräns för anslutning upprättas. HRESULT = 0x800A1527-client: ett oväntat fel uppstod under bearbetningen av denna begäran. HRESULT = 0x800A1527-client: det gick inte att skicka SOAP-meddelandet eller inget identifierbart svar togs emot HRESULT = 0x800A1527-client: Ospecificerat klient fel.
Se lösningarna 6, 7, 8 och 9
Fel meddelande 3:
Koppling: ogiltigt certifikat. HRESULT = 0x800A1529-client: ett oväntat fel uppstod under bearbetningen av denna begäran. HRESULT = 0x800A1529-client: det gick inte att skicka SOAP-meddelandet eller inget identifierbart svar togs emot HRESULT = 0x800A1529-client: Ospecificerat klient fel. HRESULT=0x800A1529
Se lösning 6 och 9
Fel meddelande 4:
Koppling: Ospecificerat HTTP-fel. HRESULT = 0x800A1518-client: ett oväntat fel uppstod under bearbetningen av denna begäran. HRESULT = 0x800A1518-client: det gick inte att skicka SOAP-meddelandet eller inget identifierbart svar togs emot HRESULT = 0x800A1518-client: Ospecificerat klient fel. HRESULT=0x800A1518
Se lösningarna 6, 7, 8 och 9
Fel meddelande 5:
Anslutnings fel.: inget matchande autentiseringsschema aktive ras i kopplingen. HRESULT = 0x80004005: Ospecificerat fel-klient: ett oväntat fel uppstod under bearbetningen av denna begäran. HRESULT = 0x80004005: Ospecificerat fel-klient: det gick inte att skicka SOAP-meddelandet, eller så har inget identifierbart svar tagits emot HRESULT = 0x80004005: Ospecificerat fel-klient: Ospecificerat klient fel. HRESULT = 0x80004005: Ospecificerat fel
Se lösningarna 7 och 9
Fel meddelande 6:
Klient: det gick inte att läsa in begäran i SoapReader. HRESULT = 0x80070057: parametern är felaktig. -Client: Ospecificerat klient fel. HRESULT = 0x80070057: parametern är felaktig. faultcode = klient.
Se lösningarna 6, 7, 8 och 9
Fel meddelande 7:
Programmet kan inte öppna system databasen. [DBNETLIB] [ConnectionOpen (Connect ()).] SQL Server finns inte eller åtkomst nekades.System administratören bör köra pcConfiguration på Business Portal-servern för att åtgärda problemet.
Se lösningarna 5 och 9
Fel meddelande 8:
Ett fel har uppstått. Fel: det gick inte att öppna system databasen. (pcconnect)
Se lösningarna 1, 2, 3, 4 och 9
Fel meddelande 9:
Programmet kan inte läsa Solomon Connection information. System administratören bör köra pcConfiguration på Business Portal-servern för att åtgärda problemet
Se lösningarna 1, 2, 3, 4 och 9
Fel meddelande 10:
Det går inte att ansluta till system databasen med PCConfiguration. Ogiltigt användar namn och lösen ord.
Se lösningarna 4 och 9
Fel meddelande 11:
Fel: SOAP-klient: ett fel uppstod vid bearbetning av SOAP-begäran. Ogiltig sökväg för PCService. asmx angivet i ProjectService. wsdlYour system administratören bör köra pcConfiguration-Update web service på Business Portal-servern för att åtgärda problemet.
Se lösningarna 6 och 9
Orsak
För att Project-sidorna ska fungera måste Internet Information Services (IIS) kunna förbereda och skicka en SOAP-begäran (Simple Object Access Protocol) till PCService. asmx-filen. Det finns flera saker som måste konfigureras för att det ska fungera. Om ett eller flera av följande inte konfigureras korrekt kan det orsaka felet i avsnittet "Symptom":
-
Inloggnings informationen för Microsoft Dynamics SL-databasen saknas eller lagras felaktigt i registret.
-
Microsoft. Solomon. PMA. Security. ImpersonateDLL. dll saknas, är inte registrerat, eller så har användarna inte behörighet till filen.
-
Identiteten för programpoolen har inte behörighet till register nyckel för HKEY_LOCAL_MACHINE \SOFTWARE\Microsoft\Business Portal\PMA\Solomon
-
Filen CAPICOM. dll saknas, inte är registrerad, av en felaktig version eller att användarna inte har behörighet till den
-
IIS-servern och SQL-servern måste kunna kommunicera via TCP/IP-protokollet
-
Sökvägen till PCService. ASX-filen i ProjectService. WSDL är felaktig
-
Sökvägen måste peka på namnet på IIS-servern
-
Sökvägen måste innehålla port numret
-
Sökvägen måste vara en URL som inte är SSL
-
Om du använder IIS-värdhuvuden måste sökvägen matcha den korrekta webbplatsen
-
-
IIS-webbplatsen använder inte Windows-inloggningsautentisering (NTLM)
-
Variabeln SessionState i Web. config är felaktigt angiven
Fel meddelandet innehåller normalt inte mycket information om vilka av de föregående objekten som är felaktiga. Vi rekommenderar att du provar alla möjliga lösningar.
Lösning
Lösning 1 – Kör verktyget PCConfiguration
-
Gå till PCConfiguration. exe-filen på Business Portal-servern och dubbelklicka för att köra. Den finns vanligt vis i mappen c:\Inetpub\wwwroot\bin eller i mappen C:\Inetpub\wwwroot\wss\VirtualDirectories\80\bin
-
Fyll i följande rutor:
-
SQL Server-namn – Ange namnet på SQL Server som är värd för Microsoft Dynamics SL-databaserna
-
System DB – ange namnet på databasen för Microsoft Dynamics SL-systemet
-
SQL-användare-ange namnet på en SQL-användare som har till gång till system databasen. "SA" eller "BusinessPortalUser" är vanliga alternativ.
-
Lösen ord – ange lösen ordet för den användare som anges i rutan SQL-användare
-
-
Klicka på Testa anslutning. Om du får ett fel meddelande granskar du värdena i steg 2. Obs! Den här knappen kanske inte utför åtgärden på grund av bugg 55474.
-
Klicka på Uppdatera registret. Du bör få följande meddelande: "informationen har skrivits till registret"
-
Stäng verktyget och försök igen.
Lösning 2 – kontrol lera filen Microsoft. Solomon. PMA. Security. ImpersonateDLL. dll
-
Starta IIS-hanteraren (Internet Information Services) på Skype-servern
-
Högerklicka på webbplatsen för Business Portal och välj ' Egenskaper '
-
Under fliken Start Katalog kan du anteckna värdet i rutan "lokal sökväg"
-
Gå till fliken Start Katalog och anteckna värdet i kombinations rutan "programpool"
-
Klicka på OK för att stänga fönstret "egenskaper"
-
Expandera "programpooler" i IIS Manager. Högerklicka på den programpool som finns på steg 4 och välj "egenskaper".
-
Notera den användare som angetts som programpoolsidentitet under fliken identitet.
-
Klicka på OK för att stänga fönstret "egenskaper".
-
Stäng av IIS Manager
-
I Utforskaren i Windows bläddrar du till katalogen som hittats i steg 3
-
Bläddra nedåt i mappen bin och leta reda på filen Microsoft. Solomon. PMA. Security. ImpersonateDLL. dll.
-
Om filen saknas kan du behöva installera om företags portalen
-
-
Högerklicka på filen och välj egenskaper
-
Under fliken "säkerhet" ser du till att användaren från steg 7 har "Läs" och "Läs & kör rättigheter"
-
Klicka på OK för att stänga fönstret "egenskaper"
-
Högerklicka på filen igen och välj "öppna med..."
-
Välj "Välj program från en lista"
-
Klicka på "Bläddra..."
-
Bläddra till C:\Windows\System32-mappen och leta reda på filen Regsvr32. exe och klicka på "öppna"
-
Klicka på OK. Du bör få följande meddelande: "DllRegisterServer i C:\Inetpub\wwwroot\bin\Microsoft.Solomon.Pma.Security.ImpersonateDLL.dll lyckades."
-
Försök att läsa in Business Portal-sidorna igen
Lösning 3 – kontrol lera register nyckel
-
Starta IIS-hanteraren (Internet Information Services) på Skype-servern
-
Högerklicka på webbplatsen för Business Portal och välj egenskaper
-
Notera värdet i kombinations rutan "programpool" på fliken Start Katalog
-
Klicka på OK för att stänga dialog rutan egenskaper och stänga av IIS Manager
-
Klicka på Start-> kör och skriv RegEdt32. Då öppnas Registereditorn
-
Gå till HKEY_LOCAL_MACHINE \SOFTWARE\Microsoft\Business Portal\PMA\Solomon
-
Om den här register nyckel saknas läser du lösning 1 för att köra verktyget PCConfiguration
-
-
Högerklicka på "Solomon" och välj "Permissions"
-
Se till att användaren från steg 3 har behörigheten läsa
-
Försök att läsa in Business Portal-sidorna igen
Mer information finns i Knowledge Base- artikeln 912363 .
Lösning 4 – kontrol lera filen CAPICOM. dll
-
Gå till mappen C:\Windows\System32 på Business Portal-servern
-
Högerklicka på CAPICOM. DLL och välj ' Egenskaper '
-
Om filen saknas kan du behöva kopiera filen från en annan arbets Station eller installera om Business Portal
-
-
Under fliken version kontrollerar du att fil versionen visar 2.1.0.1
-
Om fil versionen är felaktig kan du behöva kopiera filen från en annan arbets Station eller installera om Business Portal
-
-
På fliken säkerhet kontrollerar du att gruppen domän \ användare har Läs-och Läs-& kör rättigheter för den här filen. SeKnowledge Base-artikel 927618
-
Klicka på OK för att stänga dialog rutan Egenskaper
-
Högerklicka på filen igen och välj "öppna med..."
-
Välj "Välj program från en lista"
-
Klicka på "Bläddra..."
-
Bläddra till C:\Windows\System32-mappen och leta upp filen Regsvr32. exe och klicka på öppna.
-
Klicka på OK. Du bör få följande meddelande: "DllRegisterServer i C:\WINDOWS\system32\capicom.dll lyckades."
-
Försök att läsa in Business Portal-sidorna igen
-
Om du fortfarande får felet:
-
Se lösning 1 för att köra verktyget PCConfiguration igen.
-
Starta om IIS genom att klicka på Start > kör och skriv "IISReset"
-
Försök att läsa in Business Portal-sidorna igen
-
Mer information finns i Knowledge Base- artikeln 909144 .
Lösning 5 – Kontrol lera IIS-servern och SQL-servern kan kommunicera via TCP/IP-protokollet
-
TCP/IP-protokollet bör vara aktiverat på både SQL Server och på den server som kör IIS-värd för Business Portal-webbplatser.
-
Information om hur du kontrollerar detta finns i Knowledge Base-artikeln 954024
Lösning 6 – kontrol lera sökvägen till PCService. ASX-filen i filen ProjectService. WSDL
-
Gå till ProjectService. WSDL-filen på Business Portal-servern. Den finns vanligt vis i mappen C:\Program Files\Microsoft Dynamics\Business Portal\Applications\PMA.
-
Öppna filen i anteckningar
-
Bläddra till slutet av filen och leta reda på taggen som börjar med "<SOAP: Address location ="
-
Det ska finnas en URL-adress till PCService. asmx-filen i den här taggen. Det ska se ut så här: "HTTP://dator namn: 80/BusinessPortal/Applications/PMA/PCService. asmx" denna URL har flera specifika krav. Kontrol lera och korrigera följande objekt efter behov:
-
URL-adressen måste innehålla dator namnet (till exempel BPSERVER). IP-adresser (till exempel 192.168.0.10), localhost eller ett domän namn (till exempel BP.contoso.com) fungerar inte för SOAP-begäranden.
-
Du hittar dator namnet genom att klicka på Start-> kör och skriv CMD
-
Ange värdnamn och tryck på RETUR
-
Namnet på datorn ska returneras. Dator namn i URL-adressen måste ställas in så att det matchar detta.
-
-
URL-adressen bör inte använda SSL. URL-adressen ska börja med "http://" och inte "https://"
-
Om du har en webbplats som kräver SSL läser du Knowledge Base-artikel 924723 för anvisningar om hur du konfigurerar ett undantag för att tillåta en icke-SSL-anslutning till PCService. asmx-filen.
-
-
URL-adressen ska matcha BusinessPortal webbplats i IIS
-
Detta kan vara ett problem om du använder värdhuvuden för att skilja mellan flera webbplatser som körs på samma server.
-
Mer information finns i Knowledge Base- artikeln 2005711 .
-
-
-
Testa URL-adressen för att kontrol lera att den är giltig. För att göra det kopierar du webb adressen och klistrar in den i Internet Explorer på Skype-servern. Den ska öppna en sida med namnet "PCServices". Om du får ett fel meddelande om att ett SharePoint-felmeddelande visas eller om det inte går att visa sidan kan du kontrol lera objekten i steg 4.
-
Nu när ProjectService. WSDL-filen har en giltig URL-adress kan du försöka med att använda sidorna för företag igen
Mer information finns i Knowledge Base- artikeln 892356 eller i Knowledge Base- artikeln 897024 .
Lösning 7 – kontrol lera AUTENTISERINGSMETODEN i IIS
-
Starta IIS-hanteraren (Internet Information Services) på Skype-servern
-
Högerklicka på webbplatsen för Business Portal och välj egenskaper
-
Klicka på Redigera i avsnittet "inloggningsautentisering och åtkomst kontroll" under fliken Katalog säkerhet...
-
Kontrol lera att "integrerad Windows-autentisering" är markerad
-
Se till att "Aktivera anonym åtkomst", "sammanfattad autentisering för Windows-domänservrar" och ".NET Passport-autentisering" är avmarkerat
-
"Grundläggande auktorisering" behöver inte kontrol leras. Men det bör inte orsaka ett problem om det är markerat
-
Klicka på OK och sedan på OK igen för att stänga dialog rutan Egenskaper
-
Stäng av IIS Manager
-
Starta om IIS genom att klicka på Start > kör och skriv "IISReset"
-
Prova med att använda Business Portal-sidorna igen
Lösning 8 – verifiera sessionState-variabeln i Web. config-filen
-
Starta IIS-hanteraren (Internet Information Services) på Skype-servern
-
Högerklicka på webbplatsen för Business Portal och välj egenskaper
-
Notera värdet i rutan "lokal sökväg" på fliken Start Katalog
-
Klicka på OK för att stänga dialog rutan egenskaper och stänga av IIS Manager
-
Gå till katalogen som hittats i steg 3 och leta reda på filen Web. config
-
Gör en säkerhets kopia av filen Web. config
-
Öppna filen Web. config i anteckningar
-
Hitta taggen som börjar med "<sessionState"
-
Ändra hela taggen till "<sessionState-läge =" InProc "/>"
-
Spara filen och Stäng Anteckningar
-
Starta om IIS genom att klicka på Start > kör och skriv "IISReset"
-
Försök att läsa in Business Portal-sidorna igen
Lösning 9 – kör PCConnectDebug-skriptet och skicka resultatet till support.
-
Ladda ned B2004933_pcConnectDebug. zip
-
Packa upp filen på Business Portal-servern
-
Kopiera filen "pcConnectDebug. asp" till mappen C:\Program Files\Microsoft Dynamics\Business Portal\Applications\PMA.
-
På Business Portal-servern öppnar du Internet Explorer och loggar in på Business Portal
-
Klicka på webb sidan projekt Center
-
Klistra in följande URL för att öppna sidan PCConnectDebug: http://servername:port/BusinessPortal/Applications/PMA/pcconnectdebug.asp ersätter "servername" med namnet på BP-servern. Byt ut "Port" mot Port numret som webbplatsen körs under.
-
Du uppmanas att klicka på OK för att fortsätta. Klicka på OK.
-
En webb sida visas som börjar med "starta debug...". I Internet Explorer klickar du på Arkiv-> Spara som... och spara sidan i en fil.
-
Varning: beroende på hur långt det går att nå kan resultatet innehålla ett lösen ord i klartext. Du kan redigera filen i anteckningar och ersätta det faktiska lösen ordet med ordet "thePassword" innan du skickar filen till support.
-
-
Skicka denna fil till Microsofts kund support för att få mer analys.
-
När problemet är löst tar du bort filen pcConnectDebug. asp från katalogen C:\Program\Microsoft Dynamics\Business Portal\Applications\PMA.