การติดตั้ง Office 2010 หยุดที่ขั้นตอนที่ 4 จาก 4 และคุณได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้: "เกิดปัญหาขณะติดตั้ง Microsoft Office"

อาการ

ในระหว่างการติดตั้ง Microsoft Office Home and Student 2010 หรือ Home and Business 2010 การติดตั้งอาจหยุดในขั้นตอนที่ 4 จาก 4 และคุณได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้:

เกิดปัญหาขณะติดตั้ง Microsoft Office <edition> 2010: เกิดปัญหาขณะติดตั้ง Microsoft Office พยายามรันการติดตั้งอีกครั้ง หากปัญหายังคงเกิดขึ้นอีก ติดต่อแผนกสนับสนุนผลิตภัณฑ์ Microsoft

หมายเหตุ ปัญหานี้อาจเกิดขึ้นเมื่อคุณพยายามที่จะใช้ Office Starter 2010

สาเหตุ

ข้อความแสดงข้อผิดพลาดเฉพาะสำหรับการติดตั้งคลิก-ทู-รัน และอาจเกิดขึ้นหากค่าสตริง AppData ไม่ได้ชี้ไปที่ตำแหน่งที่ตั้งที่ถูกต้องในคีย์ย่อยของรีจิสทรีต่อไปนี้:

HKEY_USERS\S-1-5-18\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

ค่าต้องค้นหาตำแหน่ง %USERPROFILE%\Application Data ใน Windows XP และตำแหน่ง %USERPROFILE%\AppData\Roaming ใน Windows Vista หรือ Windows 7

การแก้ไข

หากคุณกำลังติดตั้ง Office Home and Student 2010 หรือ Home and Business 2010 ให้ลองวิธีต่อไปนี้ที่แสดงไว้ในส่วนนี้ หากยังคงเกิดปัญหาขึ้นอยู่ ให้ไปที่ส่วน "วิธีแก้ไขปัญหา" ที่อยู่ในบทความนี้เพื่อใช้วิธีการติดตั้งแบบดั้งเดิมสำหรับ Office รุ่นเหล่านี้

วิธีที่ 1: ปรับเปลี่ยนรีจิสทรีของ Windows

สิ่งสำคัญ ส่วน วิธีการ หรืองานนี้ประกอบด้วยขั้นตอนต่างๆ ที่จะบอกคุณเกี่ยวกับวิธีการปรับเปลี่ยนรีจิสทรี อย่างไรก็ตาม อาจเกิดปัญหาร้ายแรงได้หากคุณแก้ไขรีจิสทรีไม่ถูกต้อง ดังนั้น ตรวจสอบว่าคุณทำตามขั้นตอนเหล่านี้อย่างระมัดระวัง เพื่อเพิ่มการป้องกัน ให้สำรองข้อมูลรีจิสทรีก่อนแก้ไข จากนั้น คุณอาจกู้คืนรีจิสทรีได้หากมีปัญหาเกิดขึ้น สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีสำรองและกู้คืนรีจิสทรี คลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base:
322756 วิธีการสำรองข้อมูลและคืนค่ารีจิสทรีใน Windows

เพื่อให้เราแก้ปัญหานี้ให้คุณ ไปที่ส่วน "แก้ปัญหาให้ฉัน" หากคุณต้องการแก้ปัญหานี้ด้วยตนเอง ไปที่ส่วน "ฉันจะแก้ปัญหาด้วยตนเอง"

แก้ปัญหาให้ฉัน



เพื่อแก้ปัญหานี้โดยอัตโนมัติ คลิกปุ่มหรือลิงก์ แก้ปัญหา ในกล่องโต้ตอบ ดาวน์โหลดไฟล์ คลิก Run แล้วทำตามขั้นตอนในวิซาร์ดแก้ปัญหา



หมายเหตุ
  • วิซาร์ดนี้อาจมีเฉพาะภาษาอังกฤษเท่านั้น แต่การแก้ปัญหาอัตโนมัติใช้ได้กับเวอร์ชันภาษาอื่นๆ ของ Windows ด้วย
  • หากคุณไม่ได้อยู่ที่คอมพิวเตอร์ที่เกิดปัญหา ให้บันทึกวิธีแก้ปัญหาในแฟลชไดร์ฟหรือซีดี แล้วรันบนคอมพิวเตอร์ที่เกิดปัญหา


ให้ฉันแก้ไขด้วยตนเอง


เพื่อแก้ปัญหานี้ ตรวจสอบข้อมูลค่าสำหรับ AppData ในรีจิสทรี โดยทำตามขั้นตอนของขั้นตอนที่ใช้กับระบบปฏิบัติการของคุณ

สำหรับผู้ใช้ Windows 7 และ Windows Vista
  1. คลิก Start แล้วไปที่ช่อง เริ่มค้นหา พิมพ์ regedit.exe
  2. ในรายการ Programs คลิกขวา regedit.exe แล้วคลิก Run as administrator หากคุณได้รับพรอมท์ให้ป้อนรหัสผ่านผู้ดูแลระบบหรือเพื่อยืนยัน พิมพ์รหัสผ่านหรือคลิก ทำต่อ เพื่อยืนยัน
  3. ค้นหาแล้วคลิกคีย์ย่อยรีจิสทรีต่อไปนี้:

    HKEY_USERS\S-1-5-18\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
  4. ในบานหน้าต่างรายละเอียดของโปรแกรมแก้ไขรีจิสทรี ค้นหาและคลิกขวา AppData แล้วคลิก แก้ไข
  5. ในช่อง ข้อมูลค่า พิมพ์ %USERPROFILE%\AppData\Roaming แล้วคลิก OK
  6. ปิดโปรแกรมแก้ไขรีจิสทรี
  7. รันการติดตั้ง Microsoft Office 2010 อีกครั้ง

สำหรับผู้ใช้ Windows XP
  1. คลิก Start แล้วคลิก Run
  2. ในช่อง Open พิมพ์ regedit.exe แล้วคลิก OK
  3. ค้นหาแล้วคลิกคีย์รีจิสทรีต่อไปนี้:

    HKEY_USERS\S-1-5-18\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
  4. ในบานหน้าต่างรายละเอียดของโปรแกรมแก้ไขรีจิสทรี ค้นหาและคลิกขวา AppData แล้วคลิก แก้ไข
  5. ในช่อง ข้อมูลค่า พิมพ์ %USERPROFILE%\Application Data แล้วคลิก OK
  6. ปิดโปรแกรมแก้ไขรีจิสทรี
  7. รันการติดตั้ง Microsoft Office 2010 อีกครั้ง


ตรวจสอบว่าปัญหานี้ได้รับการแก้ไขหรือไม่ หากปัญหานี้ได้รับการแก้ไข แสดงว่าคุณเสร็จสิ้นในส่วนนี้แล้ว หากปัญหายังไม่ได้รับการแก้ไข โปรดติดต่อแผนกสนับสนุน

การหลีกเลี่ยงปัญหา

เพื่อหลีกเลี่ยงข้อผิดพลาดในการติดตั้งคลิก-ทู-รัน ให้ใช้แฟ้ม MSI เพื่อทำตามวิธีแบบดั้งเดิมในการติดตั้ง Microsoft Office Home and Student 2010 หรือ Home and Business 2010

สิ่งสำคัญ Microsoft Office Starter 2010 ไม่มีวิธีการติดตั้งแฟ้ม MSI คุณจะไม่สามารถทำตามขั้นตอนในส่วนนี้เพื่อแก้ไขปัญหาได้ หากคุณพยายามที่จะใช้หรือติดตั้ง Office Starter 2010 บนคอมพิวเตอร์ของคุณ

ขั้นตอนที่ 1: เอา Microsoft Office Click-to-Run 2010 ออก

  1. คลิก เริ่ม
  2. คลิก โปรแกรมทั้งหมด แล้วเปิดโฟลเดอร์ เบ็ดเตล็ด (ผู้ใช้ Windows XP สามารถข้ามขั้นตอนนี้ได้)
  3. คลิก เรียกใช้ แล้วคลิกในกล่อง เปิด
  4. พิมพ์ appwiz.cpl แล้วคลิก ตกลง
  5. เลือก Microsoft Office Click-to-run 2010 ในรายการโปรแกรมที่ติดตั้งในปัจจุบัน
  6. คลิก ถอนการติดตั้ง (หรือ เอาออก สำหรับผู้ใช้ Windows XP) แล้วคลิก ใช่

ขั้นตอนที่ 2: ดาวน์โหลดและติดตั้งแฟ้ม MSI

หมายเหตุ คุณจะสามารถดาวน์โหลดแฟ้ม MSI ชนิดจำหน่ายปลีกอย่างสมบูรณ์ทางออนไลน์ได้ หากคุณซื้อ Office 2010 ทางออนไลน์ และได้ให้ Windows Live ID ไว้
  1. เข้าถึงบัญชีของคุณด้วยการใช้ข้อมูลประจำตัว Windows Live ID
  2. หากคุณได้เข้าสู่ระบบแล้ว คุณจะต้องคลิก บัญชีของฉัน ที่มุมขวาบนของหน้าจอ หากคุณไม่ได้เข้าสู่ระบบ ให้ป้อนข้อมูลประจำตัว Windows Live ID ของคุณ
    สิ่งสำคัญ คุณต้องป้อน Windows Live ID เดียวกับที่คุณใช้เมื่อคุณซื้อ Office 2010 ทางออนไลน์

  3. หลังจากที่คุณได้เข้าสู่ระบบแล้ว ให้ค้นหารุ่นของ Office 2010 ที่คุณซื้อ แล้วคลิก ดาวน์โหลด
    หมายเหตุ ข้อมูลนี้จะถูกวางไว้ที่ส่วน บัญชีของฉัน



  4. ในหน้าจอถัดไป ให้คลิก ตัวเลือกขั้นสูง ที่อยู่ใต้ปุ่ม ดาวน์โหลดตอนนี้



  5. เลือก 32 บิตหรือ 64 บิตเพื่อดาวน์โหลดแฟ้ม MSI ที่เหมาะสม ขนาดของแฟ้มนี้ควรจะอยู่ที่ประมาณ 600 เมกะไบต์



  6. เมื่อแฟ้มเสร็จสิ้นการดาวน์โหลดแล้ว ให้เรียกใช้แฟ้มเพื่อติดตั้ง Office 2010

ข้อมูลอ้างอิง

ข้อมูลเพิ่มเติมเกี่ยวกับคลิก-ทู-รันสำหรับ Office 2010:หากบทความนี้ไม่สามารถแก้ไขปัญหาของคุณได้ ให้ลองตัวเลือกการสนับสนุนอื่นๆ เหล่านี้:

ข้อมูลเพิ่มเติม

คุณสมบัติ

รหัสบทความ: 2445957 - การตรวจสอบครั้งสุดท้าย: 21 ต.ค. 2012 - ฉบับแก้ไข: 1

คำติชม