ข้ามไปที่เนื้อหาหลัก
การสนับสนุน
ลงชื่อเข้าใช้
ลงชื่อเข้าใช้ด้วย Microsoft
ลงชื่อเข้าใช้หรือสร้างบัญชี
สวัสดี
เลือกบัญชีอื่น
คุณมีหลายบัญชี
เลือกบัญชีที่คุณต้องการลงชื่อเข้าใช้

อาการ

พิจารณาสถานการณ์สมมติต่อไปนี้:

  • Update Rollup 6 สำหรับ Microsoft Exchange Server 2010 Service Pack 2 (SP2) หรือการปรับปรุงสะสมรุ่นที่ใหม่กว่าติดตั้งอยู่ในสภาพแวดล้อมที่ประกอบด้วยหลายไซต์ไดเรกทอรีที่ใช้งานอยู่

  • ไซต์มีเซิร์ฟเวอร์การเข้าถึงไคลเอนต์เชื่อมต่อกับอินเทอร์เน็ต

  • Url ภายใน และภายนอกถูกกำหนดค่าบนเซิร์ฟเวอร์การเข้าถึงไคลเอนต์เชื่อมต่อกับอินเทอร์เน็ต

  • คุณพยายามทำข้อมูลให้ตรงกับอุปกรณ์ไปยังกล่องจดหมาย โดยใช้ Microsoft Exchange ActiveSync (EAS)

  • อุปกรณ์ส่งคำขอ EAS ไปยังเซิร์ฟเวอร์การเข้าถึงไคลเอนต์ที่ไม่ได้อยู่ในไซต์ไดเรกทอรีที่ใช้งานอยู่ซึ่งเป็นตำแหน่งที่ตั้งของเซิร์ฟเวอร์กล่องจดหมาย

ในสถานการณ์สมมตินี้ อุปกรณ์ดึงการตอบสนองที่เปลี่ยนเส้นทาง HTTP 403 แทนที่จะตอบสนองการเปลี่ยนเส้นทาง HTTP 451 ที่คาดไว้ จากนั้น กระบวนการซิงโครไนส์ล้มเหลว

นอกจากนี้ เหตุการณ์ต่อไปนี้ถูกบันทึกไว้ในบันทึกของโปรแกรมประยุกต์:

Log Name: Application Source: MSExchange ActiveSync Date: Date and Time Event ID: 1044 Task Category: Requests Level: Warning Keywords: Classic User: N/A Computer: COMPUTER Description: The Client Access server doesn't have the InternalURL value set for the Microsoft-Server-ActiveSync virtual directory. This prevents Exchange ServiceDiscovery from finding the MobileSyncService information for user MBX server . At least one Client Access server in the user's mailbox Active Directory site must have the InternalURL value set. The format for the InternalURL value is https://hostname/Microsoft-Server-ActiveSync

หมายเหตุ

  • หากปัญหานี้เกิดขึ้นในการติดตั้งบนสถานเดียวของ Exchange Server 2010 รายการถูกบันทึกในแฟ้มบันทึกของ Internet Information Services (IIS) ต่อไปนี้คือ ตัวอย่างของรายการนี้:

    Date Time 214.21.84.142 POST /Microsoft-Server-ActiveSync/default.eas Cmd=Provision&DeviceType=DeviceType&User=user1 &DeviceId=DeviceId&Log=RdirTo:https%3a%2f%2fmail-eu.contoso.coml%2fMicrosoft-Server-ActiveSync_V25_LdapC1_Cpo19984_Fet20015_S130_Error:DiscoveryInfoMissing_Mbx:mbx1.contoso.com_Budget:(D)Conn%3a1%2cHangingConn%3a0%2cAD%3a%24null%2f%24null%2f0%25%2cCAS%3a%24null%2f%24null%2f0%25%2cAB%3a%24null%2f%24null%2f0%25%2cRPC%3a%24null%2f%24null%2f0%25%2cFC%3a%24null%2f0%2cPolicy%3aDefaultThrottlingPolicy%2cNorm_ 443 contoso\user1 192.168.0.20 UserAgent - 403 0 0 1477 523 20046

  • คุณสามารถใช้แบบสอบถาม Studio ตัวแยกวิเคราะห์แฟ้มบันทึกต่อไปนี้เพื่อระบุผู้ใช้ที่ได้รับผลกระทบเมื่อปัญหานี้เกิดขึ้น:

    SELECT COUNT(*) AS Hits, cs-username AS UserFROM '[LOGFILEPATH]' WHERE cs-uri-query LIKE '%DiscoveryInfoMissing%'
    GROUP BY User
    ORDER BY Hits DESC



สาเหตุ

ปัญหานี้เกิดขึ้นบนอุปกรณ์ Android และ Windows Phone 8 ได้เนื่องจากไม่ประกอบด้วยรายการของชนิดของอุปกรณ์และรูปแบบที่ผ่านการตรวจสอบ โดยDeviceCapability.RedirectDeviceTypesโครงสร้างชนิดและรุ่นของอุปกรณ์

ปัญหานี้เกิดขึ้นบนอุปกรณ์ iOS เครื่องคอมพิวเตอร์ Apple ได้เนื่องจากคำขอจากอุปกรณ์ iOS ไม่ประกอบด้วยข้อมูลรุ่น EAS หรือสายอักขระอุปกรณ์ ดังนั้น ฟังก์ชันDeviceCapabilityไม่เปลี่ยนเส้นทางการร้องขอ

การแก้ปัญหา

เมื่อต้องการแก้ไขปัญหานี้ ติดตั้ง update rollup ดังต่อไปนี้:

2866475คำอธิบายของการปรับปรุงค่าสะสม 2 สำหรับ Exchange Server 2010 SP3

สถานะ

Microsoft ยืนยันว่านี่เป็นปัญหาในผลิตภัณฑ์ของ Microsoft ซึ่งแสดงไว้ในส่วน "นำไปใช้กับ"

ข้อมูลเพิ่มเติม

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับปัญหานี้ คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:

2746164คำอธิบายของการปรับปรุงค่าสะสม 6 สำหรับ Exchange Server 2010 Service Pack ที่ 2

2751417การซิงโครไนส์ล้มเหลวถ้าคุณทำซิงค์อุปกรณ์ภายนอกไปยังกล่องจดหมายผ่าน EAS ในสภาพแวดล้อม Exchange Server 2010สำหรับข้อมูลเพิ่มเติมเกี่ยวกับ Studio ตัวแยกวิเคราะห์แฟ้มบันทึก ไปที่เว็บไซต์ของ Microsoft ต่อไปนี้:

ข้อมูลทั่วไปเกี่ยวกับ 2.0 Studio ตัวแยกวิเคราะห์แฟ้มบันทึก
ผลิตภัณฑ์ของบริษัทอื่นที่กล่าวถึงในบทความนี้ผลิตขึ้น โดยบริษัทที่ไม่ขึ้นอยู่กับ Microsoft ไมโครซอฟท์ไม่รับประกัน ทั้งโดยนัย หรืออย่างอื่น ใด เกี่ยวกับประสิทธิภาพหรือความน่าเชื่อถือของผลิตภัณฑ์เหล่านี้

ต้องการความช่วยเหลือเพิ่มเติมหรือไม่

ต้องการตัวเลือกเพิ่มเติมหรือไม่

สํารวจสิทธิประโยชน์ของการสมัครใช้งาน เรียกดูหลักสูตรการฝึกอบรม เรียนรู้วิธีการรักษาความปลอดภัยอุปกรณ์ของคุณ และอื่นๆ

ชุมชนช่วยให้คุณถามและตอบคําถาม ให้คําติชม และรับฟังจากผู้เชี่ยวชาญที่มีความรู้มากมาย

ข้อมูลนี้เป็นประโยชน์หรือไม่

คุณพึงพอใจกับคุณภาพภาษาเพียงใด
สิ่งที่ส่งผลต่อประสบการณ์ใช้งานของคุณ
เมื่อกดส่ง คำติชมของคุณจะถูกใช้เพื่อปรับปรุงผลิตภัณฑ์และบริการของ Microsoft ผู้ดูแลระบบ IT ของคุณจะสามารถรวบรวมข้อมูลนี้ได้ นโยบายความเป็นส่วนตัว

ขอบคุณสำหรับคำติชมของคุณ!

×