ข้ามไปที่เนื้อหาหลัก
การสนับสนุน
ลงชื่อเข้าใช้
ลงชื่อเข้าใช้ด้วย Microsoft
ลงชื่อเข้าใช้หรือสร้างบัญชี
สวัสดี
เลือกบัญชีอื่น
คุณมีหลายบัญชี
เลือกบัญชีที่คุณต้องการลงชื่อเข้าใช้

อาการ

หลังจากที่คุณดาวน์โหลดการปรับปรุงจากการปรับปรุงของ Windows บนคอมพิวเตอร์ที่ใช้ Windows Vista แล้ว คุณอาจประสบกับอาการต่อไปนี้

  • กล่องโต้ตอบปรากฏขึ้นและระบุว่ากระบวนการโฮสต์สำหรับWindows Services ไม่ทำงาน

  • หลังจากที่คุณเริ่มการทำงานของคอมพิวเตอร์ใหม่ กล่องโต้ตอบการปรับปรุงของ Windows จะปรากฏขึ้น ในกล่องโต้ตอบมีข้อความระบุไว้ดังนี้

    ไม่ได้ติดตั้งการปรับปรุงบางอย่าง

    ล้มเหลว การปรับปรุง xx
    พบข้อผิดพลาด

    รหัส 800706BA

  • เหตุการณ์ที่มีลักษณะเดียวกันนี้จะถูกบันทึกลงในบันทึกการทำงานของโปรแกรมประยุกต์

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากแฟ้มสถานะของ Background Intelligent Transfer Service (BITS) เสียหาย ปัญหานี้ทำให้กระบวนการโฮสต์สำหรับ Windows Services ไม่ทำงาน ปัญหานี้ทำให้คุณไม่สามารถใช้ BITS เพื่อถ่ายโอนแฟ้มได้

การแก้ไข

การปรับปรุงสำหรับแก้ไขปัญหานี้พร้อมให้บริการแล้ว เครื่องมือซ่อมแซม BITS จะช่วยแก้ไขปัญหาที่เกิดจากความเสียหายของแฟ้มสถานะของ BITS ปัญหาดังกล่าวทำให้กระบวนการโฮสต์สำหรับ Windows Services ไม่ทำงาน ปัญหานี้ทำให้คุณไม่สามารถใช้ BITS เพื่อถ่ายโอนแฟ้มได้ ใช้เครื่องมือนี้เพื่อแก้ไขความเสียหายและเปิดใช้งานการถ่ายโอนแฟ้มด้วย BITS อีกครั้ง หลังจากที่คุณเรียกใช้เครื่องมือนี้ คุณอาจต้องเริ่มการทำงานของคอมพิวเตอร์ใหม่อีกครั้ง

ข้อมูลการดาวน์โหลด

แฟ้มต่อไปนี้สามารถดาวน์โหลดได้จากศูนย์ดาวน์โหลด Microsoft:

Windows Vista รุ่น 32 บิต

ดาวน์โหลดแพคเกจ 940520 ทันที

Windows Vista รุ่น 64 บิต

ดาวน์โหลดแพคเกจ 940520 ทันที

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการดาวน์โหลดแฟ้มสนับสนุนของ Microsoft ให้คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base

119591 วิธีการขอรับแฟ้มสนับสนุนของ Microsoft จากบริการออนไลน์ (ลิงค์นี้อาจเชื่อมโยงไปยังเนื้อหาที่เป็นภาษาอังกฤษบางส่วน หรือทั้งหมด) Microsoft สแกนแฟ้มนี้เพื่อป้องกันไวรัสแล้ว Microsoft ใช้ซอฟต์แวร์ตรวจสอบไวรัสล่าสุด ณ วันที่มีการประกาศแฟ้มนั้นๆ แฟ้มดังกล่าวจะถูกจัดเก็บในเซิร์ฟเวอร์เพิ่มการรักษาความปลอดภัย ซึ่งช่วยป้องกันการเปลี่ยนแปลงแฟ้มโดยไม่ได้รับอนุญาต


คุณยังสามารถแก้ไขปัญหานี้ได้ด้วยตนเองโดยใช้วิธีใดวิธีหนึ่งต่อไปนี้

วิธีที่ 1

  1. เปิดใช้งานตัวเลือก แสดงแฟ้มที่ซ่อนไว้ โดยให้ทำตามขั้นตอนต่อไปนี้:

    1. คลิก เริ่ม คลิก แผงควบคุม คลิก ตัวเลือกโฟลเดอร์ แล้วคลิกแท็บ มุมมอง

    2. คลิก แสดงแฟ้มและโฟลเดอร์ที่ซ่อนไว้ แล้วคลิก ตกลง

  2. ในฐานะผู้ดูแลระบบ ให้ค้นหาโฟลเดอร์ Programdata\Microsoft\Network\Downloader แล้วลบแฟ้มทั้งหมดที่มีชื่อแฟ้มที่ขึ้นต้นด้วย Qmgr โดยให้ทำตามขั้นตอนต่อไปนี้:

    1. คลิก เริ่ม พิมพ์ \Programdata\Microsoft\network\downloader ในกล่อง เริ่มการค้นหา แล้วกด ENTER

    2. ในหน้าต่าง Downloader ให้เลือกแล้วลบแฟ้มที่ขึ้นต้นด้วย Qmgr ตัวอย่าง ให้ลบแฟ้มต่อไปนี้

      • Qmgr0.dat

      • Qmgr1.dat

      หมายเหตุ

      • หากไม่ลบแฟ้มดังกล่าว ให้เริ่มการทำงานของคอมพิวเตอร์ในเซฟโหมดที่ไม่มีระบบเครือข่าย โดยใช้วิธีที่ 2 หรือวิธีที่ 3

      • หากลบแฟ้มดังกล่าวเสร็จเรียบร้อยแล้ว ให้เปิดการปรับปรุงของ Windows ขึ้นทันที แล้วติดตั้งการปรับปรุงล่าสุด

วิธีที่ 2

  1. รีสตาร์ทคอมพิวเตอร์

  2. กดปุ่ม F8 ในขณะที่คอมพิวเตอร์เริ่มการทำงานใหม่

    หมายเหตุ คุณต้องกดปุ่ม F8 ก่อนที่ตัวบ่งชี้สถานะการทำงานของ Windows Vista ปรากฏ

  3. เมื่อเมนู ตัวเลือกการเริ่มระบบขั้นสูง ปรากฏ ให้ใช้ปุ่มลูกศรเพื่อเลือก เซฟโหมด แล้วกด ENTER

  4. เปิดใช้งานตัวเลือก แสดงแฟ้มที่ซ่อนไว้ โดยให้ทำตามขั้นตอนต่อไปนี้:

    1. คลิก เริ่ม คลิก แผงควบคุม คลิก ตัวเลือกโฟลเดอร์ แล้วคลิกแท็บ มุมมอง

    2. คลิก แสดงแฟ้มและโฟลเดอร์ที่ซ่อนไว้ แล้วคลิก ตกลง

  5. ในฐานะผู้ดูแลระบบ ให้ค้นหาโฟลเดอร์ Programdata\Microsoft\Network\Downloader แล้วลบแฟ้มทั้งหมดที่มีชื่อแฟ้มที่ขึ้นต้นด้วย Qmgr โดยให้ทำตามขั้นตอนต่อไปนี้:

    1. คลิก เริ่ม พิมพ์ \Programdata\Microsoft\network\downloader ในกล่อง เริ่มการค้นหา แล้วกด ENTER

    2. ในหน้าต่าง Downloader ให้เลือกแล้วลบแฟ้มที่ขึ้นต้นด้วย Qmgr ตัวอย่าง ให้ลบแฟ้มต่อไปนี้

      • Qmgr0.dat

      • Qmgr1.dat

  6. ให้เปิดการปรับปรุงของ Windows โดยทันที แล้วติดตั้งการปรับปรุงล่าสุด

วิธีที่ 3

  1. เริ่มการทำงานของคอมพิวเตอร์ใหม่ในเซฟโหมดโดยไม่มีระบบเครือข่าย โดยให้ทำตามขั้นตอนต่อไปนี้:

    1. ออกจากโปรแกรมที่เปิดอยู่ทั้งหมด


    2. คลิก เริ่ม พิมพ์ Run ในกล่อง เริ่มการค้นหา แล้วกด ENTER


    3. พิมพ์ msconfig แล้วคลิก ตกลง


      โปรแกรมอรรถประโยชน์ของการกำหนดค่าระบบจะปรากฏขึ้น

    4. คลิกแท็บ เริ่มระบบ คลิกเพื่อเลือกกล่องกาเครื่องหมาย การเริ่มระบบแบบปลอดภัย คลิกเพื่อเลือกกล่องกาเครื่องหมาย น้อยที่สุด แล้วคลิก ตกลง

    5. เริ่มการทำงานของคอมพิวเตอร์ใหม่เมื่อคุณได้รับการพร้อมท์

  2. เปิดใช้งานตัวเลือก แสดงแฟ้มที่ซ่อนไว้ โดยให้ทำตามขั้นตอนต่อไปนี้:

    1. คลิก เริ่ม คลิก แผงควบคุม คลิก ตัวเลือกโฟลเดอร์ แล้วคลิกแท็บ มุมมอง

    2. คลิก แสดงแฟ้มและโฟลเดอร์ที่ซ่อนไว้ แล้วคลิก ตกลง

  3. ในฐานะผู้ดูแลระบบ ให้ค้นหาโฟลเดอร์ "Programdata\Microsoft\Network\Downloader" แล้วลบแฟ้มทั้งหมดที่มีชื่อแฟ้มที่ขึ้นต้นด้วย Qmgr โดยให้ทำตามขั้นตอนต่อไปนี้:

    1. คลิก เริ่ม พิมพ์ \Programdata\Microsoft\network\downloader ในกล่อง เริ่มการค้นหา แล้วกด ENTER

    2. ในหน้าต่าง Downloader ให้เลือกแล้วลบแฟ้มที่ขึ้นต้นด้วย Qmgr ตัวอย่าง ให้ลบแฟ้มต่อไปนี้

      • Qmgr0.dat

      • Qmgr1.dat

  4. เริ่มระบบคอมพิวเตอร์ของคุณใหม่ในโหมดปกติ โดยให้ทำตามขั้นตอนต่อไปนี้:

    1. ออกจากโปรแกรมที่เปิดอยู่ทั้งหมด


    2. คลิก เริ่ม พิมพ์ Run ในกล่อง เริ่มการค้นหา แล้วกด ENTER


    3. พิมพ์ msconfig แล้วคลิก ตกลง

      โปรแกรมอรรถประโยชน์ของการกำหนดค่าระบบจะปรากฏขึ้น

    4. บนแท็บ เริ่มระบบ ให้คลิกเพื่อล้างกล่องกาเครื่องหมาย การเริ่มระบบแบบปลอดภัย แล้วคลิก ตกลง เพื่อเริ่มการทำงานของคอมพิวเตอร์ใหม่

    5. เริ่มการทำงานของคอมพิวเตอร์ใหม่เมื่อคุณได้รับการพร้อมท์

  5. ให้เปิดการปรับปรุงของ Windows โดยทันที แล้วติดตั้งการปรับปรุงล่าสุด

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "การใช้งาน"

ต้องการความช่วยเหลือเพิ่มเติมหรือไม่

ต้องการตัวเลือกเพิ่มเติมหรือไม่

สํารวจสิทธิประโยชน์ของการสมัครใช้งาน เรียกดูหลักสูตรการฝึกอบรม เรียนรู้วิธีการรักษาความปลอดภัยอุปกรณ์ของคุณ และอื่นๆ

ชุมชนช่วยให้คุณถามและตอบคําถาม ให้คําติชม และรับฟังจากผู้เชี่ยวชาญที่มีความรู้มากมาย

ข้อมูลนี้เป็นประโยชน์หรือไม่

คุณพึงพอใจกับคุณภาพภาษาเพียงใด
สิ่งที่ส่งผลต่อประสบการณ์ใช้งานของคุณ
เมื่อกดส่ง คำติชมของคุณจะถูกใช้เพื่อปรับปรุงผลิตภัณฑ์และบริการของ Microsoft ผู้ดูแลระบบ IT ของคุณจะสามารถรวบรวมข้อมูลนี้ได้ นโยบายความเป็นส่วนตัว

ขอบคุณสำหรับคำติชมของคุณ!

×