อาการ
หลังจากที่คุณติดตั้งเซอร์วิสแพ็คบนเซิร์ฟเวอร์ที่กำลังเรียกใช้ Microsoft Exchange Server 2010 หรือ Exchange Server 2007 คุณอาจพบอย่างน้อยหนึ่งปัญหาต่อไปนี้:
-
Outlook Web App หรือ Outlook Web Access (OWA) การเปลี่ยนเส้นทางจากโพรโทคอล HTTP เป็นโพรโทคอล HTTPS ล้มเหลว
-
การรักษาความปลอดภัย Secure Sockets Layer (SSL) ถ่ายล้มเหลว
-
ข้อผิดพลาดที่คล้ายกับต่อไปนี้จะแสดงขึ้นเมื่อผู้ใช้พยายามเชื่อมต่อกับ OWA:
403 – ห้าม: การเข้าถึงถูกปฏิเสธ
คุณไม่มีสิทธิ์ในการดูไดเรกทอรีหรือเพจโดยใช้ข้อมูลประจำตัวที่คุณให้มานี้ -
รายการที่คล้ายกับต่อไปนี้ถูกบันทึกไว้ในบันทึก IIS:
2013-03-28 18:44:52 192.168.66.13 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.1;+WOW64;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+InfoPath.2) /owa/ 192.168.66.25 - 80 - 403 4 5 343 ที่ได้รับ
สาเหตุ
ปัญหานี้เกิดขึ้นหากเปิดใช้งานตัวเลือกการตั้งค่าคอนฟิก "จำเป็นต้องใช้ SSL" บนเว็บไซต์เริ่มต้นหรือไดเรกทอรีเสมือน
หมายเหตุ โดยค่าเริ่มต้น ตัวเลือกการตั้งค่าคอนฟิก "จำเป็นต้องใช้ SSL" เปิดใช้งานบนเว็บไซต์เริ่มต้นเมื่อคุณติดตั้ง Exchange Server มีเซอร์วิสแพ็ค นอกจากนี้ การตั้งค่าคอนฟิก "จำเป็นต้องใช้ SSL" ถูกเปิดใช้งานบนไดเรกทอรีเสมือนภายใต้เว็บไซต์เริ่มต้น
การแก้ปัญหา
เมื่อต้องการแก้ไขปัญหานี้ ให้ทำตามขั้นตอนเหล่านี้:
-
เริ่มต้น IIS 7 Manager
-
เลือกเว็บไซต์เริ่มต้น และจากนั้น ตรวจสอบให้แน่ใจว่า คุณอยู่ในมุมมองของลักษณะการทำงาน
-
คลิกสองครั้งที่การตั้งค่า SSL
-
คลิกเพื่อยกเลิกเลือกกล่องกาเครื่องหมายจำเป็นต้องใช้ SSL
-
เรียกใช้คำสั่ง IISRESET
-
ทำซ้ำขั้นตอนที่ 1 ถึง 5 สำหรับเว็บไซต์เสมือนทั้งหมดภายใต้เว็บไซต์เริ่มต้น
ข้อมูลเพิ่มเติม
สำหรับข้อมูลเพิ่มเติมเกี่ยวกับ SSL ถ่ายใน Exchange Server 2010 ไปที่เว็บไซต์ของ Microsoft TechNet ดังต่อไปนี้:
วิธีการกำหนดค่า SSL ถ่ายใน Exchange 2010
สำหรับข้อมูลเพิ่มเติมเกี่ยวกับปัญหาที่อาจเกิดขึ้นได้เมื่อคุณใช้ offloader แบบ SSL อื่น ๆ ในสภาพแวดล้อมของ Exchange Server 2007 คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
945453คุณไม่สามารถล็อกอินเข้า Outlook Web Access ในสภาพแวดล้อมของ Exchange Server 2007 และคุณได้รับข้อผิดพลาด: "ข้อผิดพลาด HTTP 403.4"