อาการ
คุณพบข้อผิดพลาดต่อไปนี้เมื่อสร้างการเชื่อมต่อใหม่หรือการเรียกใช้โฟลว์ UI:
-
UnreachableCrlEndpoint
-
InvalidConnectionCredentials
-
เวลาหมดของเกตเวย์
ถ้าคุณกําลังใช้บัญชี AAD โปรดตรวจสอบให้แน่ใจว่าข้อมูลประจําตัวของคุณถูกต้อง และบัญชีของคุณได้รับการซิงโครไนซ์กับเครื่องของคุณโดยทําตามขั้นตอนในบทความต่อไปนี้: https://support.microsoft.com/en-my/help/4555623/troubleshoot-ui-flow-invalid-credentials-error-using-aad-account
หากคุณยังคงประสบปัญหา โปรดอ่านเพิ่มเติม
สาเหตุ
ข้อผิดพลาดนี้สามารถระบุว่าผลิตภัณฑ์ไม่สามารถเข้าถึงเซิร์ฟเวอร์ CRL ได้ เนื่องจาก UI Service UIService ของ Windows หรือเซสชันผู้ใช้ของคุณไม่สามารถเข้าถึงโดเมนอย่างน้อยหนึ่งโดเมนในเอกสารต่อไปนี้: https://learn.microsoft.com/en-us/power-automate/limits-and-config#ui-flows-required-services
กําลังตรวจสอบปัญหา
เมื่อต้องการตรวจสอบว่าคุณมีสิทธิ์เข้าถึงจุดสิ้นสุด CRL จากเซสชันผู้ใช้หรือไม่ คุณสามารถพยายามเข้าถึง URL จากส่วนที่ชื่อว่า "บริการที่จําเป็นสําหรับโฟลว์ UI" ในเอกสารประกอบPower Automate โดยพิมพ์ลงในแถบ URL ของเบราว์เซอร์
ขณะนี้ยังไม่มีวิธีทดสอบว่าคุณมีสิทธิ์เข้าถึงจุดสิ้นสุด CRL จากบริการ Windows "UIFlowService" หรือไม่ ไปที่ส่วนถัดไปโดยตรง
ขั้นตอนการแก้ปัญหา
คุณจะต้องขอให้ผู้ดูแลระบบของคุณตรวจสอบให้แน่ใจว่าจุดสิ้นสุดสามารถเข้าถึงได้จาก ทั้งเซสชันผู้ใช้ และบริการ Windows "UIFlowService" (เรียกใช้เป็นบัญชี NT SERVICE\UIFlowService)
เมื่อต้องการตรวจสอบว่าไฟร์วอลล์ Windows มีความรับผิดชอบหรือไม่ ให้สอบถามผู้ดูแลระบบของคุณด้วย
หากปัญหาเกิดจากไฟร์วอลล์ Windows คุณจะต้องทําตามคําแนะนําจาก 'สร้างโปรแกรมขาออกหรือกฎการบริการ' ที่นี่: https://learn.microsoft.com/en-us/windows/security/threat-protection/windows-firewall/create-an-outbound-program-or-service-rule