ข้ามไปที่เนื้อหาหลัก
การสนับสนุน
ลงชื่อเข้าใช้
ลงชื่อเข้าใช้ด้วย Microsoft
ลงชื่อเข้าใช้หรือสร้างบัญชี
สวัสดี
เลือกบัญชีอื่น
คุณมีหลายบัญชี
เลือกบัญชีที่คุณต้องการลงชื่อเข้าใช้

อาการ

สมมติว่า คุณเริ่มระบบของคอมพิวเตอร์ไคลเอ็นต์ EFI อินเทอร์เฟซเฟิร์มแวร์ Extensible บูตก่อนดำเนินการสภาพแวดล้อม (PXE) และจากนั้น คุณเชื่อมต่อกับเซิร์ฟเวอร์บริการการปรับใช้ Windows (WDS) ที่กำลังเรียกใช้ Windows Server 2008 R2 คอมพิวเตอร์ไคลเอนต์ที่มีอะแดปเตอร์เครือข่ายที่ไม่สนับสนุนแบบหลายผู้รับ เมื่อคุณพยายามที่จะเรียกใช้โปรแกรมสำหรับเริ่มต้นระบบ โปรแกรมล้มเหลว และคุณไม่สามารถปรับใช้ Windows ไปยังคอมพิวเตอร์ไคลเอนต์

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากมีข้อผิดพลาดเกิดขึ้นเมื่อ WDS พยายามที่จะปิดการใช้งานแบบหลายผู้รับหมายเหตุ ปัญหานี้เกิดขึ้นเฉพาะเมื่ออะแดปเตอร์เครือข่ายบนคอมพิวเตอร์ไคลเอนต์ไม่สนับสนุนแบบหลายผู้รับ

การแก้ไข

ข้อมูลโปรแกรมแก้ไขด่วน

มีโปรแกรมแก้ไขด่วนที่รองรับพร้อมให้บริการจาก Microsoft อย่างไรก็ตาม โปรแกรมแก้ไขด่วนนี้มุ่งหวังเพื่อการแก้ไขเฉพาะปัญหาที่อธิบายไว้ในบทความนี้ ใช้การแก้ไขด่วนนี้กับระบบต่าง ๆ ที่พบปัญหาอธิบายไว้ในบทความนี้เท่านั้น โปรแกรมแก้ไขด่วนนี้อาจได้รับการทดสอบเพิ่มเติม ดังนั้น ถ้าคุณไม่ได้รับผลกระทบจากปัญหานี้รุนแรง เราขอแนะนำให้ คุณรอการปรับปรุงซอฟต์แวร์ถัดไปที่ประกอบด้วยโปรแกรมแก้ไขด่วนนี้ หากโปรแกรมแก้ไขด่วนพร้อมสำหรับการดาวน์โหลด คุณจะเห็นส่วน "มีโปรแกรมแก้ไขด่วนพร้อมสำหรับการดาวน์โหลด" ที่ด้านบนของบทความฐานข้อมูลองค์ความรู้นี้ หากส่วนนี้ไม่ปรากฏขึ้น ติดต่อฝ่ายสนับสนุนและบริการลูกค้าของ Microsoft เพื่อขอรับโปรแกรมแก้ไขด่วน หมายเหตุ ถ้ามีปัญหาอื่น ๆ เกิดขึ้น หรือถ้าจำเป็นต้องแก้ไขปัญหาใด ๆ คุณอาจต้องสร้างคำขอรับบริการแยกต่างหาก จะมีค่าใช้จ่ายในการสนับสนุนปกติกับคำถามเพิ่มเติมและเรื่องอื่น ๆ ที่ไม่มีสิทธิได้รับโปรแกรมแก้ไขด่วนเฉพาะนี้ สำหรับรายชื่อทั้งหมด ของหมายเลขโทรศัพท์ของฝ่ายบริการลูกค้าและการสนับสนุนของ Microsoft หรือเพื่อสร้างการร้องขอบริการแยกต่างหาก แวะไปที่เว็บไซต์ของ Microsoft ต่อไปนี้:

http://support.microsoft.com/contactus/?ws=supportหมายเหตุ แบบฟอร์ม "มีโปรแกรมแก้ไขด่วนพร้อมสำหรับการดาวน์โหลด" แสดงภาษาที่โปรแกรมแก้ไขด่วนพร้อมใช้งาน ถ้าคุณไม่เห็นภาษาของคุณ อาจเป็น เพราะไม่มีโปรแกรมแก้ไขด่วนพร้อมใช้งานสำหรับภาษานั้น

ข้อกำหนดเบื้องต้น

เมื่อต้องการใช้โปรแกรมแก้ไขด่วนนี้ คุณต้องเรียกใช้ Windows Server 2008 R2 Service Pack 1 (SP1)สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการขอรับเซอร์วิสแพ็ค Windows 7 หรือ Windows Server 2008 R2 คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:

976932 ข้อมูลเกี่ยวกับ Service Pack 1 สำหรับ Windows 7 และ Windows Server 2008 R2

ข้อมูลรีจิสทรี

เมื่อต้องการใช้โปรแกรมแก้ไขด่วนในแพ็คเกจนี้ คุณไม่มีการเปลี่ยนแปลงใด ๆ ในรีจิสทรี

ความต้องการในการเริ่มระบบใหม่

คุณไม่ต้องรีสตาร์ทคอมพิวเตอร์หลังจากใช้โปรแกรมแก้ไขด่วนนี้

ข้อมูลการแทนที่โปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนนี้ไม่ได้ใช้แทนโปรแกรมแก้ไขด่วนที่มีการนำออกใช้ก่อนหน้านี้

ข้อมูลไฟล์

ไฟล์การติดตั้งโปรแกรมแก้ไขด่วนรุ่นที่ใช้งานทั่วโลกจะมีคุณลักษณะตามที่แสดงในตารางต่อไปนี้ วันที่และเวลาสำหรับไฟล์เหล่านี้จะแสดงอยู่ใน Coordinated Universal Time (UTC) วันที่และเวลาสำหรับไฟล์นี้ในคอมพิวเตอร์ท้องถิ่นจะแสดงเวลาท้องถิ่นของคุณพร้อมกับเวลาออมแสงปัจจุบัน (DST) นอกจากนี้ วันที่และเวลาอาจเปลี่ยนแปลงเมื่อคุณดำเนินการบางอย่างในไฟล์

หมายเหตุข้อมูลแฟ้มของ Windows Server 2008 R2

สิ่งสำคัญ โปรแกรมแก้ไขด่วน Windows 7 และโปรแกรมแก้ไขด่วน Windows Server 2008 R2 จะรวมอยู่ในแพคเกจเดียวกัน อย่างไรก็ตาม โปรแกรมแก้ไขด่วนในหน้าขอโปรแกรมแก้ไขด่วนแสดงอยู่ภายใต้ระบบปฏิบัติการทั้งสอง หากต้องการขอแพคเกจโปรแกรมแก้ไขด่วนที่ใช้ได้กับระบบปฏิบัติการหนึ่งหรือทั้งสอง โปรดเลือกโปรแกรมแก้ไขด่วนที่แสดงอยู่ภายใต้ "Windows 7/Windows Server 2008 R2" ในเพจนั้น โปรดดูส่วน "นำไปใช้กับ" ในบทความนี้อยู่เสมอ เพื่อให้ทราบถึงระบบปฏิบัติการจริงที่สามารถใช้ได้กับโปรแกรมแก้ไขด่วนแต่ละรายการ

  • แฟ้มที่นำไปใช้กับผลิตภัณฑ์เจาะจง SR_Level (RTM, SPn), และสาขาเซอร์วิส (LDR, GDR) สามารถระบุได้ โดยตรวจสอบหมายเลขรุ่นของแฟ้มดังที่ปรากฏในตารางต่อไปนี้

    เวอร์ชัน

    รุ่นผลิตภัณฑ์

    SR_Level

    สาขาบริการ

    6.1.760 1 21xxx

    Windows Server 2008 R2

    SP1

    LDR

  • แฟ้ม MANIFEST (.manifest) และแฟ้ม MUM (.mum) ซึ่งติดตั้งสำหรับแต่ละสภาพแวดล้อมจะแสดงรายการแยกต่างหากในส่วน "ข้อมูลสำหรับ Windows Server 2008 R2 แฟ้มเพิ่มเติม" แฟ้ม MUM และแฟ้ม MANIFEST และ แฟ้มแค็ตตาล็อก (.cat) การรักษาความปลอดภัยที่เกี่ยวข้อง มีความสำคัญอย่างมากในการรักษาสถานะของคอมโพเนนต์ปรับปรุงแล้ว แฟ้มแค็ตตาล็อกการรักษาความปลอดภัยซึ่งแอตทริบิวต์ไม่ได้แสดงรายการไว้จะได้รับการลงชื่อด้วยลายเซ็นดิจิทัลของ Microsoft

สำหรับทั้งหมดได้รับการสนับสนุน Windows Server 2008 R2 รุ่นที่ใช้ x64

ชื่อไฟล์

รุ่นของไฟล์

ขนาดไฟล์

วันที่

เวลา

Bootmgfw.efi

6.1.7601.21894

673,136

09-Jan-2012

14:38

Wdsmgfw.efi

6.1.7601.21894

532,480

09-Jan-2012

11:44

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "นำไปใช้กับ"

ข้อมูลเพิ่มเติม

คุณต้องใช้โปรแกรมแก้ไขด่วนนี้ไปยังรูปภาพที่สองของไฟล์รูปภาพเริ่มต้นระบบ Windows Vista หรือ Windows Server 2008 เมื่อต้องการทำเช่นนี้ ให้ทำตามขั้นตอนเหล่านี้หมายเหตุ รูปภาพที่สองเป็นรูปสภาพแวดล้อมการติดตั้งพร้อมเครื่องของ Windows (Windows PE)

  1. บนเซิร์ฟเวอร์บริการการปรับใช้ Windows ติดตั้ง Windows แบบอัตโนมัติติดตั้งชุดอุปกรณ์ (AIK) สำหรับ Windows 7 เมื่อต้องการขอรับ Windows AIK สำหรับ Windows 7 แวะไปที่เว็บไซต์ของ Microsoft ต่อไปนี้:

    http://www.microsoft.com/downloads/details.aspx?familyid=696DD665-9F76-4177-A811-39C26D3B3B34&displaylang=enหมายเหตุ คุณยังสามารถติดตั้ง Windows AIK สำหรับ Windows 7 ในคอมพิวเตอร์ที่กำลังเรียกใช้ระบบปฏิบัติการที่ได้รับการสนับสนุน โดย Windows AIK สำหรับ Windows 7 แยกต่างหาก

  2. คลิกเริ่ม คลิกโปรแกรมทั้งหมดคลิกMicrosoft Windows AIKคลิกขวาพร้อมรับคำสั่งของเครื่องมือการปรับใช้และจากนั้น คลิกเรียกใช้ในฐานะผู้ดูแล UAC ถ้าคุณได้รับพร้อมท์ สำหรับรหัสผ่านผู้ดูแลระบบ หรือ เพื่อยืนยัน ให้พิมพ์รหัสผ่าน หรือทำการยืนยัน

  3. แยก Windows6.0-KB2649909-v2 -แพลตฟอร์มแฟ้ม.cab จากแพคเกจโปรแกรมแก้ไขด่วนนี้ไปยังโฟลเดอร์ชั่วคราว โดยทำตามขั้นตอนต่อไปนี้:

    1. คลิกเริ่ม คลิกเรียกใช้พิมพ์cmdและจากนั้น คลิกตกลง

    2. ที่พร้อมท์คำสั่งนี้ ให้พิมพ์คำสั่งต่อไปนี้ และกด ENTER:

      Expand.exe CabFilePath -R-f: * TempFolderPathNotes

      • ตัวยึดCabFilePathแทนเส้นทางของแฟ้ม CAB

      • ตัวยึดTempFolderPathแทนเส้นทางของโฟลเดอร์ชั่วคราว

  4. ปิดการใช้งานรูปบูตตัวที่มีปัญหาทำให้รายงานพร้อมใช้งานสำหรับการดาวน์โหลดในกระบวนการปรับปรุง การทำเช่นนี้ เปิดสแน็ปอิน Windows การปรับใช้บริการ Microsoft Management Console (MMC) คลิกขวารูปสำหรับเริ่มระบบที่คุณต้องการปรับปรุง แล้ว คลิกปิดใช้งาน

  5. ส่งออกรูปภาพสำหรับเริ่มระบบที่ต้องปรับปรุงจากเซิร์ฟเวอร์บริการการปรับใช้ Windows ไปที่BootWimPath การทำเช่นนี้ คลิกขวารูปบูต แล้ว คลิกส่งออกรูปภาพ ส่งออกรูปแบบเริ่มต้นระบบเพื่อBootWimPathหมายเหตุ

    • ตัวยึดBootWimPathแสดงถึงไดเรกทอรีภายในเครื่องที่ส่งออกแฟ้ม Boot.wim

    • ถ้าคุณติดตั้ง Windows AIK บนคอมพิวเตอร์แยกต่างหาก คุณต้องคัดลอกแฟ้ม Boot.wim ไปยังไดเรกทอรีบนคอมพิวเตอร์เครื่องนั้น ดำเนินการขั้นตอนที่ 6 ถึง 8 ในคอมพิวเตอร์เครื่องนั้น

  6. กำหนดใช้รูปเริ่มต้นระบบสำหรับสิทธิ์ในการอ่าน/เขียน เมื่อต้องการทำเช่นนี้ ให้พิมพ์คำสั่งต่อไปนี้ที่พร้อมท์คำสั่ง และจากนั้น กด ENTER:

    dism /mount-wim /wimfile:BootWimPath/index:2 /mountdir:MountLocationหมายเหตุ

    • ตัวยึดMountLocationแสดงถึงตำแหน่งที่ตั้งในการกำหนดใช้รูปภาพ

    • ตรวจสอบให้แน่ใจว่า คุณกำหนดใช้รูปภาพที่มีหมายเลขดัชนีสำหรับเริ่มต้นระบบคือ 2

  7. คัดลอกแฟ้ม Wdsmgfw.efi จากโฟลเดอร์ TempFolderPath ไปยังโฟลเดอร์ต่อไปนี้:

    MountLocation\Windows\Boot\PXE

  8. คัดลอกแฟ้ม Bootmgfw.efi จากโฟลเดอร์ TempFolderPath ไปยังโฟลเดอร์ต่อไปนี้:

    MountLocation\Windows\Boot\EFI

  9. เอาแฟ้ม Boot.wim และยอมรับการเปลี่ยนแปลงทั้งหมดแล้ว เมื่อต้องการทำเช่นนี้ ให้พิมพ์คำสั่งต่อไปนี้ที่พร้อมท์คำสั่ง และจากนั้น กด ENTER:

    Dism.exe /unmount-wim /mountdir:MountLocation /commit

  10. เพิ่มแฟ้ม Boot.wim ปรับปรุงไปยังเซิร์ฟเวอร์บริการการปรับใช้ Windows เมื่อต้องการทำเช่นนี้ เปิดสแน็ปอิน MMC ของบริการการปรับใช้ Windows คลิกขวารูปบูตคลิกเพิ่มรูปบูตและระบุเส้นทางของแฟ้ม Boot.wim ปรับปรุงแล้ว

  11. คลิกขวาใน MMC บริการการปรับใช้ Windows สแนปอิน รูปสำหรับเริ่มระบบที่คุณเพิ่มเข้ามาเพื่อให้แน่ใจว่า ได้เปิดใช้งาน

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับการปรับใช้ Windows Services แวะไปที่เว็บไซต์ของ Microsoft ต่อไปนี้:

ข้อมูลทั่วไปเกี่ยวกับบริการการปรับใช้ Windowsสำหรับข้อมูลเพิ่มเติมเกี่ยวกับคำศัพท์ของการปรับปรุงซอฟต์แวร์ ให้คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:

824684 คำอธิบายของคำศัพท์มาตรฐานที่ใช้เพื่ออธิบายโปรแกรมปรับปรุงซอฟต์แวร์ของ Microsoft

ต้องการความช่วยเหลือเพิ่มเติมหรือไม่

ต้องการตัวเลือกเพิ่มเติมหรือไม่

สํารวจสิทธิประโยชน์ของการสมัครใช้งาน เรียกดูหลักสูตรการฝึกอบรม เรียนรู้วิธีการรักษาความปลอดภัยอุปกรณ์ของคุณ และอื่นๆ

ชุมชนช่วยให้คุณถามและตอบคําถาม ให้คําติชม และรับฟังจากผู้เชี่ยวชาญที่มีความรู้มากมาย

ข้อมูลนี้เป็นประโยชน์หรือไม่

คุณพึงพอใจกับคุณภาพภาษาเพียงใด
สิ่งที่ส่งผลต่อประสบการณ์ใช้งานของคุณ
เมื่อกดส่ง คำติชมของคุณจะถูกใช้เพื่อปรับปรุงผลิตภัณฑ์และบริการของ Microsoft ผู้ดูแลระบบ IT ของคุณจะสามารถรวบรวมข้อมูลนี้ได้ นโยบายความเป็นส่วนตัว

ขอบคุณสำหรับคำติชมของคุณ!

×