อาการ
หลังจากคุณได้ติดตั้ง Windows Vista Service Pack 1 (SP1) บนคอมพิวเตอร์ที่ใช้งาน Windows Vista อยู่ คุณพบอาการหนึ่งหรือทั้งสองอาการต่อไปนี้:
-
ไม่มีการติดตั้งโปรแกรมควบคุมอุปกรณ์ และมีเครื่องหมายอัศเจรีย์ (!) ปรากฏอยู่ติดกับโปรแกรมควบคุมอุปกรณ์ในตัวจัดการอุปกรณ์
-
โปรแกรมควบคุมอุปกรณ์ได้ติดตั้งไว้อย่างถูกต้องแล้วในตัวจัดการอุปกรณ์ แต่อุปกรณ์ฮาร์ดแวร์ทำงานไม่ปกติ
สาเหตุ
ปัญหาเกิดขึ้นเนื่องจาก Window Vista SP1 ได้ปรับปรุงแฟ้มระบบและโปรแกรมควบคุมบางตัว เพื่อปรับปรุงเสถียรภาพการทำงานของอุปกรณ์ เมื่อคุณติดตั้ง Window Vista SP1 กระบวนการติดตั้ง Service Pack อาจติดตั้งโปรแกรมควบคุมอุปกรณ์บางตัวใหม่อีกครั้ง ในตอนท้ายของการติดตั้ง
หมายเหตุ เราแนะนำให้คุณติดตั้งโปรแกรมควบคุมล่าสุดสำหรับฮาร์ดแวร์ของคุณ ก่อนติดตั้ง Windows Vista SP1 ในการทำเช่นนี้ คุณจะสามารถป้องกันปัญหาที่ได้กล่าวไว้ในส่วนของ “อาการ”
การแก้ไข
เมื่อต้องการแก้ไขปัญหานี้ ให้ใช้วิธีการต่อไปนี้ตามลำดับที่ปรากฏ
วิธีที่ 1: ดูว่าพบโปรแกรมควบคุมอุปกรณ์อยู่ในตัวจัดการอุปกรณ์หรือไม่
โดยให้ทำตามขั้นตอนต่อไปนี้:
-
คลิก เริ่ม พิมพ์ ตัวจัดการอุปกรณ์ ในกล่อง เริ่มการค้นหา แล้วกด ENTER
-
หากไม่พบโปรแกรมควบคุมอุปกรณ์ของอุปกรณ์นั้น ๆ อยู่ในตัวจัดการอุปกรณ์ จะมีเครื่องหมายอัศเจรีย์ (!) ปรากฏอยู่ติดกับอุปกรณ์นั้น หากไม่มีเครื่องหมายอัศเจรีย์ (!) ปรากฏขึ้นมา และหากอุปกรณ์ทำงานไม่ปกติ ให้ไปที่วิธีที่ 2
-
หากมีเครื่องหมายอัศเจรีย์ (!) ปรากฏอยู่ติดกับโปรแกรมควบคุมอุปกรณ์อยู่ในตัวจัดการอุปกรณ์ คุณสามารถใช้ Windows Update เพื่อสแกนหาโปรแกรมควบคุมอุปกรณ์ได้ โดยให้ทำตามขั้นตอนต่อไปนี้
-
คลิก เริ่ม คลิก โปรแกรมทั้งหมด แล้วคลิก Windows Update
หากคุณได้รับการพร้อมท์เพื่อใส่รหัสผ่านของผู้ดูแลระบบหรือเพื่อยืนยัน ให้พิมพ์รหัสผ่านหรือทำการยืนยัน -
คลิก ตรวจหาโปรแกรมปรับปรุง
-
หากต้องการดูว่ามีโปรแกรมควบคุมซึ่งถูกปรับปรุงใหม่อยู่หรือไม่ ให้คลิก ดูการปรับปรุงที่มี
หากมีการปรับปรุง ให้คลิกเพื่อเลือกโปรแกรมควบคุมที่คุณต้องการติดตั้ง แล้วคลิก ติดตั้ง หากคุณได้รับการพร้อมท์เพื่อใส่รหัสผ่านของผู้ดูแลระบบหรือเพื่อยืนยัน ให้พิมพ์รหัสผ่านหรือทำการยืนยัน
-
หาก Windows Update ไม่สามารถระบุหาตำแหน่งของโปรแกรมควบคุมอุปกรณ์ที่จำเป็นได้ ให้ติดต่อผู้ผลิตอุปกรณ์เพื่อดาวน์โหลดโปรแกรมควบคุมอุปกรณ์ล่าสุดสำหรับ Windows Vista สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการดาวน์โหลด ให้ดูที่ส่วน "ข้อมูลเพิ่มเติม"
วิธีที่ 2: ถอนการติดตั้ง จากนั้นให้ติดตั้งโปรแกรมควบคุมอุปกรณ์ใหม่
หากโปรแกรมควบคุมอุปกรณ์ได้ติดตั้งไว้อย่างถูกต้องแล้วในตัวจัดการอุปกรณ์ แต่อุปกรณ์ยังทำงานไม่ปกติ ให้ติดตั้งโปรแกรมควบคุมอุปกรณ์ใหม่ด้วยตนเอง โดยให้ทำตามขั้นตอนต่อไปนี้
-
คลิก เริ่ม พิมพ์ ตัวจัดการอุปกรณ์ ในกล่อง เริ่มการค้นหา แล้วกด ENTER
-
ในกล่องโต้ตอบ ตัวจัดการอุปกรณ์ ให้ระบุตำแหน่งของอุปกรณ์ฮาร์ดแวร์ที่ไม่ทำงาน
-
คลิกขวาที่อุปกรณ์ แล้วคลิก คุณสมบัติ
-
คลิกแท็บ โปรแกรมควบคุม
-
คลิก ถอนการติดตั้ง
-
ตรวจดูให้แน่ใจว่าไม่ได้ทำเครื่องหมายเลือกที่กล่องเครื่องหมาย ลบซอฟต์แวร์โปรแกรมควบคุมสำหรับอุปกรณ์นี้ จากนั้นคลิก ตกลง
-
ในกล่องโต้ตอบ ตัวจัดการอุปกรณ์ ให้คลิกเมนู Action จากนั้นคลิก สแกนหาการเปลี่ยนแปลงฮาร์ดแวร์
คุณควรได้รับข้อความแจ้งว่ากำลังติดตั้งอุปกรณ์ฮาร์ดแวร์อยู่ และอุปกรณ์ที่ถูกถอนการติดตั้งจะแสดงอยู่ในตัวจัดการอุปกรณ์ -
หากยังไม่ได้ติดตั้งโปรแกรมควบคุมอุปกรณ์ฮาร์ดแวร์ ให้ใช้ Windows Update เพื่อสแกนหาโปรแกรมควบคุมอุปกรณ์ที่ปรับปรุงใหม่ โดยให้ทำตามขั้นตอนต่อไปนี้
-
คลิก เริ่ม คลิก โปรแกรมทั้งหมด แล้วคลิก Windows Update
หากคุณได้รับการพร้อมท์เพื่อใส่รหัสผ่านของผู้ดูแลระบบหรือเพื่อยืนยัน ให้พิมพ์รหัสผ่านหรือทำการยืนยัน -
คลิก ตรวจหาโปรแกรมปรับปรุง
-
หากต้องการดูว่ามีโปรแกรมควบคุมซึ่งปรับปรุงใหม่ที่สามารถใช้ได้หรือไม่ ให้คลิก ดูการปรับปรุงที่มี
หากมีการปรับปรุง ให้คลิกเพื่อเลือกโปรแกรมควบคุมที่คุณต้องการติดตั้ง แล้วคลิก ติดตั้ง หากคุณได้รับการพร้อมท์เพื่อใส่รหัสผ่านของผู้ดูแลระบบหรือเพื่อยืนยัน ให้พิมพ์รหัสผ่านหรือทำการยืนยัน
-
หาก Windows Update ไม่สามารถระบุหาตำแหน่งของโปรแกรมควบคุมอุปกรณ์ที่จำเป็นได้ ให้ติดต่อผู้ผลิตอุปกรณ์เพื่อดาวน์โหลดโปรแกรมควบคุมอุปกรณ์ล่าสุดสำหรับ Windows Vista สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการดาวน์โหลด ให้ดูที่ส่วน "ข้อมูลเพิ่มเติม"
ข้อมูลเพิ่มเติม
สำหรับข้อมูลเกี่ยวกับวิธีติดต่อผู้จำหน่ายฮาร์ดแวร์และซอฟต์แวร์ ให้คลิกหมายเลขบทความที่เหมาะสมในรายการต่อไปนี้เพื่ออ่านบทความในฐานข้อมูลความรู้ของไมโครซอฟท์:
65416 ข้อมูลผู้ติดต่อของผู้จำหน่ายฮาร์ดแวร์และซอฟต์แวร์ A-K (ลิงค์นี้อาจเชื่อมโยงไปยังเนื้อหาที่เป็นภาษาอังกฤษบางส่วน หรือทั้งหมด)
60781 ข้อมูลผู้ติดต่อของผู้จำหน่ายฮาร์ดแวร์และซอฟต์แวร์ L-P (ลิงค์นี้อาจเชื่อมโยงไปยังเนื้อหาที่เป็นภาษาอังกฤษบางส่วน หรือทั้งหมด)
60782 ข้อมูลผู้ติดต่อของผู้จำหน่ายฮาร์ดแวร์และซอฟต์แวร์ Q-Z (ลิงค์นี้อาจเชื่อมโยงไปยังเนื้อหาที่เป็นภาษาอังกฤษบางส่วน หรือทั้งหมด)ไมโครซอฟท์จะให้ข้อมูลติดต่อของบริษัทอื่น เพื่อช่วยให้คุณสามารถขอรับการสนับสนุนทางเทคนิคได้ ข้อมูลติดต่อนี้อาจเปลี่ยนแปลงโดยไม่ต้องแจ้งให้ทราบล่วงหน้า ไมโครซอฟท์ไม่รับประกันความถูกต้องของข้อมูลการติดต่อกับบริษัทอื่น
สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีแก้ไขปัญหาเรื่องเสียงซึ่งอาจเกิดขึ้นหลังจากที่คุณติดตั้ง Windows Vista Service Pack 1 แล้ว ให้คลิกที่หมายเลขของบทความเพื่ออ่านบทความในฐานความรู้ของไมโครซอฟท์:
948481 คุณพบปัญหาเรื่องเสียงหลังจากติดตั้ง Windows Vista Service Pack 1