ข้ามไปที่เนื้อหาหลัก
การสนับสนุน
ลงชื่อเข้าใช้
ลงชื่อเข้าใช้ด้วย Microsoft
ลงชื่อเข้าใช้หรือสร้างบัญชี
สวัสดี
เลือกบัญชีอื่น
คุณมีหลายบัญชี
เลือกบัญชีที่คุณต้องการลงชื่อเข้าใช้

อาการ

สมมติว่าคุณสำรองข้อมูลหางของแฟ้มบันทึกสำหรับฐานข้อมูล แบบจำลองที่ใช้ตัวเลือก Norecovery ใน Microsoft SQL server ๒๐๑๔หรือ SQL server ๒๐๑๒และฐานข้อมูลจะถูกใส่ลงในสถานะการคืนค่า เมื่อการสำรองข้อมูลเสร็จสมบูรณ์แล้วคุณจะไม่สามารถเริ่มบริการ SQL Server ใหม่ได้และคุณจะได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้ในบันทึกข้อผิดพลาด SQL Server:

<วันที่> <> Spid10s ฐานข้อมูล ' ตัวแบบ ' ถูกทำเครื่องหมายเป็นการคืนค่าและอยู่ในสถานะที่ไม่อนุญาตให้มีการเรียกใช้การกู้คืน <วันที่> <เวลา> spid10s ข้อผิดพลาด: ๙๒๗ความรุนแรง:14, State: 2. <วัน> <> เวลา ของฐานข้อมูล ' model ' ไม่สามารถเปิดได้ อยู่ตรงกลางของการคืนค่า <วันที่> <เวลา> spid10s ไม่สามารถสร้าง tempdb ได้ คุณอาจไม่มีพื้นที่ว่างบนดิสก์เพียงพอ เพิ่มเนื้อที่ว่างบนดิสก์โดยการลบไฟล์อื่นๆบนไดรฟ์ tempdb แล้วเริ่ม SQL Server ใหม่ ตรวจหาข้อผิดพลาดเพิ่มเติมในบันทึกเหตุการณ์ที่อาจระบุว่าเหตุใดไฟล์ tempdb จึงไม่สามารถเตรียมใช้งานได้ <วันที่> <เวลา> การติดตาม SQL spid10s จะหยุดทำงานเนื่องจากการปิดเซิร์ฟเวอร์ รหัสการติดตาม = ' 1 ' นี่คือข้อความที่ให้ข้อมูลเท่านั้น ไม่จำเป็นต้องมีการกระทำของผู้ใช้

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากฐานข้อมูล แบบจำลอง จะถูกใช้เป็นเทมเพลตสำหรับฐานข้อมูลทั้งหมดที่สร้างขึ้นบนอินสแตนซ์ของ SQL Server ถ้าฐานข้อมูลตัว แบบ ถูกทำเครื่องหมายเป็นไม่อนุญาตให้มีสถานะการกู้คืน tempdb ไม่สามารถสร้างได้และบริการ SQL Server ไม่สามารถเริ่มทำงานได้

การแก้ไข

ข้อมูล service pack

เมื่อต้องการแก้ไขปัญหานี้ให้ขอรับ Service Pack 1 สำหรับ SQL Server ๒๐๑๔

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับ SQL Server ๒๐๑๔ Service Pack 1 (SP1) ให้ดูที่ข้อบกพร่องที่ได้รับการแก้ไขใน SQL Server ๒๐๑๔ Service pack 1

วิธีแก้ไขปัญหาชั่วคราว

เมื่อต้องการแก้ไขปัญหานี้ให้ใช้วิธีการต่อไปนี้:

  • ป้องกันการเชื่อมต่อทั้งหมดจากแอปพลิเคชันไปยัง SQL Server

  • เริ่มบริการ SQL Server พร้อมกับการตั้งค่าสถานะการติดตาม๓๖๐๘

  • เรียกใช้คำสั่ง "คืนค่าฐานข้อมูลแบบจำลองด้วยการกู้คืน"

  • เอาค่าสถานะการติดตาม๓๖๐๘และเริ่ม SQL Server ใหม่

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "นำไปใช้กับ"

ต้องการความช่วยเหลือเพิ่มเติมหรือไม่

ต้องการตัวเลือกเพิ่มเติมหรือไม่

สํารวจสิทธิประโยชน์ของการสมัครใช้งาน เรียกดูหลักสูตรการฝึกอบรม เรียนรู้วิธีการรักษาความปลอดภัยอุปกรณ์ของคุณ และอื่นๆ

ชุมชนช่วยให้คุณถามและตอบคําถาม ให้คําติชม และรับฟังจากผู้เชี่ยวชาญที่มีความรู้มากมาย

ข้อมูลนี้เป็นประโยชน์หรือไม่

คุณพึงพอใจกับคุณภาพภาษาเพียงใด
สิ่งที่ส่งผลต่อประสบการณ์ใช้งานของคุณ
เมื่อกดส่ง คำติชมของคุณจะถูกใช้เพื่อปรับปรุงผลิตภัณฑ์และบริการของ Microsoft ผู้ดูแลระบบ IT ของคุณจะสามารถรวบรวมข้อมูลนี้ได้ นโยบายความเป็นส่วนตัว

ขอบคุณสำหรับคำติชมของคุณ!

×