อาการ
พิจารณาสถานการณ์ต่อไปนี้:
-
องค์กร Microsoft Exchange สององค์กรได้รับการกำหนดค่าให้ติดต่อ Fabrikam.com และ Contoso.com จะถูกใช้ในตัวอย่างนี้
-
Cmdlet การส่งออก-AutoDiscoverConfigถูกใช้เพื่อส่งออกข้อมูลการค้นหาอัตโนมัติจากแต่ละองค์กรไปยังอีก
-
กล่องจดหมายของคุณอยู่ใน Contoso.com
-
คุณกำลังใช้ Microsoft Outlook ๒๐๑๓ Service Pack 1 (SP1) บนคอมพิวเตอร์ที่เข้าสู่ระบบโดเมน Contoso.com
ในสถานการณ์สมมตินี้คุณสังเกตเห็นอาการต่อไปนี้:
-
ในโปรไฟล์ Outlook ที่มีอยู่บัญชีผู้ใช้อีเมล Exchange ไม่ได้รับการอัปเดตโดยกระบวนการค้นหาอัตโนมัติอีกต่อไป
-
ถ้าคุณสร้างโปรไฟล์การส่งข้อความ Outlook ใหม่เพื่อเชื่อมต่อกับกล่องจดหมาย Microsoft Exchange Server การกำหนดค่าบัญชีผู้ใช้อีเมล Exchange ไม่สำเร็จ
-
ถ้าคุณใช้ทดสอบอีเมอัตโนมัติเพื่อเริ่มกระบวนการค้นหาอัตโนมัติคุณสังเกตเห็นข้อผิดพลาด0x800C8203 จะแสดงอยู่ในผลลัพธ์
-
คุณจะเห็นกระบวนการค้นหาอัตโนมัติของ Outlook ที่พยายามเชื่อมต่อกับค่าเริ่มต้น Url การค้นหาอัตโนมัติที่กำหนดไว้ล่วงหน้า
สาเหตุ
Outlook ๒๐๑๓ SP1 ก่อนอื่นจะดึงวัตถุจุดเชื่อมต่อบริการที่นำเข้า (SCP) ขององค์กรระยะไกล (ในตัวอย่างนี้ Fabrikam.com) ดังนั้นจึงพยายามเชื่อมต่อกับ URL การค้นหาอัตโนมัติของ Fabrikam หลังจาก Outlook ล้มเหลวในการเข้าถึง URL Fabrikam ในที่สุดคุณจะพยายามเชื่อมต่อกับ url การค้นหาอัตโนมัติ Contoso.com ที่กำหนดไว้ล่วงหน้าดังนี้
https://contoso.com/autodiscover/autodiscover.xml
https://autodiscover.contoso.com/autodiscover.xmlอย่างไรก็ตามเนื่องจาก Outlook ไม่เรียกวัตถุ SCP Contoso ภายในเครื่องจะไม่ลองเชื่อมต่อกับ URL Contoso ภายใน (ตัวอย่างเช่น https://CAS1Contoso.com/Autodiscover/Autodiscover.xml ซึ่งCAS1คือชื่อของเซิร์ฟเวอร์การเข้าถึงไคลเอ็นต์)
การแก้ไข
เมื่อต้องการแก้ไขปัญหานี้ให้ใช้การอัปเดตที่อธิบายไว้ในบทความต่อไปนี้ในฐานความรู้ของ Microsoft:
๒๘๗๘๓๒๓ คำอธิบายของแพคเกจโปรแกรมแก้ไขด่วนของ Outlook ๒๐๑๓ (Outlook-x-none): 8 เมษายน๒๐๑๔
วิธีแก้ไขปัญหาชั่วคราว
ถ้าคุณไม่สามารถติดตั้งแพคเกจโปรแกรมแก้ไขด่วน KB ๒๘๗๘๓๒๓ผู้ดูแลเครือข่ายสามารถสร้างระเบียน DNS เพื่อทำให้ระเบียน autodiscover.contoso.com สามารถเข้าถึงได้โดยไคลเอ็นต์ Outlook บนเครือข่ายภายใน
ข้อมูลเพิ่มเติม
เมื่อต้องการเริ่มเครื่องมือทดสอบอีเมอัตโนมัติให้ทำตามขั้นตอนต่อไปนี้:
-
ให้เริ่ม Outlook
-
กดแป้น Ctrl ค้างไว้แล้วคลิกขวาที่ไอคอน Outlook ในพื้นที่การแจ้งเตือนแล้วคลิกทดสอบอีเมอัตโนมัติ
-
ตรวจสอบว่าที่อยู่อีเมลที่ถูกต้องอยู่ในกล่องที่อยู่อีเมล
-
ในหน้าต่างทดสอบอีเมอัตโนมัติให้คลิกเพื่อยกเลิกการเลือกกล่องกาเครื่องหมายใช้ Guessmartและกล่องกาเครื่องหมายการรับรองความถูกต้อง Guessmart ที่ปลอดภัย
-
คลิกเพื่อเลือกกล่องกาเครื่องหมายใช้การค้นหาอัตโนมัติแล้วคลิกทดสอบ