Symptoms
After you install Microsoft Exchange Server 2019 Cumulative Update 13 (CU13), client-side searches in Microsoft Outlook that use Exchange Web Services (EWS) return incomplete search results and an "HTTP 503" error code. You might also receive the following error message:
We're having trouble fetching results from server.
Cause
This issue typically occurs after you send an email message that includes voting options and has tracking enabled, or if you have voicemail items in your mailbox.
Workaround
To work around this issue, perform the search by using Outlook in Online mode or Outlook on the web (OWA). To verify that you're experiencing this issue, look for an "HTTP 503" response to an EWS request for the mailbox that's being searched. Then, follow the server-side steps in the next section.
More information
To verify that users are encountering this issue, administrators can use Exchange Management Shell (EMS) on the server on which the user’s database is mounted. To first verify the server, run the following command:
Get-MailboxDatabaseCopyStatus (Get-Mailbox “AffectedUserAlias").Database.Name | ?{$_.Status -eq “Mounted”}
The server will be identified in <DatabaseName\ServerName> format. Then, on that same server, run the following commands:
CD $ExScripts
. .\ManagedStoreDiagnosticFunctions.ps1$MBX = Get-Mailbox "MailboxNameHere"
$DB = $MBX.Database.Name $Display = $MBX.DisplayName$MailboxNumber = Get-StoreQuery -Database $DB -Query "SELECT MailboxNumber,DisplayName FROM Mailbox" -Unlimited | ?{$_.DisplayName -like $Display}
$Result = Get-StoreQuery -Database $DB -Query "SELECT MessageClass,FolderID,p10800003 FROM Message WHERE MailboxNumber=$($MailboxNumber.MailboxNumber) AND (p10800003=258 OR p10800003=259 OR p10800003=260 OR p10800003=263 OR p10800003=264 OR p10800003=266 OR p10800003=270 OR p10800003=283 OR p10800003=284 OR p10800003=304)" -UnlimitedIf the $Result variable returns any results, you (or a user) is encountering this issue. In this case, open a ticket with Microsoft Support, and include "PR_ICON_INDEX" in the case title for assistance about this known issue.