UML bileşen diyagramı oluşturma

Bileşenleri, bağlantı noktalarını, arabirimleri ve aralarındaki ilişkileri göstermek için UML bileşen diyagramı oluşturabilirsiniz.

UML'de bileşen sistemin modüler bir bölümünü temsil eder. Davranış, gerekli ve sağlanan arabirimler açısından tanımlanır. Bileşenin ortak özellikler ve işlemleriyle bir dış görünümü vardır ve özel özelliklerle ve sınıflayıcıları gerçekleştirmeyle bir iç görünümü vardır. İç görünüm, dış davranışın dahili olarak nasıl gerçekleştiriliyor olduğunu gösterir.

Örnek UML bileşen diyagramı.

İlk olarak, UML Bileşeni şablonunu açar ve dört seçenekden birini seçersiniz. Ardından UML Bileşeni kalıbı, UML 2.5 standardına uygun şekillerle birlikte görüntülenir.

Not: UML Bileşeni kalıbı, yalnızca Visio Plan 2 abonesiyseniz kullanılabilir. Aboneliğiniz varsa Visio'nun en son sürümünün olduğundan emin olun.

Bileşen diyagramı başlatma

  1. Visio‘yu başlatın. Zaten açık bir dosyanız varsa, Dosya Dosyası'>tıklayın.

  2. Yazılım ve Veritabanı > Ve UML Bileşeni > kategorilere gidin.

  3. Boş şablonu veya üç başlangıç diyagramını seçin. İstediğiniz şablonu seçtiyken Oluştur'a tıklayın.

  4. Diyagramın yanında Şekiller penceresini görüyor olması gerekir. Bölmeyi görmüyorsanız Görev Bölmeleri'nde >şekillerin seçili olduğundan emin olun. Pencereyi yine de görmüyorsanız, sol tarafta yer alan Şekiller penceresini Şekilleri Genişlet Penceresi düğmesi tıklayın.

  5. Görünüm sekmesinde Bağlantı Noktaları'nın yanındaki onay kutusunun seçili olduğundan emin olun. Bu, şekilleri bağlamaya başlayarak bağlantı noktalarının görünmesini sağlar.

  6. Şimdi, diyagramınıza eklemek istediğiniz şekilleri Şekiller penceresinden sayfaya sürükleyin. Metin etiketlerini yeniden adlandırmak için, etiketlere çift tıklayın.

Bileşen şekilleri

Ne zaman kullan

Sisteminiz veya uygulamanız tüm işlevsel üniteler için bileşen şekillerini kullanın.

"Depolama" bileşen şekli

Stereotipi gösterme veya gizleme

Stereotip etiketini göstermek veya gizlemek için şekle sağ tıklayın.

Sağ tıklama menüsü, StereoType komutunu göster komutu,  <<bileşeni>> etiketiyle göster

Alt sistem

Bileşen şeklini, diğer bileşenleri içeren bir alt sistem şekli olarak kullanabilirsiniz. Daha büyük olacak şekilde yeniden boyutlandırabilir ve diğer bileşenleri üzerine sürükleyebilirsiniz. Yeşil vurguyu gördüğünüzde bırakın. Bu noktadan büyük şekle bir kapsayıcı gibi davranır ve daha küçük olan şekil de kapsayıcı olarak hareket eder.

İpucu: Bileşen, başka bir bileşenin üzerine sürüklendikten sonra kaybolursa, CTRL+SHIFT+F tuşlarına basarak bileşeni öne getirin.

Sipariş bileşeni sürüklenerek üzerine sürüklenen Alt sistem şeklini depola

Arabirim şekilleri

Ne zaman kullan

  1. Bir sınıfın/arabirimin gerçekleştirilmesini belirtmek istediğiniz zaman, Sağlanan Arabirim şeklini kullanın.

  2. Sınıf/arabirimde bağımlılık belirtmek istediğiniz zaman Gerekli Arabirimi kullanın.

Bağlanmış iki arabirim, 1: Daireyle biten Arabirim şekli, 2: Yuva ile biten Gerekli Arabirim şekli

1. Adım

Sağlanan Arabirim şeklini sayfaya sürükleyin ve bağlantı noktası karesi için bağlantı noktasını kullanın. Bağlantı noktasının etrafında yeşil vurgu gördüğünüzde bağlantının bağlı olduğunu bilirsiniz.

Bileşen şekline tutkallı olarak sağlanan Arabirim şekli

2. Adım

Gerekli Arabirim şeklini sayfaya sürükleyin ve bağlantı noktası karesi için bağlantı noktasını da yukarı doğru tutun. Bağlantı noktasının etrafında yeşil vurgu gördüğünüzde bağlantının bağlı olduğunu bilirsiniz.

Bileşen şekline tutkallı gerekli Arabirim şekli

3. Adım

Hem Sağlanan hem de Gerekli arabirimi birbirine bağlamak için, önce Gerekli Arabirim şeklini seçin. Sonra sarı tutamacı bakın.

Gerekli Arabirim şekli üzerinde sarı tutamaç

4. Adım

Sağlanan Arabirim'e bağlanmak için sarı tutamacı sürükleyin.

Sağlanan Arabirim'e bağlı gerekli Arabirim şekli

Bağlayıcı ipuçları

Bağlayıcıları düzeltme

Bağlayıcı çok fazla dönüş alıyorsa, bağlayıcıya sağ tıklayın ve ardından Düz Bağlayıcı'ya tıklayın.

Çokluğu gösterme

Gerekirse bağlayıcıya sağ tıklayın ve ÇokŞelilik Göster'i seçin. Bitirebilirsiniz, ayrıntıları ekyebilirsiniz ve dört metin kutusu görüntülenir. Tüm metin kutularına ihtiyacınız yoksa, size gerek yok olanları silin.

Bağlayıcı türünü değiştirme

Bağlayıcı türünü değiştirebilirsiniz. Örneğin, İlişki İlişkilerinden Yönlendirilen İlişkiye değiştirebilirsiniz. Bağlayıcıya sağ tıklayın ve Bağlayıcı Türünü Ayarla'ya tıklayın.

Nokta bağlantıları yerine dinamik bağlantılar oluşturma

Şekilleri çok fazla taşımayı tahmin ediyorsanız, nokta bağlantısı yerine dinamik bağlantı oluşturabilirsiniz.

Bağlayıcılarda metni taşıma veya döndürme

Büyük olasılıkla bağlayıcı çizgileriniz üzerinde metni döndürmeniz veya taşımanız gerekir. Bu işlem şöyle yapılır:

  1. Seçilecek her şeyin seçimini kaldırmak için sayfanın boş bir alanına tıklayın.

  2. Giriş sekmesinin Araçlar grubunda Metin Bloğu aracına tıklayın ve sonra da Metin Bloğu düğmesi

  3. Döndürmek veya taşımak istediğiniz metni olan bağlayıcıya tıklayın.

  4. Metin bloğunı taşımak için sürükleyin veya taşımak için Döndürme Tutamacı' Döndürme tutamacı

  5. Bitir bittiğinde, İşaretçi Aracı düğmesine tıklayın ve sonra da İşaretçi düğmesi

    İşaretçi Aracı düğmesine geri İşaretçi düğmesi sonra, metin şekle göre aynı konumu sağlar. Metni sürüklemek için İşaretçi İşaretçi düğmesi 'nı kullanırsanız şekil de hareket eder. Metni şekilden bağımsız olarak taşımak için, Metin Bloğu Aracı'nın Metin Bloğu düğmesi .

Örnek UML bileşen diyagramı.

İlk olarak, UML Bileşeni şablonunu açar ve dört seçenekden birini seçersiniz. Ardından UML Bileşeni kalıbı, UML 2.5 standardına uygun şekillerle birlikte görüntülenir.

Not: UML Bileşeni kalıbı, yalnızca Visio Plan 2 abonesiyseniz kullanılabilir. Aboneliğiniz varsa Visio'nun en son sürümünün olduğundan emin olun.

Sıralı diyagram başlatma

  1. Web için Visio'yu açın.

  2. Galeride, sayfayı aşağı kaydırarak UML Bileşeni satırına kadar (sayfanın ortalarında) ilerleyin.

    Satırdaki ilk öğe, boş bir şablonu ve yardımcı kalıbı temsil eder. Satırdaki diğer öğeler, hızla işe başlamanıza yardımcı olmak için önceden çizilen bazı şekillere sahip örnek diyagramlardır.

  3. Daha büyük bir önizleme görmek için herhangi bir öğeye tıklayın.

  4. Kullanmak istediğiniz diyagramı butonlarken Oluştur düğmesine tıklayın.

    İlgili kalıbın yer olduğu yeni diyagram tarayıcınızda açılır.

Bileşen şekilleri

Ne zaman kullan

Sisteminiz veya uygulamanız tüm işlevsel üniteler için bileşen şekillerini kullanın.

"Depolama" bileşen şekli

Stereotipi gösterme veya gizleme

Stereotip etiketini göstermek veya gizlemek için şekle sağ tıklayın.

Sağ tıklama menüsü, StereoType komutunu göster komutu,  <<bileşeni>> etiketiyle göster

Alt sistem

Bileşen şeklini, diğer bileşenleri içeren bir alt sistem şekli olarak kullanabilirsiniz. Daha büyük olacak şekilde yeniden boyutlandırabilir ve diğer bileşenleri üzerine sürükleyebilirsiniz. Yeşil vurguyu gördüğünüzde bırakın. Bu noktadan büyük şekle bir kapsayıcı gibi davranır ve daha küçük olan şekil de kapsayıcı olarak hareket eder.

İpucu: Bileşen, başka bir bileşenin üzerine sürüklendikten sonra kaybolursa, CTRL+SHIFT+F tuşlarına basarak bileşeni öne getirin.

Sipariş bileşeni sürüklenerek üzerine sürüklenen Alt sistem şeklini depola

Arabirim şekilleri

Ne zaman kullan

  1. Bir sınıfın/arabirimin gerçekleştirilmesini belirtmek istediğiniz zaman, Sağlanan Arabirim şeklini kullanın.

  2. Sınıf/arabirimde bağımlılık belirtmek istediğiniz zaman Gerekli Arabirimi kullanın.

Bağlanmış iki arabirim, 1: Daireyle biten Arabirim şekli, 2: Yuva ile biten Gerekli Arabirim şekli

1. Adım

Sağlanan Arabirim şeklini sayfaya sürükleyin ve bağlantı noktası karesi için bağlantı noktasını kullanın. Bağlantı noktasının etrafında yeşil vurgu gördüğünüzde bağlantının bağlı olduğunu bilirsiniz.

Bileşen şekline tutkallı olarak sağlanan Arabirim şekli

2. Adım

Gerekli Arabirim şeklini sayfaya sürükleyin ve bağlantı noktası karesi için bağlantı noktasını da yukarı doğru tutun. Bağlantı noktasının etrafında yeşil vurgu gördüğünüzde bağlantının bağlı olduğunu bilirsiniz.

Bileşen şekline tutkallı gerekli Arabirim şekli

3. Adım

Hem Sağlanan hem de Gerekli arabirimi birbirine bağlamak için, önce Gerekli Arabirim şeklini seçin. Sonra sarı tutamacı bakın.

Gerekli Arabirim şekli üzerinde sarı tutamaç

4. Adım

Sağlanan Arabirim'e bağlanmak için sarı tutamacı sürükleyin.

Sağlanan Arabirim'e bağlı gerekli Arabirim şekli

Bağlayıcı ipuçları

Bağlayıcıları düzeltme

Bağlayıcı çok fazla dönüş alıyorsa, bağlayıcıya sağ tıklayın ve ardından Düz Bağlayıcı'ya tıklayın.

Çokluğu gösterme

Gerekirse bağlayıcıya sağ tıklayın ve ÇokŞelilik Göster'i seçin. Bitirebilirsiniz, ayrıntıları ekyebilirsiniz ve dört metin kutusu görüntülenir. Tüm metin kutularına ihtiyacınız yoksa, size gerek yok olanları silin.

Bağlayıcı türünü değiştirme

Bağlayıcı türünü değiştirebilirsiniz. Örneğin, İlişki İlişkilerinden Yönlendirilen İlişkiye değiştirebilirsiniz. Bağlayıcıya sağ tıklayın ve Bağlayıcı Türünü Ayarla'ya tıklayın.

Nokta bağlantıları yerine dinamik bağlantılar oluşturma

Şekilleri çok fazla taşımayı tahmin ediyorsanız, nokta bağlantısı yerine dinamik bağlantı oluşturabilirsiniz.

Bağlayıcılarda metni taşıma veya döndürme

Büyük olasılıkla bağlayıcı çizgileriniz üzerinde metni döndürmeniz veya taşımanız gerekir. Bu işlem şöyle yapılır:

  1. Seçilecek her şeyin seçimini kaldırmak için sayfanın boş bir alanına tıklayın.

  2. Giriş sekmesinin Araçlar grubunda Metin Bloğu aracına tıklayın ve sonra da Metin Bloğu düğmesi

  3. Döndürmek veya taşımak istediğiniz metni olan bağlayıcıya tıklayın.

  4. Metin bloğunı taşımak için sürükleyin veya taşımak için Döndürme Tutamacı' Döndürme tutamacı

  5. Bitir bittiğinde, İşaretçi Aracı düğmesine tıklayın ve sonra da İşaretçi düğmesi

    İşaretçi Aracı düğmesine geri İşaretçi düğmesi sonra, metin şekle göre aynı konumu sağlar. Metni sürüklemek için İşaretçi İşaretçi düğmesi 'nı kullanırsanız şekil de hareket eder. Metni şekilden bağımsız olarak taşımak için, Metin Bloğu Aracı'nın Metin Bloğu düğmesi .

Component diagram displaying the structure of software code as cohesive components

Açıklama Balonu 1 Bileşen diyagramında bileşenler, örnekler yerine genel türlerdir. Bileşen örneklerini göstermek için bir dağıtım diyagramı.

Açıklama Balonu 2 Bağımlılıkları bir istemci bileşeninin bir şekilde sağlayıcı bileşenine bağımlı olduğunu gösterir.

  1. Aşağıdaki Visio 2010: Şablon Kategorileri altında Yazılım'atıklayın, UML ModeliDiyagramı'ne ve sonra da Oluştur'a tıklayın.

  2. Sistem ağaç görünümü, sistem paketini eklemek istediğiniz pakete veya alt sisteme bileşen diyagramı tıklayın ve ardından Yeni menüsünde Bileşen Diyagramı'ne tıklayın.

    Boş bir sayfa görüntülenir ve UML Bileşeni kalıbı en üst kalıp haline gelir. Çalışma alanında 'Bileşen' filigran olarak görüntülenir. Diyagramı temsil eden bir simge ağaç görünümüne eklenir.

    Not: Ağaç görünümü görünmüyorsa, UML menüsünde Görünüm üzerine gelin ve Model Gezgini'ne tıklayın.

  3. Temsil etmek istediğiniz her bileşene uygun çizim sayfasına bir Bileşen şekli sürükleyin.

  4. Uygun olduğunda, bir Arabirim şeklini çizim sayfasına sürükleyin ve uç noktayı daire olmadan bir bileşen şekline tutkallama.

    Sınıfa, bileşene veya diğer öğelere arabirim ekleme

    1. Statik bir yapıda, bileşen veya dağıtım diyagramında, çizgilipop Interface şeklini çizim sayfasına sürükleyin.

    2. Uç noktayı daire olmadan bir bağlantı noktası veya Bağlantı noktası görüntüsü - mavi X üzerinde sınıf öğeye tutkallama.

    3. Ad, işlem ve diğer özellik değerlerini eklemek için Arabirim şekline çift tıklayın.

      İpuculistesi

      Ayrıca, sınıfa benzeyen dikdörtgen bir Arabirim şekliyle bir arabirimi de temsil edilebilirsiniz. Arabirim işlemlerinin listesini görüntülemek istediğiniz zaman bu şekli kullanın.

      Bir arabirimde görüntüleniyor olan şeklin türünü değiştirmek için, Arabirim şekline sağ tıklayın ve Sınıf Gibi Arabirim Olarak Göster veya BahçeliPop Arabirimi Olarak Göster 'e tıklayın.

  5. Bileşenler arasındaki veya bir bileşenle başka bir bileşenin arabirimi arasındaki ilişkileri göstermek için Bağımlılık şekilleri kullanın.

    UML öğeleri arasındaki bağımlılık ilişkisini göstermek

    1. UML Statik Yapısı, UMLDağıtımı veya UML Bileşeni kalıbından bir Bağımlılık şeklini çizim sayfasına sürükleyin ve ilişkilendirmek istediğiniz öğelerin yakınına tutun.

    2. Uç noktayı bir ok ucuyla bir bağlantı noktasına tutkal Bağlantı noktası görüntüsü - mavi X öğenin üzerinde bağlı olduğu öğeye bağlıdır. Ok ucu olmayan uç noktayı, diğer öğeye bağlı olan öğedeki bağlantı noktasına tutkallama.

    3. Ad, stereotip ve diğer özellikleri eklemek için bağımlılığı çift tıklatın.

      İpucu: izleme, iyileştirme, kullanım veya bağlama bağımlılığını belirtmek için, UML Statik Yapısı kalıbından İzleme ,İyileştirici, Kullanım veya Bağlama şekillerini kullanabilirsiniz.

  6. Ad, öznitelikler, işlemler ve diğer özellikleri ek şekle eklemek istediğiniz UML Özellikleri iletişim kutusunu açmak için herhangi bir şekle çift tıklayın.

  7. Diyagramı kaydedin.

Ayrıca Bkz.

Visio'da UML diyagramları oluşturma

UML iletişim diyagramı oluşturma

UML dağıtım diyagramı oluşturma

UML sıralı diyagramı oluşturma

Daha fazla yardıma mı ihtiyacınız var?

Office yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Office Insider Programına Katılın

Bu bilgi yararlı oldu mu?

×