Belirtiler
Microsoft Exchange Server 2016 Toplu Güncelleştirme 8'i (CU8) yükledikten sonra, bulut posta kutuları arşiv özelliği etkin değilse Microsoft Office 365 kullanıcılarından karma ortamlardaki şirket içi posta kutularına yapılan uygun/meşgul sorguları başarısız olur.
Neden
Bu sorun, Exchange ServerExchange Server 2016 CU8 üzerindeki OAuth bağlantısını etkileyen bilinen bir sorun nedeniyle oluşur.
Geçici çözüm
Bu soruna geçici bir çözüm bulmak için her bulut posta kutusu için kişisel arşiv posta kutuları oluşturun.
Çözüm
Bu sorunu çözmek için, Exchange ServerExchange Server 2016 için Toplu Güncelleştirme 9'u veya Exchange ServerExchange Server 2016 için daha sonraki bir toplu güncelleştirmeyi yükleyin.
Daha Fazla Bilgi
Bu sorunla karşılaştığınızı doğrulamak için Test-OAuthConnectivity cmdlet'ini kullanın.
Örneğin, Office 365 ve çalıştırmak için Uzak PowerShell'e bağlanın
Test-OAuthConnectivity -Service EWS -TargetUri https://< Şirket İçi EWS URL'si/>ews/Exchange.asmx -Posta Kutusu <Bulut Posta Kutusu>
Senaryonuz bir eşleşme ise, bu cmdlet aşağıdaki yanıtı oluşturur:
Exchange Yanıt Ayrıntıları:
HTTP yanıt iletisi:
Özel durum:
System.Net.WebException: Uzak sunucu şu hatayı döndürdü: (500) İç Sunucu Hatası.
at System.Net.HttpWebRequest.GetResponse()
at Microsoft.Exchange.Monitoring.TestOAuthConnectivityHelper.SendExchangeOAuthRequest(ADUser user, String orgDomain, Uri targetUri, String& diagnosticMessage, Boolean appOnly, Boolean useCachedToken, Boolean reloadConfig)
Durum
Microsoft bunun, "Şunlar için geçerlidir" bölümünde listelenen Microsoft ürünlerinde sorun olduğunu doğrulamıştır.
Başvurular
Microsoft'un yazılım güncelleştirmelerini tanımlamak için kullandığı terminoloji hakkında bilgi edinin.