Uzak Masaüstü kolay yazdırma, yavaş Windows Server 2012 R2'de çalışan

Bu makalede, Windows Server 2012 R2'de bir Uzak Masaüstü oturumunda yazdırma sırasında oluşan bir sorun açıklanır. Bu sorunu gidermek bir düzeltme kullanılabilir. Düzeltmeyi bir önkoşulyoktur.

Belirtiler

Windows Server'ın önceki bir sürümünden Windows Server R2 2012 için Uzak Masaüstü Sunucusu yükseltme varsayın. Bu durumda, Uzak Masaüstü kolay yazdırma sürücüsü olarak kullanan yönlendirilen yazıcı üzerinden yazdırmak için daha uzun sürer. Örneğin, yükseltme işleminden önce bir dakika içinde baskı yapıldığı, şimdi beş dakika sürer.

Neden

Windows Server 2012 R2'de eklenen Driver-Requested arşiv için iyileştirilmiş XPS çıktı olarak bilinen yeni bir özellik nedeniyle bu sorun oluşur. Bu özellik dosya aktarımı gecikme azaltır. Tasarım gereği, bu özellik biriktirme işi yazdırır önce tamamlanmasını bekler. Bunun etkisi hemen biriktirme hala devam ederken başlamaması nedeniyle yazdırma işi uzun sürüyor olur.

Çözüm

Bu sorunu gidermek için bir düzeltme yayınladık. Bu sorun yalnızca Windows Server 2012 R2'de gözlenen olsa da, düzeltmeyi Windows 8.1 ve Windows RT 8.1 için de geçerlidir.

XPS Driver-Requested arşiv için optimize edilmiş çıktı özelliği devre dışı bırakmak istiyorsanız, bu düzeltmeyi yükleyin ve aşağıdaki kayıt defteri alt anahtarı oluşturun:

HKLM\System\CurrentControlSet\Control\Print\DontUseArchive
Bu özelliği devre dışı bırakmak için regkey değeri 1 olarak ayarlayın.

Önemli Bir dil paketini yüklerseniz, bu düzeltmeyi yükledikten sonra bu düzeltmeyi yeniden yüklemeniz gerekir. Bu nedenle, herhangi bir dilde yüklemeniz önerilir önce gereken paketleri bu düzeltmeyi yükleyin. Daha fazla bilgi için bkz: .

Düzeltme bilgileri

Microsoft, desteklenen bir düzeltmeyi kullanıma sunmuştur. Ancak, bu düzeltmeyi yalnızca bu makalede anlatılan sorunu düzeltmesi amaçlanmıştır. Bu düzeltmeyi yalnızca bu sorunla karşılaşmış olan sistemlere uygulayın.

Düzeltme karşıdan yüklenebilir varsa, bu Bilgi Bankası makalesinin başında "Düzeltme karşıdan kullanılabilir" bölümü bulunur. Bu bölüm görünmüyorsa, düzeltmeyi edinmek için Microsoft Müşteri Hizmetleri ve destek için bir istek gönderin.

Not: Ek sorunlar oluşursa veya sorun giderme gerekiyorsa, ayrı bir hizmet isteği oluşturmanız gerekebilir. Ek destek sorularına ve bu düzeltme için geçerli olmayan sorunlara normal destek ücretleri uygulanır. Tam listesi Microsoft Müşteri Hizmetleri ve destek telefon numaralarını veya ayrı bir hizmet isteği oluşturmak için aşağıdaki Microsoft Web sitesine bakın:

Not: "Düzeltme karşıdan kullanılabilir" formunda düzeltmenin kullanılabilir olduğu diller görüntülenir. Kendi dilinizi görmüyorsanız, bu dil için kullanılabilir bir düzeltme değil çünkü.

Önkoşullar

Bu düzeltmeyi uygulamak için Windows 8.1 veya Windows Server 2012 R2 yüklü olması gerekir.

Yeniden başlatma gereksinimi

Bu düzeltmeyi uyguladıktan sonra bilgisayarı yeniden başlatmanız gerekebilir.

Düzeltme değiştirme bilgileri

Bu düzeltme önceden yayımlanmış bir düzeltmenin yerini değildir.

Bu düzeltmenin genel sürümü aşağıdaki tablolarda listelenen özniteliklere sahip dosyaları yükler. Bu dosyaların tarih ve saatleri Eşgüdümlü Evrensel Saat'te (UTC) listelenmiştir. Yerel bilgisayarınızda bu dosyaların tarih ve saatleri, yerel saatiniz ile geçerli gün ışığından yararlanma saati (DST) bilgilerine göre görüntülenir. Ayrıca, dosyalarda belirli işlemleri gerçekleştirdiğinizde tarihler ve saatler değişebilir.

Windows 8.1 ve Windows Server 2012 R2 dosya bilgileri ve notları

Önemli Windows 8.1 düzeltmeleri ve Windows Server 2012 R2 düzeltmeleri aynı paketlerinde bulunur. Ancak, düzeltmeler düzeltme isteği sayfasında her iki işletim sistemi altında listelenir. Bir veya her iki işletim sistemleri için geçerli olan düzeltme paketini istemek için "Windows 8.1/Windows altında Server 2012 R2" sayfada listelenen düzeltme'yi seçin. Her zaman her düzeltmenin uygulandığı gerçek işletim sistemini belirlemek için bir makale "Aşağıdakilere Uygulanır" bölümüne bakın.

  • Belirli bir ürün, aşama (RTM, SPn) ve hizmet dalı (LDR, GDR) için geçerli dosyalar, aşağıdaki tabloda gösterildiği şekilde dosya sürümü numaraları incelenerek belirlenebilir:

  • Her ortam için yüklenen MANIFEST (.manifest) ve MUM dosyaları (.mum) "Ek dosya bilgileri" bölümünde ayrı olarak listelenmiştir. MUM, MANIFEST ve ilişkili güvenlik kataloğu (.cat) dosyaları, güncelleştirilen bileşenlerin durumunu korumak için oldukça önemli dosyalardır. Özniteliklerin listelenmediği güvenlik kataloğu dosyaları, Microsoft dijital imzası kullanılarak imzalanmıştır.

Durum

Microsoft bu sorunun "Aşağıdakilere Uygulanır" bölümünde listelenen Microsoft ürünlerinde bulunduğunu onaylamıştır.

Başvurular

Microsoft'un yazılım güncelleştirmelerini açıklamak için kullandığı bakın.

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Microsoft Insider 'a katılın

Bu bilgi yardımcı oldu mu?

Geri bildiriminiz için teşekkür ederiz!

Geri bildiriminiz için teşekkürler! Office destek temsilcilerimizden biriyle görüşmeniz yararlı olabilir.

×