Як зменшити метаданих у Word 2003


Microsoft Word 2002 версію цієї статті див. 290945 .

У ЦЬОМУ ЗАВДАННІ

Загальні відомості


У цій статті описано на різні способи, в яких можна зменшити метадані в документах Word.

Під час створення, відкриття або збереження документа в Microsoft Office Word 2003, документ може містити вміст, який ви не можете спільно з іншими користувачами, під час іншим користувачам документ в електронному вигляді. Ця інформація відома як метаданих. Для різних цілей метаданих використовується для редагування, перегляд, подання та витягнення документів Office.

Деякі метаданих легко доступний через інтерфейс користувача Microsoft Word. Іншими метаданими доступний тільки надзвичайні засобами, наприклад, відкрийте документ в редакторі низького рівня двійковий файл. Нижче наведено приклади метадані, які можуть міститися в документі.
  • Твоє ім'я
  • Ініціалів
  • Ім'я компанії або організації
  • Ім'я комп'ютера
  • Ім'я сервера мережі або на жорсткому диску, де було збережено в документі
  • Інші властивості "і" зведення відомості про файл
  • Non інтерфейсів частини вбудований кількість об'єктів OLE
  • Версій документа
  • Версій документа
  • Шаблон відомостей.
  • Прихований текст
  • Примітки
Метадані створюється різними способами, в документах Word. Як наслідок, це єдиний спосіб видалення всіх такого змісту від документів. У наступних розділах області, де метаданих можуть зберігатися в документах Word.

У цій статті описано на різні способи, в яких можна зменшити метадані в документах Word.

Корпорація Майкрософт надає приклади програмного коду тільки для ілюстрації без гарантії або, – прямих або непрямих. Це включає, але не обмежується, будь-яких гарантій придатності до продажу та придатності для певної мети. У цій статті припускається, що ви знайомі з, що демонструє мову програмування та інструменти, які використовуються для створення та налагодження процедури. Співробітники служби підтримки корпорації Майкрософт можуть пояснити функціональні особливості кожної конкретної процедури, але вони не будуть змінювати приклади для реалізації додаткових можливостей або створювати процедури на вимогу окремих користувачів. Щоб отримати додаткові відомості про використання прикладів коду в цій статті, клацніть номер статті в базі знань Microsoft Knowledge Base:

290140 як запускати приклади коду для програм Office XP статей бази знань

на початок

Автоматичне видалення особистих відомостей, під час збереження

Тепер автоматично видалити особисті відомості з документа Word під час збереження документа. Щоб увімкнути цей параметр, виконайте такі дії:
  1. У меню " Сервіс " клацніть
    Параметри.
  2. На вкладці " Безпека ", клацніть на
    Видалити особисті відомості з файлу, збереження на властивості на прапорець параметри конфіденційностіа потім натисніть кнопку
    OK.
Примітка. Це рекомендованим способом видалення особистих відомостей, під час збереження документа Word.

на початок

Як вручну видалити своє ім'я користувача від документів

Щоб переглянути або змінити ім'я користувача, виконайте такі дії:
  1. У меню " Сервіс " клацніть
    Параметрита натисніть кнопку на вкладці.

    Наступні поля редагування відображаються:
    Ім'я
    Ініціали
    Поштова адреса
  2. Якщо ви не хочете, ці дані в документи, введення рядків, що не ідентифікує або просторів у відповідних редагувати поля та натисніть кнопку "ОК" , щоб прийняти зміни.
Примітка. Нові документи, які ви створюєте, буде містити цю інформацію, замість значення за промовчанням, які вводяться під час інсталяції Office. Існуючі документи вже може містити відомості.

на початок

Особисті відомості про видалення вручну

Під час створення або зберегти документ у програмі Word, зведені відомості можуть зберігатися в документі. Існує кілька способів, які можна використовувати для доступу до цієї інформації:
  • Відкрийте документ. У меню " файл " натисніть кнопку
    Властивості. Загальні відомості
    Статистичні дані, вмісті
    Настроювана вкладки можуть містити всі різні властивості, зокрема своє ім'я, ім'я вашого керівника та назву компанії.
  • У провіднику Windows у документі, клацніть правою кнопкою миші та виберіть пункт Властивості. Вкладки у полі
    Діалогове вікно властивостей , може містити інформацію.
  • Використовується Microsoft Visual Basic для застосунків (VBA) макросу або іншого програмного коду для читання властивостей, що відображається в полі
    Діалогове вікно " Властивості ".
Щоб видалити відомості про наявний документ або шаблон, виконайте такі дії:
  1. Відкрийте документ або шаблон.
  2. У меню " файл " натисніть кнопку
    Властивості.
  3. На вкладці " Загальні відомості ", клацніть, щоб зняти у
    Автор, керівник, компаніїта інші поля редагування, ви не бажаєте розповсюдження.
  4. На вкладці " Custom ", видалити будь-які властивості, які містять дані, які ви не бажаєте розповсюдження.
  5. Натисніть кнопку OK.

    У полі
    Клацніть зберегтименю " файл " і натисніть кнопку
    Закрити.
Після виконання цих дій, документ не містить зведення властивостей.

на початок

Видалення особистих відомостей зведення, під час підключення до мережі вручну

Якщо ви ввійшли до мережі, ім'я користувача в мережі можуть відображатися у вікні " автор " на вкладці " Загальні відомості ", так і в полі, збережені на в
Вкладки статистики під час збереження документа. Ця проблема може виникнути, навіть якщо, буде видалено всі особисті відомості з вашого комп'ютера.

Щоб видалити відомості про з документа, коли ви в мережі, виконайте такі дії:
  1. Якщо документ зберігається на мережному сервері, скопіюйте його на локальний жорсткий диск.
  2. Запустіть комп'ютер, але робити не вхід до мережі. Коли з'явиться діалогове вікно входу мережі, натисніть кнопку скасувати , або натисніть ESC.

    Примітка. Якщо не вдається запустити Windows за допомогою уникнути (наприклад, комп'ютер працює під керуванням Microsoft Windows NT), не можна продовжити виконувати ці дії.
  3. Відкрийте документ.
  4. У меню " файл " натисніть кнопку
    Властивості.
  5. На вкладці " Загальні відомості ", клацніть, щоб зняти у
    Автор, менеджер компаніїі будь-який інший, редагувати поля, які містять дані, які ви не бажаєте розповсюдження.
  6. На вкладці " Custom ", видалити будь-які властивості, які містять дані, які ви не бажаєте розповсюдження.
  7. Натисніть кнопку OK.

    У полі
    Клацніть зберегтименю " файл " і натисніть кнопку
    Закрити.
Під час входу до мережі, чи не відкрити файл. Якщо так, ім'я користувача мережі може записуватися у файлі. Проте можна використовувати провідник Windows, скопіюйте файл до мережного сервера "або" на дискету.

на початок

Як вручну видалити примітки документів

Microsoft Word, дає можливість додавати коментарі до документів. Як правило, коментарі, містять ім'я користувача, який створив їх, таким чином, можна визначити, який записував, їх.

Коментарі, які зазвичай відображаються як розділ виділеного тексту; Коментарі, клацніть правою кнопкою миші та виберіть команду Видалити примітку.

Будь-які створюється новий примітки не містять ім'я користувача через те, що буде видалено з до діалогового вікна Параметри , як описано в розділі "Як до вручну видалити користувача ім'я з вашої документів" цієї статті.

на початок

Як вручну видалити колонтитули документів

Колонтитули в документах, можуть містити інформації. Щоб видалити з верхні й нижні колонтитули, виконайте такі дії:
  1. У меню " вигляд " натисніть кнопку верхній і нижній колонтитули.
  2. У верхній і нижній колонтитули, з'являються у верхній і нижній частині кожної сторінки в документі.

    Змінити їх, як ви хочете.
  3. Натисніть кнопку закрити на панелі інструментів колонтитули .
на початок

Видалення знаків виправлення вручну

Документи, можуть містити знаки виправлення. З знаки виправлення може визначити, який має певні зміни у документ. Прийняття або відхилення знаки виправлення, виправлений текст, що зберігається у документі, і знаки для виправлення, буде видалено.

Щоб прийняти або Відхилити виправлення, виконайте такі дії:
  1. У меню " Tools ", виберіть Виправлення , потрібно ввімкнути.
  2. На панелі інструментів рецензування натисніть кнопку назад або Далі знайти і вибрати певні зміни. Натисніть кнопку Прийняти зміни або Відхилити виправлення або видалити примітку , прийняти або відхилити вибрано перегляд.
  3. Після завершення натисніть
    Закрити.
Примітка. Якщо змінити параметри "Показати" на панелі інструментів рецензування, відомості, отримані не буде видалено. на початок

Вимкнення функції швидкого збереження

Функцію швидкого збереження, прискорює процес збереження документа, зберігши зміни, внесені до документа.

Через функцію швидкого збереження структури текст, який ви видаляєте з документа можуть залишатися в документі, навіть після того, як зберегти документ. Якщо вас турбують видалений текст, що залишилися в документи, виконайте наведені нижче дії:
  1. У меню " Сервіс " клацніть
    Параметри.
  2. Виберіть вкладку збереження .
  3. Зніміть прапорець "Дозволити швидке збереження" а потім натисніть кнопку OK.
Щоб отримати додаткові відомості про функцію швидкого збереження клацніть номер статті в базі знань Microsoft Knowledge Base:

291181 запитання й відповіді про "Дозволити швидке збереження" у Word 2002

на початок

Як знайти та видалити текст, відформатований як прихований

В документах Word можна форматувати текст як прихований. Через те, що прихований текст, може містити інформацію, яку ви не можете поширювати, можна відобразити і видалити її. Щоб видалити весь текст, у документі, відформатованих як приховані, виконайте такі дії:
  1. У меню " Сервіс " клацніть
    Параметрита натисніть кнопку вкладку вигляд.
  2. Установіть прапорець прихований текст а потім натисніть кнопку OK.
  3. У меню Edit команду
    Чи замінити.
  4. Натисніть кнопку додаткові розширити діалогове вікно.
  5. Клацніть у полі поруч із знайти.
  6. Натисніть кнопку Формат і натисніть кнопку
    Шрифт.

    Установіть прапорець прихованийа потім натисніть кнопку OK.
  7. Натисніть кнопку, заміна.
Прихований текст, буде видалено з документа. Щоб вимкнути відображення прихованого тексту, виконайте такі дії:
  1. У меню " Сервіс " клацніть
    Параметрита натисніть кнопку вкладку вигляд.
  2. Зніміть прапорець прихований текст а потім натисніть кнопку OK.
на початок

Видалення гіперпосилання з документів

Документи, можуть містити гіперпосилання на інші документи або веб-сторінки, на інтрамережу або Інтернет. Гіперпосилання зазвичай відображаються у вигляді синій підкреслена текстові рядки.

Щоб вручну видалити гіперпосилання одного з документа гіперпосилання, клацніть правою кнопкою миші, виберіть пункт гіперпосиланнята натисніть кнопку
Про видалення гіперпосилання.

Якщо потрібно видалити всі гіперпосилання в документі, для цього можна макроса VBA. Наступний приклад макрос VBA видаляє всі гіперпосилання в документ.

Примітка. Наступний приклад макрос видаляється лише посилання. Текст гіперпосилання, залишається в документі.

Увага! Перш ніж використовувати наступний приклад макрос, перегляньте відмову від гарантій щодо вище в цій статті.
Sub RemoveHyperlinks()

Dim oDoc As Document
Dim oStory As Range
Dim oHlink As Hyperlink

For Each oStory In ActiveDocument.StoryRanges
For Each oHlink In oStory.Hyperlinks
oHlink.Delete
Next
Next

End Sub
Щоб скасувати всі трасування як гіперпосилання та текст гіперпосилання у документі, ви можна використати Наступний приклад макрос.
Sub RemoveAllHyperlinks()

Dim oDoc As Document
Dim oStory As Range
Dim oHlink As Hyperlink

For Each oStory In ActiveDocument.StoryRanges
For Each oHlink In oStory.Hyperlinks
oHlink.Range.Delete
Next
Next

End Sub
на початок

Як видалити стилі документів

Документи, можуть належати стилі, які містять метаданих. Можна видалити ці стилі або перейменувати їх. Щоб це зробити, виконайте такі дії:
  1. Відкрийте документ, який містить стилі.
  2. У меню Формат команду
    Стиль.
  3. Виберіть стиль, який потрібно видалити або перейменувати.


    Натисніть кнопку, Видалити , видалити стиль, або натисніть кнопку
    Змінити перейменуйте його.
на початок

Видалення старих версій-файлу з документами

Word включає в себе функції версії файлу, яка дає змогу зберігати кілька версій той самий документ в одному файлі. Потрібно видалити попередні версії документа, перш ніж ділитися з іншими користувачами.

Щоб видалити один або кілька версій документа, виконайте такі дії:
  1. У меню " файл " натисніть кнопку
    Версії.
  2. Виберіть версію документа, який потрібно видалити.

    Щоб виділити кілька версій, клавішу CTRL, виділіть версії.
  3. Натисніть кнопку на видалення.
  4. Після видалення старих версій документа, натисніть кнопку зберегти " файл".
на початок

Як видалити посилання з кодів полів

Зв'язані зображення та інших об'єктів у документів Word може містити посилання відомостей, як-от шлях зв'язане зображення або об'єкт. Редагування коди полів, можна видалити посилання відомості з документа.

Щоб відобразити коди полів, виконайте такі дії:
  1. У меню " Сервіс " клацніть
    Параметрита натисніть кнопку вкладку вигляд.
  2. Установіть прапорець поруч із пунктом коди полів і натисніть кнопку OK.
Після того, як коди полів відображаються, можна перевірити, щоб побачити, якщо в будь-який з них містять інформації.

Щоб скасувати зв'язування відомості зв'язане зображення або інший об'єкт, виконайте такі дії:
  1. Виділіть зв'язане зображення або об'єкт або виберіть для зображення або об'єкт, код поля коди полів відображаються.
  2. Натисніть сполучення клавіш CTRL + SHIFT + F9.
Зображення або об'єкт наразі двічі. Коли зображення або об'єкта без посилань, не можна редагувати.

на початок

Як видалити шаблон імені та розташування

Всі документи, створені у програмі Word на основі шаблону. За промовчанням це файл шаблону Normal. dot, розташовані в папці шаблони. Проте можна створити документ, який ґрунтується на інший шаблон, в іншому місці. Шлях та ім'я цей шаблон, які зберігаються у властивостях документа.

Щоб переглянути шаблон імені та розташування, виберіть пункт " Властивості " файл "і відкрийте вкладку Загальні відомості .

Навіть якщо у вас не надсилати шаблон в документі, документ зберігає ім'я та розташування шаблону. Щоб змінити шаблон імені та розташування не ідентифікує значень, виконайте такі дії:
  1. У меню " Сервіс " натисніть кнопку шаблони та надбудови.
  2. Натисніть кнопку на підключення.
  3. Виберіть шаблон, який має ім'я та розташування, які не конфіденційні або унікальні.

    Наприклад, через те, що на кожному комп'ютері, інстальована програма Word із включає в себе Normal. dot, можна вибрати Normal. dot.
  4. Клацніть Відкритиі натисніть кнопку
    OK.
Примітка. Шаблон може містити, макроси, Автотекст, настроювані стилі та настроювані панелі інструментів. Змінивши шаблони, ви можете зробити деякі з цих елементів недоступні до документа.

на початок

Як видалити відомості про маршрутизацію Slip

Під час надсилання документа електронною поштою за допомогою маршрут, відомості про маршрутизацію, може бути підключено до документа. Щоб скасувати цю інформацію в документі, потрібно зберегти документ у форматі, який не зберігає відомості про маршрутизацію інтегрованим.

У Microsoft Word, збережіть його у формат форматований текст (RTF) або HTML форматі. Закрийте його та знову відкрийте новий. Через те, що відомості про маршрутизацію інтегрованим відсутній, тепер можна зберегти документ у форматі Microsoft Word.

Також можна виконувати такі дії:
  1. Вимкніть дозволити швидке, зберігається за допомогою вказівок вище в цій статті.
  2. У меню " файл " виберіть Надіслатиі виберіть Інший одержувач.
  3. Клацніть Очистити видалити маршруту а потім натисніть кнопку OK.
  4. У меню " файл " натисніть кнопку
    Про збереження.
Тепер зберегти документ без маршрутизації інтегрованим відомостей.

на початок

Як видалити своє ім'я з коду Visual Basic

Увага! Перш ніж використовувати наступний приклад макрос, перегляньте відмову від гарантій щодо вище в цій статті.

Під час запису макроса VBA у програмі Word, записаний макрос починається заголовка, подібне до такого:
' Macro1 Macro
' Macro recorded 3/11/1999 by <User Name>
Щоб скасувати макроси, які записані своє ім'я, виконайте такі дії:
  1. Відкрийте документ, який містить макроси.
  2. У меню " Сервіс " наведіть вказівник на пункт
    Макросі виберіть команду Редактор Visual Basic. Або натисніть сполучення клавіш ALT + F11.
  3. У вікні проекту двічі клацніть значок модуль, який містить макроси.
  4. Видалити своє ім'я код Записаний макрос.
Після завершення видалення своє ім'я, натисніть ALT + Q, щоб повернутися до програми і натисніть кнопку зберегти у полі
Меню " файл ".

на початок

Як видалити посилання на інші файли на Visual Basic

У редакторі Visual Basic, можна створити посилання на інший файл. Відкриття документа, яка містить посилання на інші файли, користувач бачить посилання файли.

Щоб видалити ці посилання, виконайте такі дії:
  1. Відкрийте документ, який містить посилання.
  2. У меню " Сервіс " наведіть вказівник на пункт
    Макросі виберіть Редактор Visual Basic або натисніть сполучення клавіш ALT + F11.
  3. У меню " Сервіс " клацніть
    Посилання.
  4. Клацніть, щоб зняти прапорець поруч із вказаного файлу або файлів.

    Після завершення натисніть кнопку " OK".
  5. Натисніть сполучення клавіш ALT + Q.
  6. У меню " файл " натисніть кнопку
    Про збереження.
Примітка. Якщо видалити посилання на інші файли, це може негативно вплинути на здатність макросів у документі працює належним чином.

на початок

Як видалити мережі або інформацію на жорсткому диску

Під час збереження документа на локальному жорсткому диску або мережному сервері, інформація, що визначає локального жорсткого диска або мережного сервера може записуватися в документі.

Щоб скасувати цю інформацію в документі, виконайте такі дії:
  1. Відкрийте документ.
  2. У меню " файл " натисніть кнопку Зберегти як.

    Збережіть документ дисковода (зазвичай це диск А).
  3. У меню " файл " натисніть кнопку
    Закрити.
  4. Видалити дискету дисковод.
Тепер, можна використовувати провідник Windows для копіювання документа з дискети, будь-якого жорсткого диска або мережного сервера.

Примітка. Через обмеження простору на дискету (зазвичай 1,44 мегабайт [Мб]) цей спосіб не використовувати, якщо розмір файлу вільного простору на дискету.

на початок

Вбудований об'єктів документів може містити метаданих

Якщо вбудувати об'єкт документа, об'єкт зберігає власні властивості, незалежно від того, що робити в документі. Наприклад, якщо вбудувати книгу Microsoft Excel слово документа, документ і книги кожного має власний властивості.

Щоб скасувати метаданих вбудований об'єкт, активувати з, видалити будь-які метадані, як описано в попередніх розділах, активувати контейнер документ і збережіть документ контейнер.

Примітка. Під час активації, вбудований об'єкт у документі, відображається лише частину вбудований об'єкт документа; об'єкт, може містити додаткові відомості, які не відображається. Містить лише надання вбудований об'єкт а не вміст документа, використовуйте з
Вирізати команди меню видалення об'єкта та вставлення об'єкта в документі, за допомогою на формат WMF за допомогою команди, що Спеціальне вставлення , редагування . Після цього, не можна редагувати вбудованого об'єкта; Проте його не буде містити будь-які метадані.

на початок

Змінні документа може містити метаданих

Увага! Перш ніж використовувати наступний приклад макрос, перегляньте, відмову від гарантій щодо вище в цій статті.

Щоб видалити змінні документа, які містяться в документі Word, використовуйте Наступний приклад макрос:
Sub DeleteDocVars()

Dim Response
Dim myVar As Variable

For Each myVar In ActiveDocument.Variables
Response = MsgBox("The document variable: " & myVar.Name & vbCr & _
"Value: " & myVar.Value & vbCr & vbCr & _
"Do you want to delete the variable from this document?", vbYesNo)

If Response = "6" Then
' Delete the variable.
myVar.Delete
Else
End
End If
Next myVar

MsgBox "There are no variables in the document."

End Sub
Додаткові відомості про змінних, у редакторі Visual Basic Довідка Microsoft Visual Basic меню команду Help , введіть Змінні властивостей у помічнику Office або в майстрі відповідей і натисніть кнопку пошуку , щоб розгорнути розділ.


на початок

Загальні поради щодо безпеки

Ось деякі загальні поради, які можна використовувати для підвищення рівня безпеки у вашому оточенні:
  • Кожного разу, коли ви працюєте не за комп'ютером, допомагають забезпечити за допомогою заставку, захищеного паролем, пароль для Увімкнення або блокування функція Windows NT.
  • Якщо жодних спільних папок на комп'ютері, переконайтеся, що застосування паролі до них так, що лише зареєстрованих користувачів можуть отримати доступ до ваших папок. З міркувань безпеки ще більше за допомогою керування доступом на рівні користувача можна керувати так само, хто має доступ до вашого комп'ютера, спільних папок.
  • Під час видалення файлу негайно очистити кошик. Можна вважати службову програму, яка повністю видаляє або перезаписує файлів, після їх видалення.
  • Під час створення резервної копії даних, зберігайте резервні копії в надійному місці, безпечному, вікно депозит безпеки або в заблокованому cabinet.
  • Переконайтеся, що важливих документів буде захищено паролем таким чином, щоб їх можна відкрити лише зареєстрованих користувачів. Зберігати паролі безпеки, окремі. Якщо ви не пам'ятаєте, пароль, немає іншого способу, відновити вміст документа, захищений паролем.
  • Не розповсюджувати документи в електронному вигляді. Замість цього роздрукувати їх. Не використовуйте визначення такі елементи, як Відмітна шрифти, водяні знаки, емблеми або спеціального паперу, якщо не потрібно (наприклад, презентації).
  • Електронною поштою не анонімний. Не поштою документ, якщо вас турбують питання посвідчення надається будь-яким чином до документа.
  • Не надсилати документ через Інтернет за протоколом HTTP або протокол передавання файлів (FTP). Відомості, які надсилаються через протоколів надсилається "звичайний текст,", це означає, що це технічно можливо (але навряд чи) для того, щоб бути перехоплення.
на початок