Ознаки
Під час спроби знайти каталог елементів на порталі керування замовленнями для бізнесу 3.0 разом із Microsoft Dynamics GP 9.0 з'являється таке повідомлення про помилку:
Наразі замовлення не можна обробити. Спробуйте знову пізніше.
Причина
Ця помилка виникає, тому що на комп'ютері, де запущено Портал для бізнесу, інстальовано несумісну версію середовища виконання eConnect для Microsoft Dynamics GP 9.0.
Керування замовленнями для порталу 3.0 для бізнесу залежить від середовища виконання eConnect 9.0.0.0. Однак веб-служби для Microsoft Dynamics GP зараз складено з пакета оновлень 1 для eConnect Runtime 9.0.1.0. Якщо на тому самому комп'ютері, на якому інстальовано портал керування замовленнями для бізнесу 3.0, інстальовано версію 9.0.1.0 із середовища виконання eConnect, станеться помилка.
Спосіб вирішення
Щоб вирішити цю проблему, видаліть із комп'ютера середовище виконання eConnect 9.0.1.0. Для цього виконайте описані нижче дії.
-
Натисніть кнопку Пуск і виберіть Панель керування.
-
Двічі клацніть елемент Установка й видалення програм.
-
Виберіть eConnect Runtime 9.0.1.0і натисніть кнопку Видалити.
Після видалення eConnect Runtime 9.0.1.0 інсталюйте eConnect Runtime 9.0.0.0 з інсталяційного компакт-диска порталу для бізнесу. Щоб запустити інсталятор, виконайте такі дії:
-
На компакт-диску інсталяції Бізнес-порталу знайдіть папку PreReqs\eConnect.
-
Двічі клацніть Microsoft_Business_Solutions_eConnect_Runtime.exe файлу.
Додаткові відомості
Відтворення проблеми
-
Настройте портал керування замовленнями для бізнесу 3.0, а потім створіть замовлення, щоб переконатися, що програма працює.
-
Видаліть із комп'ютера середовище виконання eConnect 9.0.0.0.
-
Інсталюйте на комп'ютері веб-служби для Microsoft Dynamics GP 9.0.
-
Спробуйте створити замовлення за допомогою порталу керування замовленнями для бізнесу 3.0.