Ознаки
Під час обробки робочого циклу угоди про рівень обслуговування (SLA), у журналі Operations Manager реєструється така помилка:
Ім'я журналу: Operations Manager
Джерело: SMCMDB Підписка Джерело даних Модуль
Ідентифікатор події: 33601
Категорія завдання: Немає
рівня: Ключові слова помилки
: Класичний
користувач: N/A
Комп'ютер: Ім'я
комп'ютера Опис:
Конфігурація підписки бази даних неприпустима.
Сталися такі помилки:
Повідомлення про виняткову ситуацію: помилка конфігурації передплати. Помилка під час читання елемента TargetType. Повідомлення про помилку: указано неприпустимий атрибут TargetType. Ідентифікатор цільового типу 9bc85fd0-934c-bfdb-9643-63779a0f3742 має бути абстрактним або першим не абстрактним базовим типом.
Це вплинуло на одну або кілька передплат.
Ім'я передплати: ім'я екземпляра WorkflowSubscription_9d183789_7944_49f2_b5fe_2d8f77ad6ddc
: цільовий робочий цикл SLA: ідентифікатор екземпляра DisplayName
: {69CBC824-AA85-B123-58C3-A46F97E54BF7}
Група керування: ManagementGroup
Причина
Ця проблема може виникнути, коли цільовий рівень служби (SLO) настроєно на використання похідного класу. Наприклад, припустімо, що ви створюєте новий клас на основі класу запитів на обслуговування та називається SRNewClass. Коли ви створюєте цільовий рівень обслуговування, а потім вибираєте SRNewClass з розділу "Клас" на вкладці Загальні майстра, подія з ідентифікатором 33601 повертається під час робочого циклу.
Спосіб вирішення
Створюючи або налаштовувавши SLO, виберіть базовий клас, з якого походить новий клас (наприклад, запит на обслуговування). У розділі "Черги" майстра створення цільових цілей рівня служби виберіть певну чергу, до якої потрібно спрямувати ці запити на обслуговування класу.
Додаткові відомості
Для тестування створіть новий запит на обслуговування за допомогою класу SRNewClass, а потім призначте його черзі, указаній у SLO. Рівень обслуговування буде застосовано до цього запиту, оскільки на його базі це запит на обслуговування. Використовуючи чергу та базовий клас запиту служби в цільовому рівні обслуговування, ви дозволяєте застосовувати рівень служби до будь-якого запиту на обслуговування, призначеного вказаній черзі.