创建新数据库

应用对象
Microsoft 365 专属 Access Access 2024 Access 2021 Access 2019 Access 2016

本文介绍了启动 Access 和创建将在台式计算机(而不是通过 Web)使用的数据库的基本过程。 它说明如何使用模板创建桌面数据库,以及如何通过创建自己的表、窗体、报表和其他数据库对象从头开始构建数据库。 它还介绍了一些可用于将现有数据导入新数据库的方法。

本文内容

概述

首次启动 Access 时或关闭数据库而不关闭 Access,将显示 MicrosoftOffice Backstage 视图。

Backstage 视图是一个起点,你可以从它开始创建新数据库、打开现有数据库、查看 Office.com 中的特色内容 - 任何你可以使用 Access 对数据库文件或数据库外部(而不是在数据库内)执行的操作。

创建数据库

打开 Access 时,Backstage 视图显示 “新建 ”选项卡。“ 新建 ”选项卡提供了多种创建新数据库的方法:

  • 空白数据库 如果需要,可以从头开始。 如果您有非常具体的设计要求或有需要容纳或合并的现有数据,这是一个不错的选择。
  • 随 Access 一起安装的模板 如果您要开始一个新项目并希望抢占先机,请考虑使用模板。 默认情况下,Access 附带多个模板。
  • 来自 Office.com 的模板除了 Access 附带的模板,你还可以在 Office.com 上找到更多模板。 甚至无需打开浏览器,可从 “新建 ”选项卡获取模板。

添加到数据库

在数据库中工作后,可以添加字段、表或应用程序部件。

应用程序部件是一项功能,可让您将多个相关的数据库对象(如同一个对象)一起使用。 例如,应用程序部件可能由一个表和一个基于该表的窗体组成。 您可以使用应用程序部分同时添加表和表单。

您还可以创建查询、窗体、报表、宏 - 您习惯使用的所有数据库对象。

使用模板创建数据库

Access 附带了各种模板,可以按原样使用,也可以作为起点使用。 模板是一个即用型数据库,包含执行特定任务所需的所有表、查询、表单、宏和报告。 例如,您可以使用一些模板来跟踪问题、管理联系人或保留费用记录。 某些模板包含一些示例记录以帮助演示其使用情况。

如果这些模板之一满足你的需求,那么使用它通常是启动数据库的最快方法。 但是,如果其他程序中的数据想要导入到 Access 中,则最好在不使用模板的情况下创建数据库。 模板已经定义了数据结构,可能需要大量工作来使现有数据适应模板的结构。

  1. 如果已打开数据库,请在 “文件 ”选项卡上单击 “关闭”。 Backstage 视图显示 “新建 ”选项卡。
  2. “ 新建 ”选项卡中提供了多组模板,其中一些模板内置于 Access 中。 可以从 Office.com 下载其他模板。 有关详细信息,请参阅本文的下一部分。
  3. 选择要使用的模板。
  4. Access 会在“ 文件名 ”框中建议数据库的文件名,你可以根据需要更改文件名。 要将数据库保存在与文件名框下方显示的文件夹不同的文件夹中,请单击 ,浏览到要保存数据库的文件夹,然后单击“ 确定”。 或者,可以创建数据库并将其链接到 SharePoint 网站。
  5. 单击“创建”。
    Access 会从所选模板创建数据库,然后打开该数据库。 对于许多模板,会显示一个表单,您可以在其中开始输入数据。 如果您的模板包含示例数据,则可以通过单击记录) 左侧的阴影框或条 (记录选择器,然后执行以下操作来删除每个记录:
    在“开始”选项卡上的“记录”组中,单击“删除”。
  6. 若要开始输入数据,请单击窗体上的第一个空单元格,然后开始键入。 使用导航窗格浏览可能要使用的其他窗体或报表。 某些模板包括一个导航窗体,允许您在不同的数据库对象之间移动。

有关使用模板的详细信息,请参阅使用 模板创建 Access 桌面数据库一文。

返回页首

在不使用模板的情况下创建数据库

如果您对使用模板不感兴趣,可以通过构建自己的表、窗体、报表和其他数据库对象来创建数据库。 在大多数情况下,这涉及以下一项或两项:

  • 将数据输入、粘贴或导入到创建新数据库时创建的表中,然后使用“创建”选项卡上的“表”命令对创建的新表重复此过程。
  • 从其他源导入数据并在此过程中创建新表。

创建空白数据库

  1. 在 “文件 ”选项卡上,单击“ 新建”,然后单击 “空白数据库”。
  2. 在“ 文件名 ”框中键入文件名。 若要更改文件的默认位置,请单击“ 浏览”找到一个位置,将数据库 (放在“ 文件名 ”框旁边) ,浏览到新位置,然后单击 “确定”。
  3. 单击“创建”。
    Access 会使用名为 Table1 的空表创建数据库,然后在数据表视图中打开 Table1。 将光标放置在 “单击以添加” 列的第一个空单元格中。
  4. 开始键入内容以添加数据,也可以粘贴其他源中的数据,如 将数据从其他源复制到 Access 表部分中所述。

在数据表视图中输入数据的设计非常类似于在 Excel 工作表中工作。 输入数据时创建表结构。 向数据表添加新列时,将在表中定义一个新字段。 Access 会根据输入的数据自动设置每个字段的数据类型。

如果此时不想在 Table1 中输入数据,请单击 “关闭” 。 如果对表进行了任何更改,Access 会提示您保存更改。 单击 “是 ”保存更改,单击 “否” 以放弃更改,或单击“ 取消 ”保持表打开状态。

提示

Access 会在位于 [install drive]:\Program Files\MicrosoftOffice\Templates\1033\Access\ 的文件夹中查找名为 Blank.accdb 的文件。 如果存在, 则 Blank.accdb 将作为所有新空白数据库的模板。 它包含的任何内容都由所有新的空白数据库继承。 这是分发默认内容(如零件编号或公司免责声明和政策)的好方法。

重要

如果关闭 Table1 时未保存至少一次,Access 会删除整个表,即使你在表中输入了数据,也是如此。

添加表格

可以使用“创建”选项卡上“表”组中的命令将新表添加到现有数据库中。

Access 功能区图像

从数据表视图开始创建表 在数据表视图中,可立即输入数据,并让 Access 在后台生成表结构。 字段名称按数字方式 (Field1、Field2 等) 分配,Access 会根据输入的数据自动设置每个字段的数据类型。

  1. 在“创建”选项卡上的“表”组中,单击“表”。
    Access 将创建表并选择“ 单击以添加 ”列中的第一个空单元格。
  2. 在 “表字段 ”选项卡的“ 添加 & 删除 ”组中,单击要添加的字段类型。 如果没有看到所需的类型,请单击 “其他字段” 。
  3. Access 显示常用字段类型的列表。 单击所需的字段类型,Access 会在插入点将新字段添加到数据表中。
    可以通过拖动来移动字段。 在数据表中拖动字段时,将显示一个垂直插入栏,该字段将放置的位置出现。
  4. 若要添加数据,请开始在第一个空单元格中键入内容,或粘贴来自其他源的数据,如 将数据从其他源复制到 Access 表部分中所述。
  5. 若要重命名列 (字段) ,请双击列标题,然后键入新名称。
    应为每个字段指定有意义的名称,以便在“ 字段列表 ”窗格中看到它时可以分辨出它包含的内容。
  6. 若要移动列,请单击其标题以选择列,然后将列拖动到所需位置。 还可以选择多个连续列,然后将它们一次性拖动到新位置。 若要选择多个连续列,请单击第一列的列标题,然后在按住 SHIFT 的同时,单击最后一列的列标题。

从设计视图开始创建表 在“设计”视图中,首先创建表结构。 然后切换到“数据表视图”以输入数据,或使用其他方法(如粘贴或导入)输入数据。

  1. 在“创建”选项卡上的“表”组中,单击“表设计”。

  2. 对于表中的每个字段,在 “字段名称” 列中键入名称,然后从 “数据类型 ”列表中选择一种数据类型。

  3. 如果需要,可以在“ 说明 ”列中键入每个字段的说明。 然后,当光标位于数据表视图中的该字段中时,说明将显示在状态栏上。 说明还用作通过从 “字段列表 ”窗格拖动字段创建的窗体或报表中的任何控件以及使用“窗体向导”或“报表向导”时为该字段创建的任何控件的状态栏文本。

  4. 添加所有字段后,保存表:

    • 在“文件”选项卡上,单击“保存”。
  5. 您可以随时切换到“数据表视图”并单击第一个空单元格,开始在表中键入数据。 还可以粘贴其他源中的数据,如 将数据从其他源复制到 Access 表部分中所述。

在设计视图中设置字段属性 无论如何创建表,最好检查和设置字段属性。 虽然某些属性在数据表视图中可用,但某些属性只能在设计视图中设置。 若要切换到设计视图,请在导航窗格中右键单击表,然后单击“ 设计视图”。 若要查看字段的属性,请单击设计网格中的字段。 属性显示在设计网格下方的 字段属性下。

要查看每个字段属性的描述,请单击该属性,然后阅读 字段属性下属性列表旁边框中的描述。 您可以通过单击“帮助”按钮获取更多详细信息。

下表描述了一些通常会调整的字段属性。

属性 说明
字段大小 对于文本字段,此属性设置字段中可存储的最大字符数。 最大值为 255。 对于“数字”字段,此属性设置将存储 (“长整数”、“双精度”等) 数字的类型。 为了获得最高效的数据存储,建议您分配您认为需要用于数据的最小空间量。 如果您的需求发生变化,您可以稍后向上调整该值。
格式 此属性设置数据的显示方式。 它不会影响实际数据,因为它存储在字段中。 可以选择预定义格式或输入自定义格式。
输入掩码 使用此属性可为将在此字段中输入的所有数据指定模式。 这有助于确保正确输入所有数据,并且其中包含所需的字符数。 有关构建输入掩码的帮助,请单击属性框右侧的 “生成器”按钮 。
默认值 使用此属性指定每次添加新记录时将显示在此字段中的默认值。 例如,如果您有一个日期/时间字段,并且始终需要在其中记录添加记录的日期,则可以输入“日期 () ” (而不) 引号作为默认值。
必选 此属性设置此字段中是否需要值。 如果将此属性设置为 “是”,则除非为此字段输入值,否则 Access 不允许添加新记录。

返回页首

将数据从其他源复制到 Access 表中

如果数据当前存储在其他程序(如 Excel)中,则可以将其复制并粘贴到 Access 表中。 一般情况下,如果数据已经分隔成几列,就像在 Excel 工作表中一样,这种方法最有效。 如果数据位于文字处理程序中,最好使用选项卡分隔数据列,或者在复制数据之前将数据转换为文字处理程序中的表。 如果数据需要任何编辑或操作 (例如,将全名分隔为名字和姓氏) ,则可能需要在复制数据之前执行此操作,尤其是在不熟悉 Access 的情况下。

将数据粘贴到空表中时,Access 会根据在空表中找到的数据类型来设置每个字段的数据类型。 例如,如果粘贴的字段中只包含日期值,Access 会将“日期/时间”数据类型应用于该字段。 如果粘贴的字段仅包含词“是”和“否”,Access 会将“是/否”数据类型应用于该字段。

Access 根据在粘贴数据的第一行中找到的内容来命名字段。 如果粘贴数据的第一行类型与后面的行相似,Access 会确定第一行是数据的一部分,并为该字段指定通用名称 (F1、F2 等 ) 。 如果粘贴数据的第一行与后面的行不相似,Access 会确定第一行由字段名称组成。 Access 会相应地为字段命名,并且不包括数据中的第一行。

如果 Access 分配了通用字段名称,应尽快重命名字段以避免混淆。 使用以下过程:

  1. 按 CTRL+S 保存表。
  2. 在“数据表”视图中,双击每个列标题,然后为每个列键入描述性字段名称。
  3. 再次保存表。

注意

也可以通过切换到“设计”视图并编辑字段名称来重命名字段。 若要切换到设计视图,请右键单击导航窗格中的表,然后单击“ 设计视图”。 若要切换回数据表视图,请双击导航窗格中的表。

返回页首

你可能有存储在其他程序中的数据,并且想要将该数据导入到新表中或将其追加到 Access 中的现有表。 或者,你可能与将数据保存在其他程序中的人员一起工作,并且你希望通过链接到该程序在 Access 中处理这些数据。 无论使用哪种方法,Access 都可以轻松地处理来自其他源的数据。 可以从 Excel 工作表、其他 Access 数据库中的表、SharePoint 列表或各种其他源导入数据。 使用的过程因来源而略有不同,但以下过程将帮助你入门。

  1. 在 Access 中, 在“外部数据 ”选项卡上的“ 导入 & 链接 ”组中,选择 “新建数据源”,然后选择要导入的文件类型的命令。
    例如,如果要从 Excel 工作表导入数据,请单击“从文件>Excel 新建数据源>”。

    注意

    如果在“ 导入 & 链接 ”组中找不到正确的格式类型,则可能需要启动最初在其中创建数据的程序,然后使用该程序将数据保存为常见的文件格式 (例如分隔的文本文件) ,然后才能将该数据导入 Access。

  2. 在“ 获取外部数据 ”对话框中,单击“ 浏览 ”以查找源数据文件,或在 “文件名 ”框中键入源数据文件的完整路径。

  3. 单击希望所有程序都允许导入的选项 (某些程序允许你在 “指定要在当前数据库中存储数据的方式和位置”下追加或链接) 。 可以创建使用导入的数据的新表,或者通过某些程序 () 可以将数据追加到现有表,或创建一个链接表,该链接表维护与源程序中数据的链接。

  4. 如果向导启动,请按照向导后几页的说明进行操作。 在该向导的最后一页上,单击“完成”。
    如果从 Access 数据库导入对象或链接表,则将显示“ 导入对象 ”或 “链接表 ”对话框。 选择所需项目,然后单击 “确定”。
    确切的过程取决于是选择导入、追加还是链接数据。

  5. Access 将提示你是否要保存刚完成的导入操作的详细信息。 如果您认为将来将再次执行相同的导入操作,请单击 “保存导入步骤”,然后输入详细信息。 然后,您可以在将来轻松地重复该操作,方法是在“外部数据”选项卡上的“导入 & 链接”组中单击“保存的导入”。如果不想保存操作的详细信息,请单击关闭。

如果选择导入表,Access 会将数据导入新表,然后在导航窗格的 “表” 组下显示该表。 如果选择将数据追加到现有表中,则数据将添加到该表中。 如果选择链接到数据,Access 将在导航窗格的“ 表 ”组下创建一个链接表。

返回页首

添加应用程序部件

可以使用应用程序部件向现有数据库添加功能。 应用程序部分可以像单个表一样简单,也可以包含多个相关对象,例如表和绑定表单。

例如,注释应用程序部分由一个包含“自动编号 ID”字段、一个日期字段和一个备注字段的表组成。 您可以将其添加到任何数据库并按原样使用,或者只需最少的自定义即可使用。

  1. 打开要向其中添加应用程序部件的数据库。
  2. 单击“创建”选项卡。
  3. 在 “模板” 组中,单击 “应用程序部件”。 此时将打开可用部件列表。
  4. 单击要添加的应用程序部件。

返回页首

打开现有 Access 数据库

  1. 在“文件”选项卡上,单击“打开”。

  2. 在“ 打开 ”对话框中,浏览到要打开的数据库。

  3. 执行下列操作之一:

    • 双击数据库,以“ Access 选项” 对话框中指定的默认模式或由管理策略设置的模式打开它。
    • 单击 “打开” 以在多用户环境中打开数据库以进行共享访问,以便您和其他用户可以读取和写入数据库。
    • 单击“ 打开 ”按钮旁边的箭头,然后单击“ 以只读方式打开 数据库以进行只读访问,以便可以查看但不能对其进行编辑。 其他用户仍可以读取和写入数据库。
    • 单击 “打开 ”按钮旁边的箭头,然后单击“ 打开独占” 以使用独占访问打开数据库。 使用独占访问权限打开数据库时,尝试打开该数据库的任何其他人都会收到“文件已在使用中”消息。
    • 单击 “打开 ”按钮旁边的箭头,然后单击“ 打开独占只读 ”以打开数据库以进行只读访问。 其他用户仍可以打开数据库,但他们仅限于只读模式。

注意

可以直接以外部文件格式(如 dBASE、MicrosoftExchange 或 Excel)打开数据文件。 还可以直接打开任何 ODBC 数据源,例如 MicrosoftSQL Server。 Access 会自动在与数据文件相同的文件夹中创建新的 Access 数据库,并添加指向外部数据库中每个表的链接。

提示

  • 若要打开最近打开的数据库之一,请在 “文件 ”选项卡上单击 “最近使用”,然后单击该数据库的文件名。 Access 将使用与上次打开数据库时相同的选项设置打开数据库。 如果未显示最近使用的文件列表,请在“ 文件 ”选项卡上单击 “选项”。 在“ Access 选项” 对话框中,单击 “客户端设置”。 在 “显示”下,输入要在“最近使用的文档”列表中显示的文档数,最多 50 个。
    还可以在 Backstage 视图的导航栏中显示最近的数据库,以便进行两键访问:1) “文件 ”选项卡,2) 要打开的最近数据库。 在“最近”选项卡底部附近,选中“快速访问此数量的最近数据库”检查框,然后调整要显示的数据库数。
  • 如果要通过单击“文件”选项卡上的“打开”命令打开数据库,则可以通过单击“打开”对话框中的“我最近使用的文档”来查看先前打开的数据库的快捷方式列表。

返回页首