修改 Excel 的数据导入和分析选项,例如数据透视表默认值、数据模型行为、加载项、性能设置以及对“数据选项”对话框中旧版导入向导的访问权限。
你还可以控制 Excel 在导入和分析过程中如何自动转换传入数据 (,例如数字、日期和格式) ,以更好地匹配数据需求。
通过选择“文件>选项数据>”查找这些选项。
数据选项
-
更改数据透视表的默认布局
从新数据透视表的多个 默认布局选项 中进行选择。 例如,选择始终以表格形式而不是压缩形式创建新数据透视表,或在更新时关闭“自动调整列宽”。 -
禁用大型数据透视表刷新操作的撤消,以减少刷新时间
如果选择禁用撤消,请选择行数作为何时禁用它的阈值。 默认值为 300,000 行。 -
创建数据透视表、查询表和数据连接时首选 Excel 数据模型
数据模型集成了多个表中的数据,从而在 Excel 工作簿中有效地构建关系数据源。 -
禁用大型数据模型操作的撤消。
如果选择禁用撤消,请选择文件大小中的兆字节数作为何时禁用它的阈值。 默认值为 8 MB。 -
启用数据分析加载项:Power Pivot、Power View 和 3D Maps。
在此处启用数据分析加载项,而不是通过“加载项”选项卡。 -
禁用数据透视表中日期/时间列的自动分组。
默认情况下,日期和时间列在它们旁边使用 + 符号分组。 此设置将禁用该默认值。
显示旧数据导入向导
与旧版数据导入向导相比,功能区上的“数据”选项卡提供的 Power Query 提供了更现代的数据连接器和转换功能。 但是,有时您可能仍然需要使用这些向导之一导入数据。 例如,当你希望将数据源身份验证凭据另存为工作簿的一部分时。
安全性 不建议保存凭据,这可能会导致安全和隐私问题或数据泄露。
注意
Web (旧版) 数据导入向导已弃用。 将 Power Query Web 连接器用于新的 Web 查询。 若要将较旧的 Web 查询移动到 Power Query,请参阅将较旧的 Web 查询移动到 Power Query。
启用旧版数据导入向导
选择文件>选项>数据。
选择一个或多个向导以启用 Excel 功能区的访问权限:
- 访问旧版) (
- Web (旧版) (已弃用)
- 旧版) (文本
- SQL Server (旧版)
- OData 数据馈送 (旧版)
- XML 数据导入 (旧版)
- 旧版) (数据连接向导
- 旧版) (Microsoft查询
关闭工作簿,然后重新打开它以查看激活的向导。
选择“ 数据>获取>数据旧版向导”,然后选择所需的向导。
可以通过重复步骤 1 到 3 并清除步骤 2 中所述的检查框来禁用这些向导。
自动数据转换
在 Excel 中输入、粘贴或加载文本时启用所有默认数据转换。 清除此框可取消选择并选择以下一个或多个选项:
- 删除前导零并转换为数字 禁用此选项可将具有前导零的数值数据存储为文本并保留前导零,而不是将其转换为数字并丢失前导零。 例如, 00123 在文本中仍为 00123 ,不会转换为数字 123。
- 保留长数字的前 15 位数字并以科学记数法显示 禁用此选项可将具有 16 位或更多位数字的数字数据存储为文本并保留所有数字,而不是仅保留前 15 位数字并将其转换为可能以科学记数法显示的数字。 例如, 12345678901234567890 在文本中保持 12345678901234567890 ,不会转换为数字 12345678901234500000 ,也不会在科学记数法中显示为 1.23457E+19。
- 将字母“E”周围的数字转换为科学记数法中的数字禁用此选项可将字母“E”周围的数值数据存储为文本,而不是将其转换为科学记数法中的数字。 例如, 123E5 在文本中仍为 123E5 ,并且在科学记数法中不会转换为数字 1.23E+07 。
- 将连续字母和数字转换为日期禁用此选项可将具有连续字母和数字的“类似日期”的值存储为文本,而不是转换为日期。 例如,JAN1 在文本中仍为 JAN1,不会转换为日期 1 月 1 日。 包含空格或其他字符(如 JAN 1 或 JAN-1)的数据可能仍被视为日期。
其他选项
加载 .csv 文件或类似文件时,通知我任何自动数据转换 禁用此选项可停止显示指示即将发生的数据转换的对话框。 默认情况下,显示对话框。 但是,如果禁用上述所有选项,该对话框也不会显示。