如何在 Word 中使用域代码创建目录和索引

Support for Office 2003 has ended

Microsoft ended support for Office 2003 on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

本文已归档。它按“原样”提供,并且不再更新。
有关本文的 Microsoft Word 98 Macintosh Edition 版本,请参见 190610
有关本文的 Microsoft Word 97 版本,请参见 125937
概要
本文说明了如何创建目录项域(TC 域)以及生成目录,还说明了如何创建索引项域(XE 域)以及生成索引。

如何创建目录项 (TC) 域

有两种方法可以标记目录项:创建自定义菜单命令或者使用键盘。

方法 1:如何创建自定义菜单命令

部分 A:要向“插入”菜单添加“MarkTableofContentsEntry”菜单命令,请按照下列步骤操作:
  1. 在“工具”菜单上,单击“自定义”,然后单击“工具栏”选项卡。
  2. 单击以选中“菜单栏”复选框。

    注意:默认情况下,此选项处于选中状态。
  3. 在“自定义”对话框中,单击“命令”选项卡。
  4. 在“类别”列表中,单击“所有命令”。
  5. 在“命令”列表中,单击“MarkTableOfContentsEntry”,然后将该命令拖至“插入”菜单。指向希望该命令在菜单上出现的位置,然后松开鼠标按钮。
  6. 在“自定义”对话框中,单击“关闭”。
部分 B:要标记要在目录中包含的文本,请按照下列步骤操作:
  1. 选择要包含的文本。
  2. 在“插入”菜单上,单击“标记目录项”。
  3. 在“标记目录项”框中,如果希望文本不同于所选的文本,请修改它。
  4. 在“目录标识符”列表中,单击表示目录的“C”。
  5. 在“级别”列表中,选择目录项的级别。
  6. 单击“标记”。
  7. 单击“关闭”。
  8. 对文档中的每个目录项重复此过程中的步骤 1 至步骤 7。

方法 2:如何使用键盘

  1. 选择希望作为目录项包含的一个或多个字词。
  2. 按 Alt+Shift+O。

    将出现“标记目录项”对话框。
  3. 在“标记目录项”框中,如果希望文本不同于所选的文本,请修改它。
  4. 在“目录标识符”列表中,单击表示目录的“C”。
  5. 在“级别”列表中,选择目录项的级别。
  6. 单击“标记”。
  7. 单击“关闭”。
  8. 对于希望创建的每个目录项重复步骤 1 至步骤 7。

如何生成目录

要生成目录,请按照下列步骤操作:
  1. 将插入点放在希望显示目录的位置。
  2. Word 2003
    在“插入”菜单上,指向“引用”,然后单击“索引和目录”。

    Word 2002
    在“插入”菜单上,单击“引用”,然后单击“索引和目录”。

    Word 2000
    在“插入”菜单上,单击“索引和目录”。
  3. 单击“目录”选项卡,然后单击“选项”按钮。
  4. 单击以选中“目录项域”复选框。
  5. 单击两次“确定”。
目录将在插入点位置插入。

如何创建索引项 (XE) 域

要标记索引项,可以使用以下任一方法:
  • 使用自定义菜单命令。
  • 使用标准菜单命令。
  • 使用键盘。
  • 使用应对文件。

方法 1:如何使用自定义菜单命令

部分 A:要向“插入”菜单添加“MarkIndexEntry”命令,请按照下列步骤操作:
  1. 在“工具”菜单上,单击“自定义”,然后单击“工具栏”选项卡。
  2. 单击以选中“菜单栏”复选框。

    注意:默认情况下,此选项处于选中状态。
  3. 在“自定义”对话框中,单击“命令”选项卡。
  4. 在“类别”列表中,单击“所有命令”。
  5. 在“命令”列表中,单击“MarkIndexEntry”,然后将该命令拖至“插入”菜单。指向希望该命令在菜单上出现的位置,然后松开鼠标按钮。
  6. 在“自定义”对话框中,单击“关闭”。
部分 B:要标记要在索引中包含的文本,请按照下列步骤操作:
  1. 选择(突出显示)要包含的文本。
  2. 在“插入”菜单上,单击“标记索引项”。
  3. 在“主索引项”框中,如果希望文本不同于所选的文本,请修改它。键入“次索引项”文本,然后选择需要的选项和页码格式。
  4. 单击“标记”以标记所选的文本,或者单击“标记全部”按钮以标记所选文本的所有匹配项。
  5. 单击“关闭”。
  6. 对希望创建的每个索引项重复步骤 1 至步骤 5。

方法 2:如何使用标准菜单命令

要标记要在索引中包含的文本,请按照下列步骤操作:
  1. Word 2003
    在“插入”菜单上,指向“引用”,然后单击“索引和目录”。

    Word 2002
    在“插入”菜单上,单击“引用”,然后单击“索引和目录”。

    Word 2000
    在“插入”菜单上,单击“索引和目录”。
  2. 在“索引”选项卡上,单击“标记索引项”按钮。
  3. 键入“主索引项”和“次索引项”文本,然后选择需要的选项和页码格式。
  4. 单击“标记”。
  5. 对希望创建的每个索引项域重复此过程中的步骤 3 和步骤 4。
  6. 单击“关闭”。

方法 3:如何使用键盘

要标记要在索引中包含的文本,请按照下列步骤操作:

  1. 选择希望作为索引项包含的一个或多个字词。
  2. 按 Alt+Shift+X。将出现“标记索引项”对话框。
  3. 在“主索引项”框中,如果希望文本不同于所选的文本,请修改它。键入“次索引项”文本,然后选择需要的选项和页码格式。
  4. 单击“标记”以标记所选的文本,或者单击“标记全部”按钮以标记所选文本的所有匹配项。
  5. 单击“关闭”。
  6. 对每个索引项域重复此过程中的步骤 1 至步骤 5。

方法 4:如何使用应对文件

当您清楚要对哪些字词编制索引并且希望一次性对文档中的所有这些字词编制索引时,可使用本方法。

要使用应对文件创建索引,请按照下列步骤操作:
  1. 在一个新文档中,插入一个两列的表格。
  2. 在左列中,键入文档中您要标记以编制索引的字词。

    注意,这些项是区分大小写的。
  3. 在右列中,键入要在索引中出现的相应文本。
  4. 保存并关闭此文档。
  5. 打开要在其中创建索引的文档。
  6. Word 2003
    在“插入”菜单上,指向“引用”,然后单击“索引和目录”。

    Word 2002
    在“插入”菜单上,单击“引用”,然后单击“索引和目录”。

    Word 2000
    在“插入”菜单上,单击“索引和目录”。
  7. 单击“索引”选项卡。
  8. 单击“自动标记”。
  9. 选择在步骤 1 至步骤 4 中创建的文件,然后单击“打开”。
Word 将自动标记文档中的字词。

如何生成索引

要生成索引,请按照下列步骤操作:
  1. 打开已在其中插入索引项的文档,然后将插入点放在希望索引出现的位置。
  2. Word 2003
    在“插入”菜单上,指向“引用”,然后单击“索引和目录”。

    Word 2002
    在“插入”菜单上,单击“引用”,然后单击“索引和目录”。

    Word 2000
    在“插入”菜单上,单击“索引和目录”。
  3. 单击“索引”选项卡,然后单击“确定”。
索引将在插入点位置插入。
WD2000 WD2002
属性

文章 ID:212346 - 上次审阅时间:12/05/2015 11:59:39 - 修订版本: 3.1

Microsoft Office Word 2003, Microsoft Word 2002 标准版, Microsoft Word 2000 标准版

  • kbnosurvey kbarchive kbhowtomaster kbhowto KB212346
反馈