修复︰ 有效的派生的列表达式在 2014年和 2016 SSIS 2012 年可能会失败

重要说明:本文是由 Microsoft 机器翻译软件进行的翻译并可能由 Microsoft 社区通过社区翻译机构(CTF)技术进行后期编辑,或可能是由人工进行的翻译。Microsoft 同时向您提供机器翻译、人工翻译及社区后期编辑的文章,以便对我们知识库中的所有文章以多种语言提供访问。翻译的文章可能存在词汇、句法和/或语法方面的错误。Microsoft 对由于内容的误译或客户对内容的使用所导致的任何不准确、错误或损失不承担责任。

点击这里察看该文章的英文版: 3164404
症状
假定您在 SQL Server Integration Services (SSI) 包,创建派生的列并添加有效的派生的列表达式。在此情况下,您可能会收到验证错误。

注意将 SSIS 2008 包迁移到 SSIS 2012 包或更高版本后,您还可能遇到此问题。
解决方案
在 SQL Server 中的以下累积更新首先修复问题︰

建议︰ 设置 SQL Server 的累积更新
SQL Server 的每个新累积更新包含所有修补程序和所有安全修补程序,已包含在以前的累积更新。我们建议您下载并安装最新的累积更新 SQL Server:

状态
Microsoft 已经确认这是"适用于"一节中列出的 Microsoft 产品中的问题。

警告:本文已自动翻译

属性

文章 ID:3164404 - 上次审阅时间:09/21/2016 03:22:00 - 修订版本: 7.0

Microsoft SQL Server 2014 Business Intelligence, Microsoft SQL Server 2012 Analysis Services, Microsoft SQL Server 2012 Business Intelligence

  • kbqfe kbsurveynew kbexpertiseadvanced kbfix kbmt KB3164404 KbMtzh
反馈