你目前正处于脱机状态,正在等待 Internet 重新连接

更改启动驱动器的 SATA 模式后出现错误消息

症状
使用基于 Windows 7 或 Windows Vista 的计算机的 BIOS 设置更改启动驱动器的串行高级技术附件 (SATA) 模式后,以使用高级主机控制器接口 (AHCI) 规格或独立磁盘冗余阵列 (RAID) 功能后,在您重新启动计算机时收到以下错误消息:
STOP 0x0000007B INACCESSABLE_BOOT_DEVICE
原因
如果禁用 Windows 7 或 Windows Vista 中的磁盘驱动程序,则会发生此问题。更改启动驱动器的 SATA/RAID 模式之前,必须启用该驱动程序。
帮我修复此问题
若要自动解决此问题,请单击修复此问题链接。然后,在文件下载对话框中单击运行,并按照本向导中的步骤操作。



注意 此向导可能只提供英文版本。但是,Windows 的其他语言版本也提供自动修复功能。

注意 如果操作的计算机并未出现此问题,则可将自动修复保存至闪存驱动器或 CD 中,以便您可以在出现此问题的计算机中运行该功能。
我自己修复此问题
重要说明 本部分(或称方法或任务)介绍了修改注册表的步骤。但是,注册表修改不当可能会导致严重问题发生。因此,请务必严格按照这些步骤操作。为了获得进一步保护,请在修改注册表之前对其进行备份。这样就可以在出现问题时还原注册表。若要详细了解如何备份和还原注册表,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
322756 如何在 Windows 中备份和还原注册表
要自己解决该问题,请在更改启动驱动器的 SATA 模式之前在注册表中启用 AHCI 驱动程序。为此,请按照下列步骤操作:
  1. 退出所有基于 Windows 的程序。
  2. 单击“开始”,在“开始搜索”框中键入 regedit,然后按 Enter。
  3. 如果显示“用户帐户控制”对话框,请单击“继续”
  4. 找到并单击下面的注册表子项之一:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV
  5. 在右窗格中,右键单击“名称”列中的“启动”,然后单击“修改”
  6. 在“数值数据”框中,键入 0,然后单击“确定”
  7. 在“文件”菜单上,单击“退出”以关闭注册表编辑器。
更多信息
在 Windows 7 或 Windows Vista 安装过程中,会禁用所有未使用的存储驱动程序。此行为会加快操作系统的启动过程。将启动驱动器更改为已禁用的驱动程序时,必须在更改硬件配置之前先启用新驱动程序。

例如,假定您在包含某控制器的计算机上安装 Windows Vista 或 Windows 7,该控制器使用 Pciide.sys 驱动程序。以后,您将 SATA 模式更改为 AHCI。因此,驱动器现在必须加载 Msahci.sys 驱动程序。但是,必须先启用 Msahci.sys 驱动程序,才能进行此更改。

此问题只影响启动驱动器。如果您更改的驱动器不是启动驱动器,则不会遇到此问题。

AHCI 为 SATA 设备提供了若干种功能。其中包括热插拔功能和电源管理功能。有关 AHCI 规格的更多信息,请访问下面的 Intel 网站:Microsoft 提供了第三方联系信息以便于您寻求技术支持。这些联系信息如有更改,恕不另行通知。Microsoft 不保证这些第三方联系信息的准确性。本文中讨论的第三方产品由 Microsoft 以外的其他公司制造。对于这些产品的性能或可靠性,Microsoft 不作任何暗示保证或其他形式的保证。
其他资源
windowsvista winvista fixit fix it
属性

文章 ID:922976 - 上次审阅时间:01/08/2014 18:49:00 - 修订版本: 16.0

Windows Vista Business, Windows Vista Enterprise, Windows Vista Home Basic, Windows Vista Home Premium, Windows Vista Starter, Windows Vista Ultimate, Windows 7 Enterprise, Windows 7 Enterprise N, Windows 7 Home Basic, Windows 7 Home Premium, Windows 7 Professional, Windows 7 Professional N, Windows 7 Starter, Windows 7 Starter N, Windows 7 Ultimate, Windows 7 Ultimate N

  • kbtshoot kbhardware kberrmsg kbexpertiseinter kbprb kbfixme kbmsifixme KB922976
反馈
ml>