以与 Excel 早期版本兼容的方式保存 Excel 工作簿

以与 Excel 早期版本兼容的方式保存 Excel 工作簿

你已升级到新版本的 Excel,并发现要与尚未升级的人员共享工作簿。 运行兼容性检查器可帮助识别可能在早期版本中不可用的功能或信息,以便你可以先解决其中一些问题,然后再共享工作簿。

将文件保存为.xls 格式并检查兼容性检查器问题

请按以下步骤操作:

  1. 单击 "文件>导出" > "更改文件类型"。

    “导出”选项卡上的“更改文件类型”

  2. “导出”选项卡上的“更改文件类型”

  3. 在“工作簿文件类型”下,双击“Excel 97 - 2003 工作簿(*.xls)”。

    Excel 97-2003 工作簿格式

  4. 在 "另存为" 弹出窗口中,选择工作簿的文件夹位置。

  5. 在 "文件名" 框中,键入新文件名(或使用已存在的文件名)。

  6. 单击“保存”。

  7. 如果出现兼容性检查器,请检查发现的所有兼容性问题。

    兼容性检查器显示轻微保真损失问题

    "查找" 链接将使你转到工作表中的位置,并且帮助链接将你转到有关问题和可能的解决方案的信息。
     

注意: 

  • 在新版本的 Excel 中,你刚才以 .xls 格式保存的工作簿以“兼容性模式”打开。 如果计划与使用早期版本的 Excel 打开此工作簿的人员往来发送此工作簿,请保持在此模式下工作。

  • 当不再需要向后兼容性时,请单击 "文件>信息" > "转换" 以将工作簿转换为当前文件格式,以便可以利用Excel 中的新增功能

针对 Excel 2007 和更高版本运行兼容性检查器

要验证工作簿是否与 Excel 2013、2010 或 2007 兼容,请在第一次保存工作簿时手动运行兼容性检查器。 然后将兼容性检查器设置为每次保存该工作簿时自动运行。

请按以下步骤操作:

  1. 单击“文件”>“信息”>“检查问题”。

    检查兼容性

  2. 选择 "检查兼容性"。

  3. 要从现在开始自动检查兼容性,请选中“保存此工作簿时检查兼容性”框。
     

    提示: 你还可以指定在检查兼容性时要包括的 Excel 版本。 默认情况下会选中所有版本,因此只需取消选中不希望包括的版本。

    兼容性检查器显示要检查的版本

    如果发现任何问题,"查找" 链接将转到工作表中的相应位置,"帮助" 链接将转到有关问题的信息和可能的解决方案。

使用 Access 合并数据源以用于使用多个表的数据功能

注意: 你还可以在 Excel 中使用VLOOKUP 函数来解决此问题,但该过程有点复杂,并且随着要合并的数据源数量的增加而变得更复杂。

Excel 2010 和早期版本不支持分析多个表的数据功能,因为这些 Excel 版本没有数据模型。 如果你的工作簿包含任何此类功能,你可以通过将功能的数据源合并到单个表中,然后将该新表用作数据源来准备在早期版本中使用。

执行此操作的一种方法是使用 Access 合并数据源并将其作为查询进行复制,然后将其导入到工作簿中。 该过程如下所示:

  1. 在 Access 中,将每个原始数据源导入为新表。

  2. 在 Excel 中,通过单击 "数据" > 数据工具 > 关系",并注意原始数据源之间的关系来打开" 关系 "对话框。

  3. 在 Access 中,重新创建每个关系

  4. 在 Access 中,创建包含 Excel 数据功能所需的所有字段的查询

  5. 在 Excel 中,将查询作为表格导入到新工作表中。

如果数据位于 Excel 中的一个表中,请选择该表作为使用多个表的数据功能的数据源,或重新创建数据功能并选择新表作为其数据源。

需要更多帮助吗?

可随时在 Excel 技术社区中咨询专家,在解答社区获得支持,或在 Excel User Voice 上建议新功能或功能改进。

另请参阅

Excel 文件格式转换时不转换的格式和功能

工作表兼容性问题

需要更多帮助?

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×