创建 UML 类图

你可以创建一个 UML 类图来显示系统类的静态视图、它们的属性和方法以及对象之间的关系。 它将概括介绍应用程序。

( Visio 专业版包括对 UML 类图和模具的支持,但标准版本不支持。)

显示银行的个人客户的 systemof 帐户的 UML 类图的示例。

启动新的类关系图时,将显示 " Uml 类" 模具以及符合 UML 2.5 标准的形状。

  1. 开始 Visio 。 或者,如果已打开文件,请单击 "文件" > "新建"。

  2. 在 "搜索" 框中,键入 " UML 类"。

  3. 选择 " UML 类图"。

  4. 在对话框中,选择空白模板或三个初学者图中的一个。 (当你选中它时,将在右侧显示每个项的说明。) 然后选择 "公制单位" 或 "美制单位"。

  5. 选择“创建”。

  6. 图表随即打开。 你应该会看到图表旁边的 "形状" 窗口。 如果看不到它,请转到 "查看>任务窗格",并确保已选中 "形状"。 如果仍然看不到它,请单击左侧的 "展开形状窗口"按钮。

  7. 在 "视图" 选项卡上,确保选中 "连接点" 旁边的复选框。 当您开始连接形状时,此选项会显示连接点。

  8. 现在,将您要包括在图表中的形状从 "形状" 窗口拖动到页面上。 若要重命名文本标签,请双击标签。

  9. 若要向 "类"、"枚举" 或 "接口" 形状添加更多成员,请将 "成员" 形状从 "形状" 面板拖动到相应的形状。 您也可以通过右键单击现有成员并选择用于插入成员的选项来添加新成员。

    通过右键单击现有成员并选择用于插入成员的选项来添加新成员。

  10.  将两个形状与 UML 连接线连接,以表示形状之间的关系。 若要更改关系类型,请右键单击连接线。 从 "设置连接线类型" 菜单中选择所需的关系。

    右键单击连接线,然后选择 "设置连接线类型" 以查看连接线类型的选项。

  11.  通过单击形状标题来调整 "类"、"枚举" 或 "接口" 形状的大小,将其选中,然后向左或向右移动黄色控制点(在形状的右边缘)以减少或增加形状的宽度。

  12.  通过选择形状,右键单击并从弹出菜单中选择相应的选项,将参数和构造型字段添加到你的类形状。

    右键单击形状,将参数和构造型字段添加到类形状。

首先,创建一个图表并添加具有符合 UML 2.5 标准的形状的 UML 类模具。

  1. 打开Visio 网页版。

  2. 在库中,向下滚动到 " UML 类" 行,在页面中间。

    行中的第一项表示一个空白模板以及配套模具。 行中的其他项是包含已绘制的一些形状的示例图表,可帮助您快速入门。

  3. 单击任何项目以查看更大的预览。

  4. 找到要使用的图表时,请单击其 "创建" 按钮。

    新图表(包含相关模具)将在浏览器中打开。 你已准备好开始绘制你的图表。

  5. 现在,将您要包括在图表中的形状从 "形状" 窗口拖动到页面上。 若要重命名文本标签,请双击标签。

  6. 若要向 "类"、"枚举" 或 "接口" 形状添加更多成员,请将 "成员" 形状从 "形状" 面板拖动到相应的形状。 您也可以通过右键单击现有成员并选择用于插入成员的选项来添加新成员。

    通过右键单击现有成员并选择用于插入成员的选项来添加新成员。

  7.  将两个形状与 UML 连接线连接,以表示形状之间的关系。 若要更改关系类型,请右键单击连接线。 从 "设置连接线类型" 菜单中选择所需的关系。

    右键单击连接线,然后选择 "设置连接线类型" 以查看连接线类型的选项。

  8.  通过单击形状标题来调整 "类"、"枚举" 或 "接口" 形状的大小,将其选中,然后向左或向右移动黄色控制点(在形状的右边缘)以减少或增加形状的宽度。

  9.  通过选择形状,右键单击并从弹出菜单中选择相应的选项,将参数和构造型字段添加到你的类形状。

    右键单击形状,将参数和构造型字段添加到类形状。

首先,选择 " UML 类图",它附带一个包含符合 UML 2.0 规范的形状的类模具。

  1. 开始 Visio 。 或者,如果已打开文件,请单击 "文件" > "新建"。

  2. 在 "搜索" 框中,键入 " UML 类"。

  3. 选择 " UML 类图"。

  4. 在对话框中,选择 "公制单位" 或 "美制单位"。

  5. 选择“创建”。

  6. 图表随即打开。 你应在图表旁边的 "形状" 窗口中看到 " UML 类" 模具。 如果看不到它,请转到 "查看>任务窗格",并确保已选中 "形状"。 如果您仍然看不到它,请选择窗口左侧空白处的 v 形展开 "形状窗口" 按钮。

  7. 在 "视图" 选项卡上,确保选中 "连接点" 旁边的复选框。 当您开始连接形状时,此选项会显示连接点。

  8. 现在,将您要包括在图表中的形状从 "形状" 窗口拖动到页面上。 若要重命名文本标签,请双击标签。

在 Visio 2010 中,创建 UML 类图的方式是使用静态结构图。 有关详细信息,请参阅创建 UML 静态结构图表

创建课程图的提示

  • 标识每个元素及其关系。

  • 清楚地确定每个类的责任。

  • 不要在图表中包含不必要的属性,这可能会导致过于复杂。

类表示法

符号

含义

-

属性或操作是私有的。

+

属性或操作是公共的。

另请参阅

Visio 中的 UML 图表

需要更多帮助?

扩展你的 Office 技能
了解培训
抢先获得新功能
加入 Office 预览体验计划

此信息是否有帮助?

谢谢您的反馈!

谢谢你的反馈! 可能需要转接到 Office 支持专员。

×