在 Visio 可以通过更改形状的文本颜色、字体、填充颜色和图案、线条粗细和样式或阴影来自定义形状的外观。

使用形状样式快速应用格式

向形状添加颜色的最快方法是使用预设形状样式的菜单。

  1. 选择要更改的形状。

  2. 在工具栏上,转到 “开始>形状样式

    Microsoft 365 Visio“开始”选项卡上的形状格式设置选项。

  3. 打开样式库并选择一个选项,所有这些选项都与绘图的颜色主题匹配。 选项包括不同的颜色、渐变和线条样式。

手动应用格式

可以使用“格式形状”窗格更精确地应用格式设置,如下所述:

  1. 选择要更改的形状或形状。

  2. 右键单击形状,然后选择“设置形状格式”。

    随即将打开“设置形状格式”窗格。 

  3. “格式形状”窗格中的“填充&行”选项卡。 (“填充&行) ”选项卡上,选择填充类型,然后选择颜色。 

  4. 如果希望形状上有边框,请在 “线条”下选择线条类型和颜色。 然后选择所需的任何其他选项,如 透明度宽度短划线类型上限类型。 

  5. 若要应用效果 (如 阴影反射发光3D 外观,请选择窗格顶部的 “格式形状”窗格中的“效果”选项卡。 (效果) 选项卡,并浏览可用选项。 

选择要应用的自定义颜色

可以通过指定红绿蓝颜色组合或十六进制颜色代码或从颜色画布中选择来应用自定义颜色。

  1. 选择一个或多个形状。

  2. 选择 “开始 > 填充 “形状填充”按钮。”。

  3. > 自定义选择更多颜色

  4. 可以为自定义颜色指定红-绿-蓝颜色组合或十六进制值,也可以直接从颜色映射中选择颜色。 

    可以在“颜色”对话框的“自定义”选项卡上选择自定义颜色。

  5. 若要选择自定义轮廓颜色,请选择 “开始 > “形状轮廓”按钮。”,然后选择 “更多颜色”。

更改形状的线条粗细

  1. 选择形状。

  2. “开始 ”选项卡上的“ 形状样式” 部分中,选择“ 粗细 ”行 >,然后选择所需的粗细。

    (“行 ”菜单还可以更改行样式。 使用 “短划线 ”或“箭头 ”选项选择所需的行类型。)

    提示: 若要更精确地调整线条粗细的大小,可以右键单击形状并选择 “形状格式”,然后选择 “线条 ”并选择所需的确切 宽度 (以 .25 pt 为增量)。 

另请参阅

将透明度应用于形状

选择、移动、调整大小和旋转形状

独立应用颜色、线条样式、渐变和效果

  1. 选择一个或多个形状。 

  2. 选择工具栏功能区上的 “形状” 选项卡。 

  3. 选择 形状 > 形状填充 “形状填充”按钮。,然后从显示的库中选择一个选项。 

    “形状填充”按钮。形状填充 ”菜单还具有一个 透明 选项,以便可以调整形状的不透明度,以显示文本或其后面的其他形状。

  4. 如果希望形状上有边框,请选择“形状轮廓“形状轮廓”按钮。,然后从显示的库中选择一个选项。

    也可以更改线条、粗细、短划线或箭头(如果已选择连接线)。

选择要应用的自定义颜色

  1. 选择一个或多个形状。

  2. 若要使用主题或标准颜色填充形状,请选择 形状 > 形状填充 “形状填充”按钮。>更多填充颜色 来定义自定义颜色。

    在“自定义颜色”对话框中,可以使用十六进制值或红绿蓝值指定任何颜色。

  3. 若要将自定义颜色应用于形状的边框,请选择 形状 > 形状轮廓 “形状轮廓”按钮。> 更多轮廓颜色

更改形状的线条粗细

  1. 选择形状。

  2. “形状” 选项卡上,选择 “形状轮廓”按钮。“形状轮廓”> “重量”,然后选择所需的粗细。

    (“ 形状轮廓 ”菜单还可以更改线条样式。 使用 “短划线 ”或“箭头 ”选项选择所需的行类型。)

    提示: 若要更精确地调整线条粗细的大小,可以右键单击形状并选择 “格式选项”。 然后,在“格式选项”窗格中,选择 “线条 ”并选择所需的确切权重(以 .25 pt 为增量)。 在“格式选项”窗格中,还可以选择形状的大纲和填充颜色,包括自定义颜色。 

另请参阅

在 web 的Visio中更改形状的大小、旋转和顺序

将透明度应用于形状

注意: 

你的浏览器不支持视频。 请安装 Microsoft Silverlight、Adobe Flash Player 或 Internet Explorer 9。

在形状中设置文本格式

可以更改形状中文本的字体、字符间距、段落间距和对齐方式、文本块的位置、项目符号或数字以及文本的制表位。 按照以下说明操作:

快速任务

任务

操作

向形状中添加文本

选择页面上的形状并键入文本。

选择形状中的文本

双击包含要设置格式的文本的形状。

设置文本块的格式

  1. 选择包含要设置格式的文本的形状。

  2. “开始 ”选项卡上的 “字体 ”和 “段落 ”组中,选择所需的格式设置选项。

将文本格式从一个形状复制到另一个形状

  1. 选择要复制的文本。

  2. “开始 ”选项卡上的 剪贴板 组中,单击 “格式刷 Visio 2010 中的格式刷。”。

  3. 单击包含要更改的文本的形状。

更改文本块背景色

  1. 选择包含要更改的文本框的形状。

  2. 右键单击形状,指向 “格式”,然后选择 “文本”。

  3. “文本 ”对话框的 “文本块 ”选项卡上的 “文本背景”下,选择 纯色

  4. 色旁边的列表中,选择所需的颜色。

  5. 单击“ 应用 ”,然后单击 “确定”。

设置符号和标点符号的格式

  1. 单击“文件”选项卡。

  2. Visio 下,单击“选项”。

  3. “Visio选项”对话框的“校对”选项卡上,单击“自动更正选项”。

  4. 选择或清除要打开或关闭的任何自动格式设置选项。

  5. 单击“确定”。

更改形状的线条

可以更改形状边框的线条颜色、线条粗细、短划线类型和透明度。

快速任务

任务

操作

更改线条颜色或格式

  1. 选择具有要设置格式的边框的形状。

  2. “开始 ”选项卡上的 “形状” 组中,单击 “行 ”并选择所需的格式设置选项。

从形状中删除线条

  1. 选择具有要删除的边框的形状。

  2. “开始 ”选项卡上的 “形状” 组中,单击 “行 ”并选择 “无行”。

将新填充应用于形状

在 Visio 2010 中,可以更改填充颜色、填充图案,甚至将自己的填充模式添加到形状。

快速任务

任务

操作

更改填充颜色

  1. 选择包含要更改的填充的形状。

  2. “开始 ”选项卡上的 “形状” 组中,单击 “填充 ”,然后选择所需的颜色。

将填充格式从一个形状复制到另一个形状

  1. 选择具有要复制的填充的形状。

  2. “开始 ”选项卡上的 剪贴板 组中,单击 “格式刷 Visio 2010 中的格式刷。”。

  3. 单击具有要更改的填充的形状。

应用模式填充

  1. 选择包含要更改的填充的形状。

  2. “开始 ”选项卡上的 “形状” 组中,单击 “填充 ”并选择 “填充选项”。

  3. “填充” 对话框的 “模式 ”列表中,选择所需的模式。

  4. “模式”颜色 列表中,选择所需的颜色。

  5. 单击“ 应用 ”,然后单击 “确定”。

创建新的填充模式

  1. “开发人员” 选项卡上的 “显示/隐藏” 组中,选择 “绘图资源管理器”。

  2. “绘图资源管理器 ”窗口中,右键单击 “填充模式”。

  3. “新建模式 ”对话框的 “详细信息”下,键入模式的名称。

  4. “行为”下,选择一个选项。

    行为选项

    • “新建图案”对话框中的按钮。 创建图像的多个副本以填充形状 (磁贴图像)

    • “新建图案”对话框中的按钮。 沿线对多个图像进行磁贴,而不会对其进行扭曲。

    • “新建图案”对话框中的按钮。 拉伸单个图像以填充形状。

  5. 若要在绘图页缩放更改时调整模式,请选中 “缩放” 复选框。

  6. 单击“确定”。

  7. 绘图资源管理器窗口中,打开 “行模式 ”文件夹,右键单击新模式,然后单击 “编辑模式形状”。

  8. 创建要指定为模式的形状或形状。 可以从头开始创建形状、更改现有形状或插入位图。

  9. 单击“ 关闭窗口 ”按钮,然后单击 “是 ”以更新模式。

注意: 需要让功能区中的 “开发人员 ”选项卡可见才能执行此操作。

显示“ 开发人员 ”选项卡

  1. 单击“文件”选项卡。

  2. Visio 下,单击“选项”。

  3. “Visio选项”对话框的“自定义功能区”选项卡上的“自定义功能区”列表中,选择“主选项卡”。

  4. “主选项卡”下,选择 “开发人员”。

  5. 单击“确定”。

从形状中删除填充

  1. 选择包含要更改的填充的形状。

  2. “开始 ”选项卡上的 “形状” 组中,单击 “填充 ”并选择 “无填充”。

将主题应用到形状

在 Visio 2010 中应用主题时,可指定绘图页上每个形状的格式 (字体、文本颜色、填充颜色、边框和阴影) 。

内置主题将颜色格式 (字体颜色、填充颜色) 和形状效果 (边框样式、阴影) 应用于形状。 可以选择仅更改边框、阴影、字体和连接器样式 (效果) 或仅更改 (文字、线条、连接器、填充和阴影颜色) 绘图中形状的颜色。

若要了解有关主题的详细信息,请参阅 使用主题对绘图应用专业外观

快速任务

任务

操作

将主题应用于绘图中的形状

“设计” 选项卡上的 “主题 ”组中,单击所需的主题,或单击 “其他”按钮 获取更多选项。

更改主题颜色

“设计” 选项卡上的 “主题 ”组中,单击“ 颜色”,然后选择所需的颜色。

更改主题效果

“设计” 选项卡上的 “主题 ”组中,单击 “效果”,然后选择所需的效果。

创建自己的主题

  1. “设计 ”选项卡上 ,在“主题” 组中,单击“ 颜色 ”,然后选择 “新建主题颜色”。

  2. “新建主题颜色 ”对话框的“ 常规”下的 “名称” 框中,键入要用于新主题的新名称。

  3. 选择所需的颜色。

  4. 单击“ 应用 ”,然后单击 “确定”。

  5. 主题 组中,单击 “效果 ”,然后选择 “新建主题效果”。

  6. “新建主题效果 ”对话框的“ 常规”下的 “名称” 框中,键入要用于新主题的新名称。

  7. 选择所需的字体、线条、填充、阴影和连接器设置。

  8. 单击“ 应用 ”,然后单击 “确定”。

从形状中删除主题

右键单击形状,指向 “格式”,然后选择 “删除主题”。

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Office Insiders

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?

Thank you for your feedback!

×