注意:  我们希望能够尽快以你的语言为你提供最新的帮助内容。 本页面是自动翻译的,可能包含语法错误或不准确之处。我们的目的是使此内容能对你有所帮助。可以在本页面底部告诉我们此信息是否对你有帮助吗? 请在此处查看本文的 英文版本 以便参考。

多选列表框是如下所示,而不是典型的列表框的复选框可滚动列表选项的列表。用户可以根据需要从列表中选择任意数量的复选框。根据您设计的多选列表框的方式,用户或许也能够键入自己的列表项旁的复选框。

本文内容

什么时候使用多选列表框

如果要,使用多选列表框:

  • 使用户能够在列表中选择多个项目。

  • 使用户能够在列表中输入他们自己的值。

  • 默认情况下,在窗体上的列表中显示大多数或所有项目。

  • 显示从固定列表、 表单模板的数据源,或从外部数据源,如数据库或 Microsoft Windows SharePoint Services 列表检索的值。

在下图中,用户可以为多个类别分配零用金报销单中的,通过在多选列表框中选中复选框。窗体设计器已选择允许自定义类别。因此,用户可以在列表中最后一个复选框旁边的空白框中输入的值。

添加到多选列表框中的选项列表的自定义值

表单模板上插入多选列表框后,您必须指定您想要在其中显示的值。否则,用户将看到一个空框中,当他们打开基于表单模板的表单。在多选列表框属性对话框中,可以自己键入项目或配置多选列表框以从数据库或其他数据源检索项目。

相关控件

Microsoft Office InfoPath 包括类似于多选列表框但的用途不同的控件。要确定哪个控件最适用于您的表单模板,请参阅下面的列表:

列表框   多选列表框中,如标准列表框使用户可以在列表中选择值。但是,使用列表框,用户可以只有一个列表中选择项。多选列表框中,如列表框中显示的所有项目列表中默认情况下。

下拉列表框   任何其他列表中,如下拉列表框将为用户提供选项列表。但是,使用下拉列表框中,列表项是在用户单击控件之前隐藏。用户可以从下拉列表中选择只有一个项目。

组合框   如果您希望用户能够键入自己的列表项或从预定义的列表中选择值,而不是多选列表框中使用组合框。用户可以从组合框中选择一个项目。

选项按钮   多选列表框中,如一组选项按钮使用户能够从选项列表中选择。与多选列表框中,用户可以从一组选项按钮选择一个选项。此外,使用选项按钮,用户单击的小圆圈进行选择,而不是单击列表框中的项目。

返回页首

用户体验

使用多选列表框中,用户通过选中或清除复选框,在窗体上的框中进行选择。如果复选框的数目超过控件的高度,显示滚动条右侧的框中,以便用户可以看到剩余的选项。

如有必要,可以以便用户可以在列表中,键入自己的条目设计表单模板。在此例中,使用编辑框中的复选框显示为列表中的最后一个项目。

多选列表框中的空白框

若要输入自定义的值,用户选择编辑框旁边的复选框,然后复选框旁边的区域中键入其条目。此为可能必须向表单模板上插入多选列表框时在多选列表框属性对话框中选择允许用户输入自定义值复选框。

返回页首

兼容性的注意事项

在设计表单模板在 InfoPath 中的时,您可以选择设计浏览器兼容的表单模板。在设计浏览器兼容的表单模板时,多选列表框控件在控件任务窗格中不可用,因为它们不能在 Web 浏览器中显示。

返回页首

插入多选列表框

插入多选列表框的过程稍有不同,具体取决于您是设计新的空白表单模板还是基于数据库或其他外部数据源设计表单模板。

下图显示多选列表框时表单模板设计者手动添加列表框项之前在设计模式中选中的外观。

在设计模式中选择的空白多选列表框

控件可以绑定,也可以不绑定。当控件被绑定时,它会连接到数据源中的域或组,以便控件中输入的数据保存在基础表单 (.xml) 文件中。控件未被绑定时,它不会连接到一个域或组,并且控件中输入的数据不会保存。当选择控件或将鼠标指针移动到控件上时,文本和绑定图标显示在控件右上角。文本指明控件绑定到的数据源中的组或域。图标指明控件是否正确绑定到该组或域。如果绑定正确,则显示绿色图标。如果绑定出现问题,则会看到蓝色或红色图标。

表单模板的数据源组成域和显示在数据源任务窗格中的分层视图中的组。多选列表框始终绑定到组中的重复域。重复域允许您在字段中存储多个值。在下面的示例表单模板上的类别多选列表框绑定到重复数据源任务窗格中的域类别

表单模板上的多选列表框与数据源中对应域间的关系

设计新的空白表单模板时,“控件”任务窗格中的“自动创建数据源”复选框默认情况下处于选中状态。将控件添加到该表单模板时,该表单模板允许 InfoPath 自动创建数据源中的域和组。这些域和组由“数据源”任务窗格中的文件夹和文件图标表示。

如果您在现有可扩展标记语言 (XML) 文件、数据库或 Web 服务的基础上设计表单模板,InfoPath 将从这些现有数据源中派生出“数据源”任务窗格中的域和组。

插入多选列表框

  1. 在表单模板中,将光标置于要插入控件的位置。

  2. 如果看不到“控件”任务窗格,请单击“插入”菜单上的“其他控件”,或按 Alt+I、C。

  3. 在“控件”任务窗格中,执行下列操作之一:

    • 若要自动创建绑定到多选列表框的数据源中的重复域,请选择自动创建数据源复选框。

    • 若要将多选列表框绑定到某个现有的重复域,请清除自动创建数据源复选框。

      注意: 如果该复选框不可用,则表示数据源已锁定。例如,如果根据 XML 架构来设计表单模板,则可能无法在 InfoPath 中向数据源添加新的域或组。这一限制有助于防止您无意中对该架构进行更改,而所做的更改可能使该架构无效。

  4. 插入控件下单击多选列表框

  5. 如果清除步骤 3 中的自动创建数据源复选框,请在您要将多选列表框绑定多选列表框绑定对话框中选择的重复域。

  6. 在表单模板中,键入标签文本上方或左侧的多选列表框中后, 跟一个冒号 (:)。

  7. 若要指定要用作列表项的值,请双击多选列表框。

  8. 单击“数据”选项卡。

  9. 执行下列操作之一来填充列表框:

    自己键入列表框值

    当您具有预先确定的、有限的一组值并且不希望将来更改这些值时,此选项很有用。如果这些值碰巧发生更改,则必须发布更新版本的表单模板,这样用户才能看到并使用最新的列表项。

    1. 单击“添加”。

    2. 在“”框中,键入您希望在用户选择此项时保存的文本。

    3. 在“显示名称”框中,键入要为此项显示的文本,然后单击“确定”。

    4. 对要添加到列表框中的每一项重复步骤 1 到步骤 3。

    5. 要测试所做的更改,请单击“常用”工具栏上的“预览”,或者按 Ctrl+Shift+B。

    使用来自表单中其他部分的值

    如果您希望列表中的值根据用户在其表单中输入的其他值而更改,此选项将很有用。

    1. 在“列表框项”下,单击“在表单数据源中查找值”。

      列表框中的项必须与表单模板上的特定重复组或重复域相关联。

    2. 单击“”框旁边的“选择 XPath数据源图像,然后在“选择域或组”对话框中单击包含将为列表框提供值的域的重复域或重复组,然后单击“确定”。

    3. 单击“”框旁边的“选择 XPath数据源图像,单击包含列表框中各项的可能值的域,然后单击“确定”。当用户单击列表框中的某一项时,将在基础 XML 中保存其中的一个值。

    4. 单击“显示名称”框旁边的“选择 XPath数据源图像,单击包含列表框中所显示的值的域,然后单击“确定”。

      提示: 为防止显示名称值在列表框中出现多次,请选中“仅显示具有唯一显示名称的条目”复选框。

    使用来自数据库、Web 服务、XML 文档或 SharePoint 网站的值

    如果您希望列表框中的值保持最新或定期刷新,此选项很有用。这些值通常存储在数据库或其他外部数据源中,每次打开表单时都会进行检索。

    1. 单击“从外部数据源查找值”。

    2. 执行下列操作之一:

      • 如果已经添加了数据连接,请在“数据连接”框中单击该连接。

      • 要添加新数据连接,请单击“添加”,然后按照数据连接向导中的说明操作。

        列表框中的项必须与特定重复域或重复组相关联。

    3. 单击“”框旁边的“选择 XPath数据源图像,然后在“选择域或组”对话框中单击包含将为列表框提供值的域的组或域,然后单击“确定”。

    4. 单击“”框旁边的“选择 XPath数据源图像,单击包含列表框中各项的可能值的域,然后单击“确定”。当用户单击列表框中的某一项时,将在基础 XML 中保存其中的一个值。

    5. 单击“显示名称”框旁边的“选择 XPath数据源图像,单击包含列表框中所显示的值的域,然后单击“确定”。

      提示: 为防止显示名称值在列表框中出现多次,请选中“仅显示具有唯一显示名称的条目”复选框。

  10. 如果您希望用户能够在多选列表框的底部键入他们自己的值,请选择允许用户输入自定义值复选框。

返回页首

版式提示

使用下列提示可帮助您调整外观、 大小和多选列表框中的其他方面:

  • 若要同时更改若干个多选列表框的宽度,请选择您想要更改,请按 ALT + ENTER,单击大小选项卡,然后在宽度框中,键入新号码其大小的多选列表框。

  • 若要更改多个多选列表框,选择您想要更改的多选列表框的背景色,单击格式菜单上的边框和底纹,然后在底纹选项卡上进行必要的调整。

  • 若要自定义显示多选列表框中的复选框旁边的字体,请使用格式工具栏上的字体字号框。若要同时更改字体和字号所有表单模板上的多选列表框,请单击包含全部,需格式,然后单击格式菜单上的应用字体的多选列表框多选列表框控件

  • 要调整多选列表框和其周围表单模板的对象之间的间距,请尝试使用多选列表框属性对话框中的大小选项卡上的边距设置。使用边距增加间距提供比使用分段符增加间距更精细的控制。

返回页首

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Office Insiders

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?

Thank you for your feedback!

×