使用此对话框可关闭或开启 Excel 中的任何自动更正或自动套用格式功能。

“自动更正”对话框中有四个选项卡。 要快速跳转到所需的信息,请单击下面的名称,该名称对应于你希望获取有关其帮助的选项卡:

自动更正键入时自动套用格式 | 操作 | 数学自动更正

自动更正

通过使用自动更正功能,你可以更正键入、大写错误和拼写错误的单词,还可以自动插入符号及其他文本片断。 默认情况下,自动更正使用一个典型错误拼写和符号的标准列表进行设置,但是你可以修改列表中的条目。

默认情况下,Excel 被设置为自动更正某些常见的键入错误。 使用在此对话框中的选项可关闭或更改任何不喜欢的内容。

如果不喜欢在键入时出现的“自动更正选项”按钮 备用文本,可使用此对话框将其关闭:清除“显示自动更正选项按钮”旁的复选框。

可以在对话框的此选项卡上执行以下操作。 单击下面的标题以展开它,并查看说明:

你可以在“自动更正”选项卡启用或禁用各种自动更正大写的选项。

  • 选中或清除以下任一复选框:

    • 更正前两个字母连续大写

    • 句首字母大写

    • 英文日期第一个字母大写

    • 更正因误按大写锁定键(Caps Lock)产生的大小写错误

你可以指定几条大写规则的例外情况。 设置的例外情况会应用到所有支持自动更正功能的 Office 程序中,这就意味着更改一个程序的此列表也会影响其他程序。

  • 在“自动更正”选项卡上,单击“例外”,然后按以下步骤之一操作:

    • 如果选择“更正前两个字母连续大写”复选框,且想要防止“自动更正”更改混合有大写和小写字母的特定的单词(如 IDs),请单击“首字母大写”选项卡。

      要将单词添加到例外列表,在框中键入单词,然后单击“添加”。 若要删除某个单词,请选择该单词,然后单击“删除”。

    • 如果选择“句首字母大写”复选框,且想要防止“自动更正”将位于某些缩写(如 appt.)形式之后的单词大写,请单击“首字母”选项卡。

      要将单词添加到例外列表,在框中键入单词,然后单击“添加”。 若要删除某个单词,请选择该单词,然后单击“删除”。

    注意: 在某些 Office 程序中,也可以选中或清除“自动将词添加到列表”复选框。 此选项在编辑文件或项目时生效。 如果自动更正进行了不需要的更正,可通过按 Ctrl+Z 撤消更正。 如果“自动将词添加到列表”复选框处于选中状态,则会将撤消的不需要更正添加到例外项列表中。

自动更正使用两个并列的单词列表。 第一个单词是用户键入的单词,第二个是程序自动输入的单词或短语,用于替换第一个单词。

自动更正列表

自动更正列表应用于支持此功能的所有 Office 程序,这意味着在一个 Office 程序中添加或删除列表中的单词时,其他 Office 程序也会受到影响。

可添加指向具有相同文本的多个条目。 例如:“youve”、“you'vr”、“you'ww”全都可替换为“you've”。 只需为每个更改添加单独的条目。

重要: 如果自动更正完全不起作用,在“自动更正”选项卡上,请确保已选中“键入时自动替换”复选框。

在自动更正列表中添加、更改或删除项

若要添加条目,请按照下列步骤操作:

  1. 在“自动更正”选项卡的“替换”框中,键入经常出现键入错误或拼写错误的单词或短语 — 例如,键入 usualy

  2. 在“替换为”框中,键入拼写正确的单词 — 例如,键入 usually

  3. 单击“添加”。

若要更改条目的替换文本,请在条目列表中选择此条目并在“替换为”框中键入新的条目。

若要删除某个条目,请在列表中选择它,然后单击“删除”。

注意: 例外”列表告知拼写检查器不要自动替换它认为拼写错误的项。 如果正在自动替换某个单词,并且已确认该单词不在“自动更正”列表中,请将该单词添加到“例外”列表中,以确保拼写检查器不会自动替换该单词。

要防止自动更正可能执行的所有自动更改和替换,请在此对话框中执行以下操作:

  • 清除选项卡顶部的所有复选框以关闭所有自动大写选项。

  • 清除“键入时自动替换”框以关闭所有自动文本替换功能。

提示: 如果 Office 已自动更正某些内容,而你不想进行该更改,只需单击“撤消​​”或在键盘上按 Ctrl+Z 即可撤消更改。

若要在不访问任何菜单的情况下快速插入符号,请向该符号分配一个击键或文本。 如果你经常要插入符号,并且不想每次都通过功能区上的“符号”命令来进行插入,则可以使用这个特别方便的方法。

需要插入一次符号、复制它,然后添加“自动更正”规则。 如有需要,在完成了下面的步骤 8 后,可以删除已插入来创建规则的符号,因此不必太担心插入此符号的位置。

  1. 在“插入”选项卡上,单击“符号”>“其他符号”。

  2. 向下滚动列表,然后双击想使用的符号将它插入到文件中。 关闭“符号”对话框。

    提示: 大多数常用的符号都是 Wingdings 字体集的一部分。 在“符号”对话框中将字体设置为“Wingdings”以加快搜索速度。

  3. 在工作簿中选择已插入的符号,然后单击功能区的“开始”选项卡中的“复制”(或者按 Ctrl+C)。

  4. 单击“文件”>“选项”>“校对”>“自动更正选项”。

  5. 单击“替换为”框,然后按 Ctrl+V 将复制的符号粘贴到此字段中。

  6. 在“替换”框中,键入要与符号相关联的字词或短语,例如,键入 check1

    在“自动更正”选项卡上的“替换”框中,键入要与复选标记符号相关联的字词或短语。
  7. 单击“添加”>“确定”。

  8. 每当想要使用刚才定义的复选标记符号时,只需键入在步骤 7 中用于添加此符号的字词即可。

提示: 如果插入的字符不是想要的那个,请尝试突出显示此插入的字符,并确保此字符的字体为 Wingdings。

键入时自动套用格式

默认情况下,Excel 会在键入时执行一些自动套用格式操作,例如,在检测到键入列表时应用项目符号或编号列表格式。 

如果希望关闭任何这些自动套用格式选项,请使用此对话框。 清除不希望为其自动套用格式的任何项的复选框。 

操作

Excel 中有一个右击操作可用。 在此对话框中选择“启用右击菜单中的其他操作”即可启用该操作。 

日期”操作允许右键单击完整的日期(包括年、月和日),然后将 Outlook 日历打开到该日期。 

忽略按钮“操作”选项卡上的“属性”和“更多操作”按钮。 这些按钮起不到任何用处。 

数学自动更正

若要从头开始创建公式,请按 Alt 和等号登录。 将出现一个公式占位符,可在其中键入数学字符。 

操作公式占位符时,可使用 Office 提供的大量快捷方式插入数学特定的字符。 默认情况下,这些数学自动更正快捷方式处于启用状态。

可以执行以下操作。 单击下面的标题以展开它,并查看说明:

 清除名为“键入时替换文本”的该复选框。  

  1. 选择要更改的项目。 

    信息将被添加到“替换”和“替换为”框中。

  2. 更改“替换”框中的快捷方式或“替换为”框中的符号。

  3. 单击“替换”按钮。

  1. 选择你想要从列表中删除的项目。

  2. 单击“删除”按钮。

开始操作之前,需要将所需的符号复制到剪贴板,以便将其粘贴到对话框中。 可通过以下方式执行此操作:关闭对话框,在一张幻灯片上手动插入符号(“插入”>“符号”),然后选择并复制该符号 (Ctrl + C)。

  1. 在“替换”框中,键入想要使用的快捷方式。

    (该快捷方式应区别于常规并且单词拼写正确,除非你始终希望该单词替换为在步骤 2 中定义的符号。)

  2. 在“替换为”框中,粘贴你想分配给步骤 1 中指定的数学自动更正快捷方式的符号。

  3. 单击“添加”。

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Office Insiders

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?

Thank you for your feedback!

×