症状
请考虑以下情形:
从安装了 Windows Internet Explorer 8 的计算机为 Microsoft Dynamics CRM 2013 中的联系人实体创建对话框。
注意 部分对话要求是查询 CRM 数据并将其显示为选择列表。
创建对话框时,可以添加“查询 CRM 数据”步骤。
查询的筛选器是动态 (FirstName -> 等于 -> {FirstName (Contact) }) 。
对话框中的下一步是包含“提示”和“响应”的页面,其中提示设置为 {FirstName (Contact) },响应设置为 Option Set,其中将从查询填充可用选项。
针对单个联系人记录运行对话框。
在这种情况下, “提示和响应 ”选项集中没有可用的选项。
原因
出现此问题的原因是 Internet Explorer 8 会导致在通过使用 dynamics slugs 插入到查询中的值的前面添加空格。
解决方法
若要解决此问题,可以使用 Windows Internet Explorer 9 创建和发布包含 CRM 查询步骤的对话框。