症状
在 Microsoft Dynamics CRM 4.0 中,从 Sales Force Automation 实体的活动列表中单击“添加现有活动”时,“约会记录”和“服务活动”记录不会显示在查找页中。 如果活动具有“计划”状态,则会出现此问题。
原因
出现此问题的原因是,用于检索Lookupdata.aspx页的活动的默认 FetchXml 语句不检索计划的活动。
解决方法
重要:本节、方法或任务包含如何修改注册表的步骤。 但如果注册表修改不当,可能造成严重问题。 因此,请务必仔细遵循以下步骤。 为增强保护,请在修改前备份注册表。 如果出现问题,可以还原注册表。 有关如何备份和还原注册表的更多信息,请单击下面的文章编号查看 Microsoft 知识库中相应的文章:
322756 如何在 Windows 中备份和还原注册表
此问题已在 Microsoft Dynamics CRM 4.0 的最新累积更新汇总中修复。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
949256 Microsoft Dynamics CRM 4.0 更新和修补程序
注意 此问题最初已在更新汇总 13 for Microsoft Dynamics CRM 4.0 中修复。
有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2267499适用于 Microsoft Dynamics CRM 4.0 的更新汇总 13 可用
若要在运行 Microsoft Dynamics CRM 4.0 的计算机上启用此修补程序,请执行以下步骤:
- 在 Microsoft Dynamics CRM 服务器上的 **HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM\**registry 子项下,添加以下REG_DWORD注册表项:
LookupActivityPointerScheduled - 将刚刚添加的注册表项的值设置为 1。
状态
Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。
详细信息
有关软件更新术语的更多信息,请单击下面的文章编号以查看 Microsoft 知识库中的相应文章:
824684 用于描述Microsoft软件更新的标准术语的说明有关Microsoft Business Solutions CRM 软件修补程序和更新包术语的详细信息,请单击以下端口号以查看Microsoft知识库中的文章:
887283 Microsoft Business Solutions CRM 软件修补程序和更新包命名标准