在 SQL Server 2005 Service Pack 2 发布之后发布的 SQL Server 2005 内部版本

简介

本文列出了在 SQL Server 2005 Service Pack 2 (SP2) 发布之后发布Microsoft SQL Server 2005 内部版本Microsoft。

详细信息

内部版本 09.00.3356 (累积更新)

此累积更新包于 2009 年 12 月 21 日发布。

此内部版本的父内部版本为 09.00.3355。
有关此内部版本的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

976952 SQL Server 2005 Service Pack 2 的累积更新程序包 17

内部版本 09.00.3355 (累积更新)

此累积更新包于 2009 年 10 月 19 日发布。

此内部版本的父内部版本为 09.00.3330。
有关此内部版本的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

974647 SQL Server 2005 Service Pack 2 累积更新程序包 16

内部版本 09.00.3330 (累积更新)

此累积更新程序包于 2009 年 8 月 17 日发布。

此内部版本的父内部版本为 09.00.3328。
有关此内部版本的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

972510 SQL Server 2005 Service Pack 2 的累积更新程序包 15

内部版本 09.00.3328 (累积更新)

此累积更新程序包于 2009 年 6 月 15 日发布。

此内部版本的父内部版本为 09.00.3327。
有关此内部版本的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

970278 SQL Server 2005 Service Pack 2 累积更新程序包 14

内部版本 09.00.3327

此内部版本于 2009 年 5 月 26 日发布。

此内部版本的父内部版本为 09.00.3325。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

VSTS 错误号 知识库文章编号 说明
315550 948567 修复:针对包含繁体中文字符的表运行查询时,在 SQL Server 2005 中返回错误的结果
315552 956574 修复:在对包含 xml:lang 属性的 XML 类型数据运行使用 NEAR 运算符的搜索查询时,数据结果不一致

内部版本 09.00.3325 (累积更新)

此累积更新程序包于 2009 年 4 月 20 日发布。

此内部版本的父内部版本为 09.00.3322。
有关此内部版本的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

967908 SQL Server 2005 Service Pack 2 累积更新程序包 13

内部版本 09.00.3320

此内部版本于 2009 年 3 月 17 日发布。

此内部版本的父内部版本为 09.00.3315。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

VSTS 错误号 知识库文章编号 说明
288894 969142 修复:在 SQL Server 2005 中对数据库运行 DBCC CHECKDB 语句时出现错误消息:“无法解除分配保留的页”

内部版本 09.00.3315 (累积更新)

此累积更新包于 2009 年 2 月 16 日发布。

此内部版本的父内部版本为 09.00.3310。
有关此内部版本的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

962970 SQL Server 2005 Service Pack 2 的累积更新程序包 12

生成号 09.00.3310

此内部版本于 2009 年 2 月 10 日发布。

此内部版本的父内部版本为 09.00.3303。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

VSTS 错误号 知识库文章编号 说明
261045 960090 MS09-004:SQL Server 2005 QFE 安全更新说明:2009 年 2 月 10 日

生成号 09.00.3303

此内部版本于 2009 年 2 月 10 日发布。

此内部版本的父内部版本为 09.00.3302。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

VSTS 错误号 知识库文章编号 说明
271873 962209 修复:在已在 SQL Server 2005 中启用了 SNAPSHOT 或 READ COMMITTED SNAPSHOT 隔离级别的数据库上运行 UPDATE 语句时,出现错误消息:“LOB 数据类型节点的数据库 ID <数据库 ID>,第 (<N>:<N>) ,插槽 <N> 不存在”

内部版本 09.00.3302

此内部版本于 2009 年 1 月 13 日发布。

此内部版本的父内部版本为 09.00.3301。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

VSTS 错误号 知识库文章编号 说明
269560 961479 修复:尝试在 SQL Server 2005 中并行重建多个索引时,可能会发生死锁
270367 961648 修补程序:在 SQL Server 2005 中尝试查询或更新大型对象 (LOB) 数据列时收到错误消息

内部版本 09.00.3301 (累积更新)

此累积更新包于 2008 年 12 月 15 日发布。

此内部版本的父内部版本为 09.00.3295。
有关此内部版本的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

958735 SQL Server 2005 Service Pack 2 的累积更新程序包 11

内部版本 09.00.3295

此内部版本于 2008 年 11 月 3 日发布。

此内部版本的父内部版本为 09.00.3294。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50003708 959132 修补程序:在使用 FAT32 文件系统的驱动器上安装 SQL Server 2005 Service Pack 2 的累积更新 10 或累积更新 9 时,出现错误消息:“发生意外错误”

内部版本 09.00.3294 (累积更新)

此累积更新程序包于 2008 年 10 月 20 日发布。

此内部版本的父内部版本为 09.00.3291。
有关此内部版本的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

956854 SQL Server 2005 Service Pack 2 的累积更新程序包 10

内部版本 09.00.3291

此内部版本于 2008 年 9 月 26 日发布。

此内部版本的父内部版本为 09.00.3289。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50003135 956889 修复:在 SQL Server 2005 或 SQL Server 2008 中对存储过程的复制运行快照代理时出现错误消息:“名称属性不能有此版本的 SQL Server 的值@param_name”

内部版本 09.00.3289

此内部版本于 2008 年 9 月 18 日发布。

此内部版本的父内部版本为 09.00.3282。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50003257 修复:SQL Server 2005 同步镜像数据库时出现错误消息:“失败断言 = 'result == LCK_OK'”
50003258 修复: 在 SQL Server 2008 或 SQL Server 2005 中使用光标对没有聚集索引的表执行 DML 操作时,可能会得到错误的结果
50003481 修复:显示从 SQL Server 2008 或 SQL Server 2005 中的远程表中选择计算列的查询的执行计划时发生访问冲突 SQL Server

内部版本 09.00.3282 (累积更新)

此累积更新程序包于 2008 年 8 月 18 日发布。

此内部版本的父内部版本为 09.00.3263。

有关此内部版本的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

953752 SQL Server 2005 Service Pack 2 累积更新程序包 9

内部版本 09.00.3263

此内部版本于 2008 年 7 月 30 日发布。

此内部版本的父内部版本为 09.00.3262

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50003097 在 SQL Server 2005 中使用 bcp.exe 实用工具复制 NVARCHAR (MAX) 数据类型的列或 VARCHAR (MAX) 数据类型的列时,可能会发生访问冲突

内部版本 09.00.3262

此内部版本于 2008 年 7 月 26 日发布。

此内部版本的父内部版本为 09.00.3261。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50003080 955997 修复:无法在引用 SQL Server 2005 Analysis Services Service Pack 2 或 SQL Server 2008 Analysis Services 中的 OLAP 表的 Excel 2007 数据透视表中查看计算成员

内部版本 09.00.3261

此内部版本于 2008 年 7 月 31 日发布。

此内部版本的父内部版本为 09.00.3260。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002947 955754 在同一表的分区函数上同时运行 DML 语句和 DDL 语句时,在 SQL Server 2005 中发生死锁

内部版本 09.00.3260

此内部版本于 2008 年 7 月 3 日发布。

此内部版本的父内部版本为 09.00.3259。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50003019 954950 修复:在 SQL Server 2005 中运行分布式查询时出现错误消息:“链接服务器'链接服务器>'<SQLNCLI'的 OLE DB 提供程序'SQLNCLI'返回消息'无事务处于活动状态'”

内部版本 09.00.3259

此内部版本于 2008 年 7 月 1 日发布。

此内部版本的父内部版本为 09.00.3257。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50003012 953550 修复:在 SQL Server 2005 Analysis Services 中运行 MDX 查询时出现错误消息:“MDX 函数失败,因为'<AttributeName>'属性的坐标包含集合”
50002988 954669 修复:正在进行的 MS DTC 事务在 SQL Server 2005 中孤立
50003005 954831 修复:在 SQL Server 2005 中,运行 TRUNCATE TABLE 语句的会话可能会停止响应,并且无法结束会话
50003007 954751 修补程序:在 SQL Server 2005 Analysis Services 中并行处理多个对象时发生访问冲突

内部版本 09.00.3257 (累积更新)

此累积更新包于 2008 年 6 月 16 日发布。

此内部版本的父内部版本为 09.00.3253。

有关此内部版本中包含的 SQL Server 2005 post-Service Pack 2 修补程序的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

951217 SQL Server 2005 Service Pack 2 累积更新程序包 8

内部版本 09.00.3253

此内部版本于 2008 年 6 月 19 日发布。

此内部版本的父内部版本为 09.00.3248。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002912 954054 修复:在 SQL Server 2005 中同步事务复制的数据时,某些更改不会复制到订阅者

内部版本 09.00.3248

此内部版本于 2008 年 5 月 22 日发布。

此内部版本的父内部版本为 09.00.3246。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002775 修复:在表中使用 BULK INSERT 语句或在 SQL Server 2005 中使用 Transact-SQL 将数据插入表时,错误消息可能会记录在 SQL Server 错误日志中

内部版本 09.00.3246

此内部版本于 2008 年 5 月 13 日发布。

此内部版本的父内部版本为 09.00.3244。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002740 952233 修复:启动或停止针对该实例的 SQL Server Profiler 跟踪时,将取消在 SQL Server 2005 Analysis Services 实例上运行的所有 MDX 查询

内部版本 09.00.3244

此内部版本于 2008 年 5 月 6 日发布。

此内部版本的父内部版本为 09.00.3242。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002776 952330 修补程序:当事务复制同步 SQL Server 2005 中的数据时,复制日志读取器代理可能会间歇性失败

内部版本 09.00.3242

此内部版本于 2008 年 4 月 29 日发布。

此内部版本的父内部版本为 09.00.3240。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002750 951194 修复:对于 SQL Server 2005 Reporting Services 报表中图表中的图例和数据之间的所有组,填充模式不一致
50002748 951190 修复:在 SQL Server 2005 中的发布服务器上运行存储过程时,事务复制不会在订阅者处运行相应的存储过程
50002765 修补程序:在两个实例之间同步 SQL Server 2005 Analysis Services 数据库后运行 MDX 查询时出现错误消息:“由于数据库中的结构更改,当前会话不再有效”

内部版本 09.00.3240

此内部版本于 2008 年 4 月 23 日发布。

此内部版本的父内部版本为 09.00.3239。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002658 修补程序:在 SQL Server 2005 中使用光标通过视图更新表时会发生访问冲突

内部版本 09.00.3239 (累积更新)

此累积更新包于 2008 年 4 月 14 日发布。

此内部版本的父内部版本为 09.00.3235。

有关此内部版本中包含的 SQL Server 2005 post-Service Pack 2 修补程序的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

949095 SQL Server 2005 Service Pack 2 的累积更新程序包 7

内部版本 09.00.3235

此内部版本于 2008 年 3 月 19 日发布。

此内部版本的父内部版本为 09.00.3234。

此内部版本包含以下 SQL Native Client 修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002580 950189 修复:当您在 SQL Server 2005 中使用该函数检索二进制列的数据时,该函数可能会返回要复制的数据的实际大小为零

内部版本 09.00.3233

此内部版本于 2008 年 7 月 8 日发布。

此内部版本的父内部版本为 09.00.3232。

此内部版本包含以下 SQL Server 2005 安全更新。

SQL 修补程序 bug 号 知识库文章编号 说明
50002340 948108 MS08-040: SQL Server 2005 QFE 安全更新说明:2008 年 7 月 8 日

内部版本 09.00.3232

此内部版本于 2008 年 3 月 8 日发布。

此内部版本的父内部版本为 09.00.3231。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002540 949959 修复:在 SQL Server 2005 中同步合并复制数据时出现错误消息:“合并进程正在重试对项目 'ArticleName' 进行的失败操作 - 原因:”输入参数值无效。 检查状态值了解详细信息。”

内部版本 09.00.3231

此内部版本于 2008 年 3 月 6 日发布。

此内部版本的父内部版本为 09.00.3230。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002512 949595 修复:在 SQL Server 2005 中运行使用联接条件的查询时出现错误消息:“非生成计划程序”
50002514 949687 修复:使用 SQL Server 2005 中的链接服务器从远程服务器运行事务时出现错误消息:“此操作与此事务上的另一个挂起操作冲突”
50002515 949631 修复:尝试针对 SQL Server 2005 Analysis Services 中的 Oracle 数据源创建货币转换时出现错误消息:“创建命名查询时执行了以下语句:SELECT 'Reporting Currency'”

内部版本 09.00.3230

此内部版本于 2008 年 2 月 28 日发布。

此内部版本的父内部版本为 09.00.3228。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002473 949199 修复:在 SQL Server 2005 中启用了 SNAPSHOT 隔离级别的数据库上运行查询时出现错误消息:“无法解除分配保留的页”

内部版本 09.00.3228 (累积更新)

此累积更新包于 2008 年 2 月 18 日发布。

此内部版本的父内部版本为 09.00.3224。

有关此内部版本中包含的 SQL Server 2005 post-Service Pack 2 修补程序的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

946608 SQL Server 2005 Service Pack 2 的累积更新程序包 6

内部版本 09.00.3224

此内部版本于 2008 年 1 月 18 日发布。

此内部版本的父内部版本为 09.00.3222。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002283 947179 修补程序:使用 VisualTotals 函数的 MDX 查询在 SQL Server 2005 Analysis Services 中返回不正确的空值
50002308 947463 修复:存储过程无法在 SQL Server 2005 中完成其执行

内部版本 09.00.3222

此内部版本于 2008 年 1 月 16 日发布。

此内部版本的父内部版本为 09.00.3221。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002212 947196 修补程序:使用属于 SQL Server 2005 Analysis Services 中某些不同角色的用户帐户运行 MDX 查询时,会发生访问冲突
50002247 945640 修复:在 SQL Server 2005 Analysis Services 的 SCOPE 语句中使用 SUM 函数时,SCOPE 语句可能返回不正确的结果
50002248 945641 修复:多次计算相同单元格的计算脚本可能会在 SQL Server 2005 Analysis Services Service Pack 2 中返回不正确的结果
50002251 947197 修补程序:在 SQL Server 2005 Analysis Services 中,服务器上的工作负载需求很高时出现错误消息:“内部错误:发生意外异常”

内部版本 09.00.3221

此内部版本于 2008 年 1 月 2 日发布。

此内部版本的父内部版本为 09.00.3215。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002166 945442 修复:如果在 SQL Server 2005 中打开查询的仅快进光标,则无法立即取消查询执行
50002168 945443 修复:当您为查询打开仅快进光标时,在 SQL Server 2005 中查询完成所需的时间比在 SQL Server 2000 中要长
50002245 942908 修复:当您在 SQL Server 2005 中更改有关订阅者的文章时,更改可能会在以后的同步期间撤消
50002246 944358 修复:以 PDF 格式显示 SQL Server 2005 Reporting Services 报表时,复杂脚本字符无法正确显示
50002249 945916 修复:在 SQL Server 2005 中删除事务中的表的某些记录或更新事务中的表的某些记录时出现错误消息:“Msg 9002”、“Msg 3314”和“Msg 9001”

内部版本 09.00.3215 (累积更新)

此累积更新包于 2007 年 12 月 17 日发布。

此内部版本的父内部版本为 09.00.3209。

有关此内部版本中包含的 SQL Server 2005 post-Service Pack 2 修补程序的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

943656 SQL Server 2005 Service Pack 2 的累积更新程序包 5

内部版本 09.00.3209

此按需版本于 2007 年 11 月 20 日发布。

此内部版本的父内部版本为 09.00.3208。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002118 CMEMTHREAD 等待类型或旋转锁上发生争用。

内部版本 09.00.3208

此按需版本于 2007 年 11 月 15 日发布。

此内部版本的父内部版本为 09.00.3206。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002030 CMEMTHREAD 等待类型导致负载下 CPU 使用率过高。

内部版本 09.00.3206

此按需版本于 2007 年 11 月 8 日发布。

此内部版本的父内部版本为 09.00.3205。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50001986 添加了一项功能,用于记录由不同元数据引起的静默冲突。

内部版本 09.00.3205

此按需版本于 2007 年 11 月 7 日发布。

此内部版本的父内部版本为 09.00.3203。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50001708 在 SQL Server Management Studio 中,如果未指定旧密码,则无法更改 db_securityadmin 数据库角色的密码。
50001999 打开接受一个或多个 DateTime 参数的报表后,无法在 Windows Internet Explorer 7 中返回到原始报表。

内部版本 09.00.3203

此按需版本于 2007 年 9 月 30 日发布。

此内部版本的父内部版本为 09.00.3200。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50001951 在 SQL Server Management Studio 中,如果未指定旧密码,则无法更改 db_securityadmin 数据库角色的密码。
50001993 打开接受一个或多个 DateTime 参数的报表后,无法在 Internet Explorer 7 中返回到原始报表。
50001997 在运行重建索引任务时,SQL Server 2005 SP2 中引入的新批处理模型会导致内存不足异常。
50001998 SQL Server 2000 的实例转发到 SQL Server 2005 的事件 ID 17055 消息,SQL Server 2005 的实例没有收到。
50002000 (此 Bug 是 Bug 编号 50000314 的变体。) SQL Server 2005 SP2 中 Report Builder 中的“保存”对话框停止响应。 如果在 Report Builder 的 URL 中指定了报表名称时启动 Report Builder,则会出现此问题。

内部版本 09.00.3200 (累积更新)

此累积更新包于 2007 年 10 月 15 日发布。

此内部版本的父内部版本为 09.00.3195。

有关此内部版本中包含的 SQL Server 2005 post-Service Pack 2 修补程序的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

941450 SQL Server 2005 Service Pack 2 的累积更新程序包 4

内部版本 09.00.3195

此按需版本于 2007 年 9 月 19 日发布。

此内部版本的父内部版本为 09.00.3194。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50001812 在链接到文档库部件的 Web 部件上设置参数时,会出现空引用异常。

生成号 09.00.3194

此按需版本于 2007 年 9 月 11 日发布。

此内部版本的父内部版本为 09.00.3186。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50001766 942087 使用 SQL Server 2005 Integration Services 内部版本 9.00.3042 生成的 C# 应用程序崩溃,并且 inDtspipeline.dll 发生访问冲突。
50001619 处理索引时发生内部异常。
50001625 在 SQL Server 2005 Analysis Services Service Pack 2 (SP2) 中,PFCompressIterator::D ecompressArray 函数在压力条件下会频繁发生访问冲突。
50001713 报表管理器向下钻取 (+/-) 与快照不一致。
50001550 合并不收敛发生在重新发布者和发布者之间。

内部版本 09.00.3186 (累积更新)

此累积更新包于 2007 年 8 月 20 日发布。

此内部版本的父内部版本为 09.00.3182。

有关此内部版本中包含的 SQL Server 2005 post-Service Pack 2 修补程序的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

939537 SQL Server 2005 Service Pack 2 累积更新包 3

内部版本 09.00.3182

此版本已不再可用。 请使用内部版本 3186 或更高版本。 此按需版本于 2007 年 7 月 17 日发布。

此内部版本的父内部版本为 09.00.3180。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50001298 938712 在 Analysis Services 2005 中,数据库的完整流程可能不会处理某些维度的所有记录
50001324 940129 MDX 查询可能不会返回结果,除非使用具有不自然层次结构的维度指定“非空”
50001440 940128 SQL Server 可能无法为涉及光标的复杂查询生成计划,并出现错误 8623

内部版本 09.00.3180

此版本已不再可用。 请使用内部版本 3186 或更高版本。 此按需版本于 2007 年 7 月 11 日发布。

此内部版本的父内部版本为 09.00.3179。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50001392 939942 修复:将 SQL Server 2005 Reporting Services 配置为在 SharePoint 集成模式下运行后,尝试访问报表时会收到错误消息

内部版本 09.00.3179

此版本已不再可用。 请使用内部版本 3186 或更高版本。 此按需版本于 2007 年 7 月 11 日发布。

此内部版本的父内部版本为 09.00.3178。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50001482 TokenAndPermUserStore 缓存存储可能会继续稳步增长并降低性能
50001194 938243 对正在重建的目录执行全文查询可能会失败,并出现索引损坏错误

内部版本 09.00.3178

此版本已不再可用。 请使用内部版本 3186 或更高版本。 此按需版本于 2007 年 7 月 5 日发布。

此内部版本的父内部版本为 09.00.3177。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50001193 938086 在代理帐户的上下文中运行并发 SQL Server 代理作业可能会失败并出现错误
50001352 938086 在代理帐户的上下文中运行并发 SQL Server 代理作业可能会失败并出现错误

内部版本 09.00.3177

此版本已不再可用。 请使用内部版本 3186 或更高版本。 此按需版本于 2007 年 6 月 29 日发布。

此内部版本的父内部版本为 09.00.3175。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50001391 939562 在 SQL Server 2005 SP2 中,包含 INSTEAD OF 触发器的查询可能会失败,并显示错误 8624
50001367 938363 当分区组有联接过滤器并且文章属于多个发布时,合并复制中可能会出现不收敛
50001379 939285 当处于同步模式且查询超时,SQL Native Client 提供程序可能会返回不正确的错误消息
50001408 939564 使用 SQL Native Client 提供程序时,查询包含超过 1,024 个字符的文本列可能返回不正确的结果
50001397 939563 合并复制拓扑中的 UPDATE 查询或 DELETE 查询可能会失败,并显示错误 8152

内部版本 09.00.3175 (累积更新)

此累积更新包于 2007 年 6 月 18 日发布。

此内部版本的父内部版本为 09.00.3169。 有关此内部版本中包含的 SQL Server 2005 post-Service Pack 2 修补程序的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

936305 适用于 SQL Server 2005 Service Pack 2 的累积更新程序包 2 可用

内部版本 09.00.3171

此按需版本于 2007 年 5 月 30 日发布。

 此内部版本的父内部版本为 09.00.3169。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL VSTS 错误号 知识库文章编号 说明
262044 937745 修复:尝试登录到 SQL Server 2005 的实例且 SQL Server 处理许多并发连接时,可能会收到错误消息
262045 937829 修补程序:针对 SQL Server 2005 Service Pack 2 中的数据库运行 MDX 查询时出现错误消息:“出现意外异常”

内部版本 09.00.3169

此按需版本于 2007 年 5 月 18 日发布。

 此内部版本的父内部版本为 09.00.3166。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50001251 937041 修复:如果发布服务器数据库在 SQL Server 2005 中的数据库镜像会话中公开运行,则发布服务器数据库中的更改不会复制到事务复制中的订阅者
50001248 937033 修复:在 SQL Server 2005 中运行链接服务器查询时出现错误消息:“链接服务器'<ServerName>'的 oledbprovider unisys.dmsII.1 报告了提供程序内存不足的错误”

内部版本 09.00.3166

此按需版本于 2007 年 5 月 7 日发布。

此内部版本的父内部版本为 09.00.3162。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50001020 936185 修复:如果临时表创建工作负载很高,则在 SQL Server 2005 中启用跟踪标志 1118 时可能会出现阻塞和性能问题
50000726 932106 修补程序:运行使用链接服务器从 SQL Server 2005 中的 Analysis Services 实例查询数据的 DMX 查询时出现错误消息:“发生以下系统错误:登录失败:用户名未知或密码错误”
50001024 934734 修复:在 SQL Server 2005 中更新包含非聚集索引的表时,数据库被标记为置疑
50000924 936863 修复:安装 SQL Server 2005 Analysis Services Service Pack 2 后,某些 MDX 查询的运行速度可能会变慢,占用更多内存
50000925 936262 在 SQL Server 2005 Analysis Services 中,即使内存使用量小于配置的 LowMemoryLimit 属性,也会清理缓存。
50000898 936261 修复:在 SQL Server 2005 Analysis Services 中处理分区时,进程停止响应,CPU 利用率达到 100%
50000802 932180 修复:在 SQL Server BIDS 中浏览 SQL Server 2005 Analysis Services 的聚类分析模型时,“群集辨别选项卡为空
50000920 935341 修复:针对 SQL Server 2005 Analysis Services 中的度量值运行 MDX 查询时出现错误消息:“发生内部错误”
50000732 932331 尝试在运行 SQL Server 2005 Analysis Services 的 32 位服务器上生成包含大量数据的挖掘模型时,将收到错误消息。
50000890 936254 修复:如果 MDX 查询从 SQL Server 2005 Analysis Services 中记录少于 4,096 条的聚合读取,则该查询可能会很慢

内部版本 09.00.3162

此按需版本于 2007 年 4 月 23 日发布。

此内部版本的父内部版本为 09.00.3161。

 此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50001001 932610 修复:在 SQL Server 2005 Analysis Services 中运行 MDX 查询时出现错误消息:“文件'pffilestore.cpp'发生意外错误,第 3267 行,函数 (PFFileStore::HandleDataPageFault') ”
50001056 935922 修复:安装 Microsoft Dynamics CRM 3.0 时出现错误消息:“安装程序无法验证指定的 Reporting Services Report Server”
50000926 935360 修复:运行从 Analysis Services 数据库检索数据的 MDX 查询时出现错误消息:“正在处理 ID 为 'DatabaseName>'<、名称为 '<DimensionName>' 的维度时发生错误”
50000923 935829 修复:在 SQL Server 2005 Analysis Services 中针对包含父子层次结构的维度运行 MDX 查询时收到错误的结果
50000871 935830 修复:如果安装了 SQL Server 2005 Analysis Services,并且服务器上存储了许多对象,则服务器启动速度可能会很慢
50000927 来自 SQL Server 2005 Analysis Services 数据库的值可能大于源数据库中的值。
50000899 935831 在 SQL Server 2005 Analysis Services 中为分区配置主动缓存时,在主动缓存更新期间可能会对基础分区进行两次处理。
50000885 935832 修复:无法取消在 SQL Server 2005 Analysis Services 中长时间运行的 MDX 查询

内部版本 09.00.3161 (累积更新)

此累积更新程序包于 2007 年 4 月 16 日发布。

此内部版本的父内部版本为 09.00.3159。

有关此内部版本中包含的 SQL Server 2005 post-Service Pack 2 修补程序的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

935356 SQL Server 2005 Service Pack 2 的内部版本 3161) (累积更新程序包可用

内部版本 09.00.3159

此按需版本于 2007 年 4 月 4 日发布。

此内部版本的父内部版本为 09.00.3156。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50001012 934459 修复:在 SQL Server 2005 内部版本 3150 到 3158 中,在某些情况下,维护计划中的“检查数据库完整性”任务和“执行 T-SQL 语句”任务可能会丢失数据库上下文

内部版本 09.00.3156

此累积更新包于 2007 年 3 月 23 日发布。

此内部版本的父内部版本为 09.00.3155。

 此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50000958 934226 修补程序:在 SQL Server 2005 中尝试使用 数据库邮件 发送电子邮件时出现错误消息:“配置文件名 (Microsoft SQL Server无效,错误 14607) ”

内部版本 09.00.3155

此按需版本于 2007 年 3 月 21 日发布。

此内部版本的父内部版本为 09.00.3154。

 此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50000900 933549 修复:在 SQL Server 2005 中执行批量复制操作时,可能会收到访问冲突
50000964 933724 修复:当您针对 SQL Server 2005 的实例运行使用用户定义的标量函数的查询时,查询性能很慢
50000875 932115 修复:幽灵行清理线程无法删除 SQL Server 2005 中数据库的某些数据文件上的虚影行
50000969 933766 修复:在 SQL Server 2005 中执行各种操作时,错误日志文件中出现失败断言消息:“失败断言 = 'fFalse' 尝试访问过期的 blob 句柄 (3) ”
50000919 运行加密存储过程时,可能会出现错误 565。 错误 565 的错误消息如下所示:“编译查询时服务器中发生堆栈溢出。 请简化查询。”
50000918 933808 修复:在 SQL Server 2005 中运行包含嵌套的 FOR XML 子句的查询时出现错误消息:“XML 数据类型已损坏”
50000921 933499 修复:在 SQL Server 2005 中使用事务复制将存储过程的执行复制到订阅者时出现错误消息:“内存不足,无法运行查询”

内部版本 09.00.3154

此按需版本于 2007 年 3 月 21 日发布。

此内部版本的父内部版本为 09.00.3153。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50000948 934106 修复:使用复制监视器监视分布数据库时,SQL Server 2005 数据库引擎生成失败断言错误
50000952 934188 修复:即使分发代理在 SQL Server 2005 中运行,分发代理也不会向订阅者传递命令
50000949 934109 修复:当您将事务复制发布配置为在 SQL Server 2005 中的订阅者处应用快照后运行其他脚本时,分发代理会生成访问冲突
50000960 来自 Excel 数据挖掘客户端加载项的内容查询可能需要很长时间才能显示结果集。 当结果集较大时,尤其会出现此问题。 Microsoft Office Excel 在查询运行时可能出现停止响应 (挂起) 的情况。

内部版本 09.00.3153

此按需版本于 2007 年 3 月 15 日发布。

此内部版本的父内部版本为 09.00.3152。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50000945 933564 修复:SQL Server 2005 中,USERSTORE_TOKENPERM缓存存储的内存消耗逐渐增加

内部版本 09.00.3152

此累积修补程序包于 2007 年 3 月 15 日发布。

此内部版本的父内部版本为 09.00.3077。

有关此内部版本中包含的 SQL Server 2005 post-Service Pack 2 修补程序的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

933097适用于 SQL Server 2005 Service Pack 2 的内部版本 3152) 的累积修补程序包 (可用

内部版本 09.00.3077

此内部版本于 2009 年 2 月 10 日发布。

此内部版本的父内部版本为 09.00.3073。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

VSTS 编号 知识库文章编号 说明
261044 960089 MS09-004: SQL Server 2005 GDR 安全更新说明:2009 年 2 月 10 日

内部版本 09.00.3073

此内部版本于 2008 年 9 月 9 日发布。

此内部版本的父内部版本为 09.00.3068。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002995 954606 MS08-052: 2008 年 9 月 9 日发布的 SQL Server 2005 Service Pack 2 GDR 的 GDI+ 安全更新说明

内部版本 09.00.3068

此内部版本于 2008 年 7 月 8 日发布。

此内部版本的父内部版本为 09.00.3054。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002341 948109 MS08-040: SQL Server 2005 GDR 安全更新说明:2008 年 7 月 8 日

内部版本 09.00.3054

此内部版本于 2007 年 3 月 4 日发布。

此内部版本包含以下 SQL Server 2005 SP2 以后的修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50001012 934458 修复:在 SQL Server 2005 内部版本 3042 到 3053 中,在某些情况下,维护计划中的“检查数据库完整性”任务和“执行 T-SQL 语句”任务可能会丢失数据库上下文

内部版本 09.00.3042 (SQL Server 2005 Service Pack 2)

这是 2007 年 2 月 27 日发布的 SQL Server 2005 Service Pack 2 的内部版本。

此内部版本包含以下 SQL Server 2005 修补程序。

SQL 修补程序 bug 号 知识库文章编号 说明
50002426 942980 修补程序:在安装了 Windows 内部数据库 SP2 的服务器上安装 SQL Server 2005 发行版时出现错误消息:“SQL Server 服务无法启动”
50000919 934246 修补程序:运行在 SQL Server 2005 中加密的长存储过程时出现错误消息:“编译查询时服务器中发生堆栈溢出”

参考资料

有关 SQL Server 增量服务模型的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

935897 可从 SQL Server 团队获取增量服务模型以提供可以解决所报告问题的修补程序

有关如何获取 SQL Server 2005 Service Pack 2 的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

913089 如何获取最新的 SQL Server 2005 Service Pack

 有关 SQL Server 2005 Service Pack 2 中的新功能和改进的详细信息,请访问以下 Microsoft 网站:

https://go.microsoft.com/fwlink/?linkid=71711有关适用于 SQL Server 2005 和 SQL Server 2008 的 Microsoft 知识库文章的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

957826 可在何处找到有关 SQL Server 2008 之后发布的 SQL Server 2008 内部版本和 SQL Server 2005 Service Pack 2 之后发布的 SQL Server 2005 内部版本的详细信息

有关 SQL Server 更新的命名架构的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

822499 Microsoft SQL Server 软件更新包的新命名架构

有关软件更新术语的更多信息,请单击下面的文章编号以查看 Microsoft 知识库中的相应文章:

824684 用于描述Microsoft软件更新的标准术语说明