Microsoft 将 Microsoft SQL Server 2008 R2 修补程序作为一个可下载的文件分发。 由于修补程序是累积的,因此每个新版本都包含之前 SQL Server 2008 R2 修补程序版本中包含的所有修补程序和安全修补程序。
症状
请考虑以下情形:
- 使用 Windows 帐户登录到运行 Windows Vista 或更高版本的 Windows 的计算机。
- 您可以使用 Windows 帐户在计算机上配置 SQL Server 2008 R2 或 SQL Server 2008 的实例。
- 更改 Windows 帐户密码。
- 您尝试更新 SSCM) 中 SQL Server 实例SQL Server 配置管理器 (密码。
在这种情况下,您会收到以下错误消息:
注意
Access is denied. [0x80070005]
解决方法
累积更新信息
SQL Server 2008 Service Pack 3 累积更新 11
此问题的修补程序已在累积更新 11 中首次发布。 有关如何获取 SQL Server 2008 Service Pack 3 的此累积更新程序包的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2834048 SQL Server 2008 Service Pack 3 的累积更新程序包 11 注意 由于版本是累积的,因此每个新的修复版本都包含之前 SQL Server 2008 Service Pack 3 修复版本中包含的所有修补程序和所有安全修补程序。 建议应用包含此修补程序的最新修补程序版本。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2629969 在 SQL Server 2008 Service Pack 3 发布之后发布的 SQL Server 2008 内部版本
SQL Server 2008 R2
此问题的修补程序已在累积更新 4 中首次发布。 有关如何获取 SQL Server 2008 R2 的此累积更新程序包的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
2345451 SQL Server 2008 R2 累积更新包 4 注意:由于版本是累积的,因此每个新的修补程序版本都包含之前 SQL Server 2008 R2 修补程序版本中包含的所有修补程序和安全修补程序。 建议应用包含此修补程序的最新修补程序版本。 有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
981356 在 SQL Server 2008 R2 发布之后发布的 SQL Server 2008 R2 内部版本
解决方法
若要解决此问题,请按照下列步骤操作:
- 在 SSCM 中,将 SQL Server 的实例更改为不同的帐户。 例如,单击 “内置帐户”,然后选择 “本地系统 ”帐户。
- 使用 Windows 帐户的新密码将 SQL Server 的实例更改回原始帐户。
状态
Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。
参考资料
有关如何更改 SQL Server 使用的帐户密码的详细信息,请访问以下 Microsoft 网站:
如何更改 SQL Server 使用的帐户的密码
有关 Windows Vista 完整性机制的更多信息,请访问以下 Microsoft 网站:
有关 Windows Vista 完整性机制的一般信息
有关 SQL Server 增量服务模型的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
935897 可从 SQL Server 团队获取增量服务模型以提供可以解决所报告问题的修补程序
有关 SQL Server 更新的命名架构的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
822499 Microsoft SQL Server 软件更新包的新命名模式有关软件更新术语的更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
824684 用于描述Microsoft软件更新的标准术语说明