KB3169738 - 修复:由于 SQL Server 2014 SP1 或 SP2 中的查询超时,基于托管备份保留期的清理任务失败

应用对象
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Express - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2014 Web - duplicate (do not use)

症状

假设您在 Microsoft SQL Server 2014 Service Pack 1 (SP1) 或 SP2 中的数据库上SQL Server启用了 Windows Azure的托管备份。 当基于保留的清理任务对大型备份 blob 执行 RESTORE HEADERONLY 语句时,执行操作可能会超时。因此,基于保留的清理任务失败。

出现此问题的原因是默认 ADO.NET 命令超时值为 30 秒。 但是,RESTORE HEADERONLY 语句的执行可能会超过 30 秒。 这会导致超时。

解决方法

此问题已首先在 SQL Server 的以下累积更新中修复:

建议:安装 SQL Server 的最新累积更新

SQL Server 的每个新累积更新都包含上一个累积更新中包含的所有修补程序和所有安全修补程序。 建议下载并安装 SQL Server 的最新累积更新:

      

状态

Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。