症状
当您使用跟踪配置文件编辑器 (TPE) 或 BTTDeploy (Bttdeploy.exe) 工具部署在 BizTalk Server 2010 中的较大的跟踪配置文件 (.btt) 时,部署将失败。此外,您收到以下错误消息:
已隐式或显式提交或中止事务 (从 HRESULT 异常︰ 0x8004D00E)。
注意:此累积更新包解决了当您使用 Bttdeploy.exe 工具时发生问题。
原因
因为事务超时 3 分钟之前可以完全部署大型配置文件后,将出现此问题。
解决方案
若要解决此问题,请应用此修复程序。应用此修复程序后,您可以扩展成大于 3 分钟的默认超时值。
注意:此修复程序应用于 BTSDeploy.exe 命令行工具而不适用于其他业务活动监视 (BAM) 工具。 若要扩展默认的超时值,请到 BTSDeploy.exe.config 文件中添加以下行︰<configuration>
<appSettings> < 添加键 = 值"CommandTimeoutInMinutes"="nn"/ > </appSettings> </ configuration> 备注:-
Nn占位符表示您想要设置为默认的超时值的分钟数。
-
如果超时时间达到了 10 分钟以上,还必须考虑 Machine.config 文件中默认的.NET Framework 超时值。此值必须是相同或更高版本的 BTSDeploy.exe.config 文件中的超时值。
-
请注意,增加超时值可能无法完全解决问题。因为基础的其他问题也会触发此问题,您可能需要查看的跟踪配置文件、 BizTalk 配置、 Windows 配置、 SQL Server 性能、 存储性能和网络性能以解决实际问题。
累积更新信息
累积更新 6为 BizTalk Server 2010 中包括的修复程序可以解决此问题。
状态
Microsoft 已经确认这是“适用于”一节中列出的 Microsoft 产品中的问题。
解决方法
若要变通解决此问题,请使用下列方法之一︰
-
部署较小尺寸的跟踪配置文件,以使事务响应不会超过 3 分钟。
-
优化 SQL Server 响应中 3 分钟超时的事务。