使用 Microsoft 登录
登录或创建帐户。
你好,
使用其他帐户。
你有多个帐户
选择要登录的帐户。

症状

请考虑以下情况:

  • 在计算机上安装完整的 Microsoft SQL Server 2005 版本。

  • 安装 Microsoft Office Accounting Professional 或 Microsoft Office Accounting Express 时,Microsoft SQL Server Express 2005。

  • 安装 2005 Microsoft SQL Server Express后,将删除 2005 Microsoft SQL Server的完整版本。

在这种情况下,启动 Accounting Professional或 Accounting Express 时,会收到以下错误消息:

Microsoft Office 会计部门遇到问题,需要关闭。 由此带来的不便,我们深表歉意。 若要查看此错误报告包含的数据,请单击此处。

在 Accounting Professional 或 Accounting Express 中打印报表时,也会收到此错误消息。

单击查看报表数据后,将收到类似于以下消息的错误消息:

未注册类 (异常来自 HRESULT:0x80040154 (REGDB_E_CLASSNOTREG) )

收到第二条错误消息时,Accounting Professional或 Accounting Express 停止响应。

原因

出现此问题的原因是在删除 2005 年 5 月的完整版本时,会计Professional或 Accounting Express 使用Microsoft SQL Server组件。 删除的一些关键组件是 Microsoft Office 2003 Web 组件。

解决方法

若要解决此问题,请重新安装 Microsoft Office 2003 Web 组件。 为此,请执行以下步骤:

  1. 依次单击“开始”、“控制面板”和“添加或删除程序”。

    注意 如果使用 Vista Windows,请单击"控制面板",然后单击"程序和功能"。

  2. 单击Microsoft Office 2003 Web 组件",然后单击"删除"。

    注意Microsoft Office 2003 Web 组件未显示在列表中,请转到步骤 3。

  3. 获取并安装 Microsoft Office 2003 Web 组件。 若要详细了解如何这样做,请访问以下 Microsoft 网站:

    http://www.microsoft.com/downloads/details.aspx?familyid=7287252C-402E-4F72-97A5-E0FD290D4B76&displaylang=en

  4. 启动 Accounting Professional 或 Accounting Express。

如果问题仍然存在,请删除 Accounting Professional Accounting Express。 然后,重新安装 Accounting Professional或 Accounting Express。

状态

Microsoft 已经确认这是一个列于“适用范围”部分的 Microsoft 产品问题。

需要更多帮助?

需要更多选项?

了解订阅权益、浏览培训课程、了解如何保护设备等。

社区可帮助你提出和回答问题、提供反馈,并听取经验丰富专家的意见。

此信息是否有帮助?

你对语言质量的满意程度如何?
哪些因素影响了你的体验?
按“提交”即表示你的反馈将用于改进 Microsoft 产品和服务。 你的 IT 管理员将能够收集此数据。 隐私声明。

谢谢您的反馈!

×