使用 Microsoft 登录
登录或创建帐户。
你好,
使用其他帐户。
你有多个帐户
选择要登录的帐户。

摘要

在尝试使用 Microsoft Windows Media Player 播放媒体文件时,收到以下错误消息:

无法播放文件, 不支持此格式。 (错误为 80040265)

原因

此问题可能是由以下一个或多个原因所引起的:

  • 一个或多个 Windows Media Player 文件丢失或损坏。

  • 您试图播放的媒体文件具有 Windows Media Player 所不支持的文件格式。 例如,您试图播放一个 .viv 文件。 Windows Media Player 不支持 .viv 文件。

  • 媒体文件已损坏。

  • 媒体文件使用的编解码器尚未安装。

  • 媒体文件使用的是 Windows Media Player 不支持的编解码器。

解决方案

若要解决此问题,请按照下列步骤操作。 完成每个步骤之后,进行测试以确定问题是否已解决。

注意 Windows Media Player 支持最常见的媒体文件格式。 但是,并非当前所有可用媒体文件格式它都支持。 在步骤 1 中,应确保 Windows Media Player 支持你尝试播放的文件格式。 如果 Windows Media Player 不支持该格式,请不要执行步骤 1 后面的步骤。 而是与该文件的分发者联系,了解是否有适用于该文件的查看器。

注意 由于 Microsoft Windows 有多个版本,因此下列步骤可能会因所用计算机的不同而有所不同。 如果是这样,请参见您的产品文档来完成这些步骤。

  1. 验证 Windows Media Player 是否支持你尝试播放的文件格式。 Windows Media Player 支持下列文件格式:

    • Windows Media 格式: .asf、.asx、.avi、.wav、.wax、.wma、.wm、.wmv

    • 动态图像专家组 (MPEG) 格式: .m3u、.mp2v、.mpg、.mpeg、.m1v、.mp2、.mp3、.mpa、.mpe、.mpv2

    • 音乐设备数字接口 (MIDI) 格式: .mid、.midi、.rmi

    • UNIX 格式: .au、.snd

    注意 Windows Media Player 不支持播放使用 Microsoft MPEG4v3 编解码器创建的 .avi 文件。 Microsoft 只支持 .asf 流格式的 MPEG4v3 文件。 不支持 .avi 文件类型的文件。 要播放该文件,必须使用原始的源文件,重新以受支持的格式(如 .wmv 格式)对文件进行编码。 执行此操作时,可以使用 Windows Media 编码器。 有关其他信息,请访问下面的 Microsoft 网站,然后在“选择下载”列表中,单击“Windows Media 编码器”:

    http://www.microsoft.com/windows/windowsmedia/download 如果您可以访问原始的源文件,请与文件的创建者联系,请求创建者将文件转换为受 Windows Media Player 支持的文件格式。

  2. 验证是否可以播放与播放时收到错误消息的文件具有相同扩展名的媒体文件。

    有关 Windows Media Player 支持的文件格式的说明和示例,请单击下面的文章编号,以查看 Microsoft 知识库中的相应文章:

    316992 Windows Media Player 多媒体文件格式
      如果另一个文件可以正常播放,则最初尝试播放的文件可能已经损坏。 如果播放两个文件时都收到了错误消息,请继续执行下一步。

  3. 删除 Windows Media Player,重新启动计算机,然后重新安装 Windows Media Player。

    1. 要删除 Windows Media Player,请按照下列步骤操作:

      1. 依次单击“开始”、“控制面板”和“添加或删除程序”。

      2. 在“当前安装的程序”列表中,单击“Microsoft Windows Media Player”,然后单击“更改/删除”。

      3. 当提示确认删除时,单击
        “是”。

        注意 使用此方法无法删除内置版本的 Windows Media Player。 有关如何删除 Windows Media Player 9 系列的其他信息,请访问下面的 Microsoft 网站:

        http://www.microsoft.com/windows/windowsmedia/player/9series/readme.aspx#removeplayer

    2. 重新启动计算机。

    3. 要下载最新版本的 Windows Media Player,请访问下面的 Microsoft 网站:

      http://www.microsoft.com/windows/windowsmedia/download/AllDownloads.aspx

  4. 重新安装最新版本的 Microsoft DirectX。
    有关 DirectX 故障排除和安装方面的其他信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

    179113 如何下载和安装 DirectX

    157730 如何使用 DirectX 诊断工具确定 DirectX 的版本

  5. 验证在尝试播放媒体文件时使用的编解码器是否正确。
    有关音频编解码器的验证、安装以及故障排除方面的其他信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

    142731 如何在 Windows 中安装和删除编解码器和 MCI 设备

    141801 Windows 95/98 中的音频和视频编解码器疑难解答

    191533 Media Player 无法使用 Indeo 4.x 编解码器播放 .avi 文件

    221831 无法下载相应的解压缩程序

  6. 启动“注册表编辑器”,然后验证以下注册表子项及其相关值是否存在。 要启动“注册表编辑器”,请依次单击“开始”、“运行”,键入
    regedit,然后单击“确定”。

    重要说明 本部分、方法或任务包含有关如何修改注册表的步骤。 但是,注册表修改不当可能会出现严重问题。 因此,请一定严格按照下列步骤操作。 为了获得进一步的保护,请在修改注册表之前对其进行备份。 这样就可以在出现问题时还原注册表。 有关如何备份和还原注册表的更多信息,请单击下面的文章编号查看 Microsoft 知识库中相应的文章:

    322756 如何在 Windows 中备份和还原注册表
    注册表子项:

    HKEY_CLASSES_ROOT\CLSID\{da4e3da0-d07d-11d0-bd50-00a0c911ce86}\Instance\{083863F1-70DE-11d0-BD40-00A0C911CE86} 相关项及其值:

    名称

    数据

    类型

    CLSID

    {083863F1-70DE-11d0-BD40-00A0C911CE86}

    字符串值

    FriendlyName

    DirectShow Filters

    字符串值

    Merit

    00600000

    DWORD 值

    如果此子项存在并且其相关值是正确的,请退出注册表编辑器。

    如果此项不存在,请创建它。 为此,请按照下列步骤操作:

    1. 找到并单击下面的子项:

      HKEY_CLASSES_ROOT\CLSID\{da4e3da0-d07d-11d0-bd50-00a0c911ce86}\Instance

    2. 在“编辑”菜单上,指向“新建”,然后单击“项”。

    3. 键入 {083863F1-70DE-11d0-BD40-00A0C911CE86},然后按 Enter。

    4. 在“编辑”菜单上,指向“新建”,然后单击“字符串值”。

    5. 键入 CLSID,然后按 Enter。

    6. 在“编辑”菜单上,单击“修改”。

    7. 键入 {083863F1-70DE-11d0-BD40-00A0C911CE86},然后单击“确定”。

    8. 在“编辑”菜单上,指向“新建”,然后单击“字符串值”。

    9. 键入 FriendlyName,然后按 Enter。

    10. 在“编辑”菜单上,单击“修改”。

    11. 键入 DirectShow Filters,然后单击“确定”。

    12. 在“编辑”菜单上,指向“新建”,然后单击“DWORD 值”。

    13. 键入 Merit,然后按 Enter。

    14. 在“编辑”菜单上,单击“修改”。

    15. 键入 600000,然后单击“确定”。

    16. 退出“注册表编辑器”。

参考

尝试播放 Windows Media Player 文件时可能还会收到其他错误消息,有关这些错误的其他信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

234019 Windows Media Player 出现“无效的文件格式”错误消息

需要更多帮助?

需要更多选项?

了解订阅权益、浏览培训课程、了解如何保护设备等。

社区可帮助你提出和回答问题、提供反馈,并听取经验丰富专家的意见。

此信息是否有帮助?

你对语言质量的满意程度如何?
哪些因素影响了你的体验?
按“提交”即表示你的反馈将用于改进 Microsoft 产品和服务。 你的 IT 管理员将能够收集此数据。 隐私声明。

谢谢您的反馈!

×