使用 Microsoft 登录
登录或创建帐户。
你好,
使用其他帐户。
你有多个帐户
选择要登录的帐户。

症状

在基于 Windows 7 的计算机上安装 Windows 随时升级时,可能会收到以下错误消息:

Windows 随时升级不成功
。升级不成功。 请重试升级。


此外,Windows 随时升级升级.日志文件:

  • <日期和时间> <,>错误 WAU DoTransmogrify 失败,0x800f081f。

  • <日期和时间> <,> WAU UpgradeSKU 失败。 正在退出。

  • <日期> <时间>,错误 WAU Windows 随时升级"不成功。

原因

如果 Windows 7 Service Pack 1 (SP1) Windows Update 下载但尚未安装,则可能会发生此问题。 有关此 Service Pack 的信息,请单击以下文章编号,在 Microsoft 知识库中查看该文章:

976932 有关适用于 Windows 7 和 Windows Server 2008 R2 的 Service Pack 1 的信息

解决方案

若要让我们解决此问题,请转到"为我修复"部分。 如果你希望自己修复此问题,请转到"让我自己修复"部分

帮我修复此问题



若要自动修复此问题,请单击" 修复它"按钮 或链接。 然后单击 "文件 下载 "对话框中的 "运行",然后按照修复向导 中的步骤 操作。




备注

  • 此向导可能只提供英文版本。 但是,自动修复功能同样适用于其他语言版本的 Windows。

  • 如果你不在遇到问题的计算机上,应该将"修复它"解决方案保存到闪存驱动器或 CD,然后在有问题的计算机上运行它。


然后,转到"此问题是否修复?"部分。



我自己修复此问题

卸载 Windows 7 Service Pack 1

若要解决此问题,请通过 DISM 命令卸载 Service Pack 1。 为此,请按照适用于你的 Windows 7 版本的这些步骤操作。

对于 32 位版本的 Windows 7

  1. 单击“开始”,然后在“搜索”框中键入 cmd。

  2. 右键单击cmd.exe,并单击"以管理员角色运行"。

  3. 键入以下命令,然后按 Enter:

    dism.exe /online /remove-package /packagename:Package_for_KB976932~31bf3856ad364e35~x86~~6.1.1.17514

  4. 删除完成后,键入退出,然后按 Enter。

  5. 重启计算机。


对于 64 位版本的 Windows 7

  1. 单击“开始”,然后在“搜索”框中键入 cmd。

  2. 右键单击cmd.exe,并单击"以管理员角色运行"。

  3. 键入以下命令,然后按 Enter:

    dism.exe /online /remove-package /packagename:Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514

  4. 删除完成后,键入退出,然后按 Enter。

  5. 重启计算机。


确定是否安装了 Windows 7 SP1 的 Beta 版本

如果安装了 Windows 7 SP1 的 Beta 版本,则不能立即使用 Windows 随时升级进行升级。 必须卸载 Beta 版本,然后重新启动 Windows 随时升级。 若要卸载 Beta 版本,请针对你的 Windows 7 版本执行以下步骤。

注意:如果卸载了 Windows 7 SP1 的 Beta 版本,但继续收到错误,则电脑上可能有 Beta 版本的残存。 这些步骤还将清理电脑上 Beta 版本的任何残存。

对于 32 位版本的 Windows 7

  1. 单击 "开始",然后在搜索框中 键入 cmd

  2. 右键单击cmd.exe,并单击"以管理员角色运行"。

  3. 键入以下命令,然后按 Enter:

    dism.exe /online /remove-package /packagename:Package_for_KB976932~31bf3856ad364e35~x86~~6.1.1.17105

  4. 删除完成后,键入退出,然后按 Enter。

  5. 重启计算机。


对于 64 位版本的 Windows 7

  1. 单击“开始”,然后在“搜索”框中键入 cmd。

  2. 右键单击cmd.exe,并单击"以管理员角色运行"。

  3. 键入以下命令,然后按 Enter:

    dism.exe /online /remove-package /packagename:Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17105

  4. 删除完成后,键入退出,然后按 Enter。

  5. 重启计算机。




此方法是否已修复问题?

  • 检查问题是否已修复。 如果问题已修复,您不用再往下看了。 如果问题没有修复,你可以联系技术支持部门

  • 我们将感谢你的反馈。 若要提供反馈或报告此解决方案的任何问题,请对"为我修复它"博客留下 评论,或向我们发送电子邮件

更多信息

在 Windows 随时升级0x800f081,你可能会看到错误日志文件。 此错误代码指示 Windows 更新已下载 Windows 7 SP1 更新,但该更新尚未安装。 可以查看此日志以查看是否发生错误。 Windows Upgrade.log 位于以下位置:

%userprofile%\AppData\Local\Microsoft\Windows\Windows Anytime Upgrade\update.log 日志文件查看此错误,请
执行以下步骤:

  1. 单击"开始",然后单击"计算机"。

  2. 复制以下文本,单击"开始",然后将以下文本粘贴到搜索框中

    :%userprofile%\AppData\Local\Microsoft\Windows\Windows 随时升级

  3. 单击顶部搜索结果中的"Windows 随时升级"文件夹。

  4. 双击此文件夹中日志文件 Update.日志文件。

  5. 在记事本中,单击"编辑"菜单上的"查找"。

  6. 将以下文本复制并粘贴到"查找内容"文本框中,然后单击"查找"。

    0x800f081发生错误,则会看到以下日志文件

    条目:

    • 2011-11-25 15:59:19,错误 WAU DoTransmogrify 由于错误0x800f081f。

    • 2011-11-25 15:59:19,错误 WAU UpgradeSKU 失败。 正在退出。

    • 2011-11-25 15:59:19,错误 WAU Windows 随时升级'未成功。


    请注意,行中每行的起始日期和时间日志文件信息更新日志文件日期和时间。

若要解决此问题,请按照"解决方法"部分中的步骤操作。

参考

有关更多信息,请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:

2632965 Windows 随时升级错误"升级不成功。 请重试升级。"在具有多语言用户界面和 MUI (Windows 7 计算机上)

需要更多帮助?

需要更多选项?

了解订阅权益、浏览培训课程、了解如何保护设备等。

社区可帮助你提出和回答问题、提供反馈,并听取经验丰富专家的意见。

此信息是否有帮助?

你对语言质量的满意程度如何?
哪些因素影响了你的体验?
按“提交”即表示你的反馈将用于改进 Microsoft 产品和服务。 你的 IT 管理员将能够收集此数据。 隐私声明。

谢谢您的反馈!

×